"أبت" خطأ إوكسيبتيون = 2، لا يوجد مثل هذا الملف أو الدليل "لماذا لا يمكنني بناء بلدي غرادل على جينكينز؟ [java]


Answers

بالنسبة لمستخدمي أرش 64، يجب أولا تمكين مولتيليب ل باسمان ، ثم تثبيت حزم 32 بت:

sudo pacman -Syv lib32-libstdc++5 lib32-zlib
Question

لدي مشكلة صغيرة.

المشكلة:
أحاول بناء غرادل من بلدي الروبوت المشروع على جينكينز والآن أنا واقفا على هذه المشكلة لا أستطيع حلها. أثناء المبنى لدي رسالة الخطأ هذه:

:Client:mergeDebugResources
/var/lib/jenkins/workspace/LMA-Client/Client/build/exploded-aar/com.google.android.gms/play-services/3.1.59/res/drawable-hdpi/common_signin_btn_text_focus_light.9.png: 
Error: Cannot run program "/opt/android-sdk/build-tools/19.0.1/aapt": java.io.IOException: error=2, No such file or directory
:Client:mergeDebugResources FAILED

يمكنك أن تتخيل أن هذا أبت ... نعم هناك وهناك ينغ ... هناك أيضا، لذلك يجب أن يكون الخطأ في مكان آخر.

الحل؟
الآن أنا غوغلد 1-2 ساعات حولها، وتصفح على هذا الموقع الكبير وما وجدت أنه إذا كان جينكينز يعمل على نظام 64 بت، ولست بحاجة إلى تثبيت ia32-ليبس. مثل هذا:

sudo apt-get install ia32-libs

الآن حاولت ذلك، وأنا لا يمكن تثبيته:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch

لذلك حاولت تثبيت "ia32-ليبس-مولتارتش" ، ولكن مرة أخرى:

The following packages have unmet dependencies:
 ia32-libs-multiarch:i386 : Depends: libgphoto2-2:i386 but it is not going to be installed
                            Depends: libsane:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

أخيرا
حتى أخيرا إم يقف هنا ويسألني: هل هذا حقا الحل؟ ولماذا يجب تثبيت هذا الشيء؟ وكيف؟ لذا يرجى مساعدتي، وأعتقد أنني لست بعيدا عن الجواب.




لقد قمت بتثبيت ندك في مدير سك وعملت.