konnte nicht aufgelöst werden com.android.support:appcompat-v7:22 und com.android.support:recyclerview-v7:21.1.2


Answers

Um das zu schaffen, musste ich folgendes setzen:

compile ("com.android.support:support-v4:22.2.0")
compile ("com.android.support:appcompat-v7:22.2.0")
compile ("com.android.support:support-annotations:22.2.0")
compile ("com.android.support:recyclerview-v7:22.2.0")
compile ("com.android.support:design:22.2.0")

kompilieren ("com.android.support: design : 22. 2 .0")

Dokumentation sagt etwas anderes ( docs ):

com.android.support: support -design: 22. 0 .0

Question

Ich installierte ALLE Extra und SDK API 21-22 einschließlich geändert compileSdkVersion 22 zu 21 buildToolsVersion '22 .0.1 'zu 21.1.2 aber Fehler.

Und Rendering-Probleme für API 22 und ich änderte es immer noch zu <= 21.




Behebt mein Problem, indem ich diese ändere

compile 'com.android.support:cardview-v7:21.0.+'
compile 'com.android.support:recyclerview-v7:21.0.+'

zu

compile 'com.android.support:cardview-v7:23.0.+'
compile 'com.android.support:recyclerview-v7:23.0.+'

Das bedeutet, dass Ihre SDK-Zielversion der Version von cardView und recyclerView und anderen Google-Bibliotheken entsprechen sollte.

targetSdkVersion 23



Importieren Sie sie? So was:

compile 'com.android.support:appcompat-v7:21.0.3'
compile 'com.android.support:recyclerview-v7:21.0.3'



Gehen Sie zu Messages Gradle Sync und klicken Sie auf Repository installieren und Projekt synchronisieren. Dies ist die erforderliche Datei im Android SDK installieren und nach der Synchronisierung können Sie erstellen oder führen Sie Ihr Projekt.




Ich hatte eine solche Abhängigkeit in build.gradle -

compile 'com.android.support:recyclerview-v7:+'

Aber es verursacht instabile Builds. Stellen Sie sicher, dass es für Sie in Ordnung ist, und schauen Sie in Ihrem Android SDK-Manager nach der aktuellen Version der verfügbaren Support-Bibliothek und ersetzen Sie diese Abhängigkeit durch

def final RECYCLER_VIEW_VER = '23.1.1'
compile "com.android.support:recyclerview-v7:${RECYCLER_VIEW_VER}"



ich löse es

ändere 22.0.0 zu 21.0.3

dependencies {

 compile fileTree(dir: 'libs', include: ['*.jar'])

//compile 'com.android.support:appcompat-v7:22.0.0'

compile 'com.android.support:appcompat-v7:21.0.3'  }

vielleicht habe ich die com.android.support:appcompat-v7:21.0.3 herunterladen aber habe nicht die compile 'com.android.support:appcompat-v7:22.0.0'

Wenn ich SDK Manager verwende, um meine support library und das support repository aktualisieren, wird das Problem behoben.




Fehler beim Suchen: com.android.support:appcompat-v7:22.0.0

Das "Ich habe buchstäblich alles andere versucht" antworten:

Dieses Problem tritt auch auf, wenn Sie keine aktuelle Android-Supportbibliothek und kein Android-Support-Repository haben. Installieren Sie einfach mit dem SDK-Manager.