[c#] Ist .NET 4.0 mit Windows XP SP2 oder niedriger kompatibel?


Answers

  • .NET 4.0 erfordert XP SP3, Win2k3 SP2, Vista, 7 oder 2008 (R2)
  • .NET 3.5 benötigt XP SP2 oder neuer.
  • .NET 2.0 benötigt Win2K SP (3?) Oder neuer.

Übrigens wird XP SP2 nicht mehr unterstützt. (auch; alle Versionen von Win2K und Vista XP1)

Question

Ich habe hier http://www.microsoft.com/downloads/en/details.aspx?FamilyID=5765d7a8-7722-4888-a970-ac39b33fd8ab gelesen, dass zur Installation von .NET 4.0 CP (Client-Profil) muss WinXP SP3 oder über. Das ist etwas beunruhigend für mich, da viele Leute auf SP2 oder darunter sind.

Gibt es eine Möglichkeit, eine .NET 4.0-Anwendung auf einer beliebigen Version von Windows XP und höher auszuführen? (ohne sich Gedanken darüber zu machen, welche Service Packs sie haben)?

Wenn nicht, was ist mit .NET 3.5, 3.0 oder 2.0?

Meine Fragen sind die folgenden:

  1. Wie niedrig muss ich in meiner .NET Framework-Version wählen, um die Kompatibilität für WinXP SP2 oder höher sicherzustellen?

  2. Wie niedrig muss ich in meiner .NET Framework-Version wählen, um Kompatibilität für WinXP (keine Service Packs) oder höher zu gewährleisten?




Related