[python] त्रुटि आयात tensorflow मॉड्यूल के दौरान



Answers

यह ज्ञात त्रुटि है MSVCP140.DLL नामक एक फ़ाइल है, जिसे आपको TensorFlow चलाने के लिए अपने सिस्टम में आवश्यकता होगी। जांचें कि क्या यह फ़ाइल आपके %path% यदि ऐसा नहीं है, तो विजुअल स्टूडियो सी ++ डाउनलोड करें यह मुफ़्त है और आप इसे यहां डाउनलोड कर सकते हैं: https://www.visualstudio.com/vs/cplusplus

Question

मैं पायथन के साथ TensorFlow सीखने की कोशिश मेरी समस्या आयात टीएफ मॉड्यूल के साथ है यहां मेरा कॉन्फ़िगरेशन है: पायथन 3.6.1 , विंडोज 7 (MSVCP140.dll के साथ)

मैंने कमांड द्वारा TensorFlow स्थापित किया है (पावर शेल में) यह काम करता हैं।

python -m pip install --upgrade tensorflow

लेकिन जब मैं अजगर पर्यावरण चलाता हूँ और आयात करने के लिए Tensor Flow का प्रयास करें

import tensorflow as tf

मुझे त्रुटियां मिलती हैं, यह त्रुटि इससे संबंधित अन्य त्रुटियों को बढ़ाती है, लेकिन शुरुआत में मैं इसे पहले हल करना चाहता हूं

ट्रेसबैक (सबसे हाल ही में कॉल अंतिम): फ़ाइल "सी: \ उपयोगकर्ता \ जेसेक \ एपडाटा \ स्थानीय \ प्रोग्राम \ पायथन \ पायथन 36 \ lib \ site-packages \ tensorflow \ python \ pywrap_tensorflow.py", पंक्ति 18, swig_import_helper fp में, पाथनाम , विवरण = imp.find_module ('_ pywrap_tensorflow', [dirname ( फ़ाइल )]) फ़ाइल "सी: \ उपयोगकर्ता \ जेएसीएके \ एपडाटा \ स्थानीय \ प्रोग्राम \ पायथन \ पायथन 36 \ lib \ imp.py", रेखा 296, खोज_मॉड्यूल में उठाना ImportError (_ERR_MSG.format (नाम), नाम = नाम) ImportError: '_pywrap_tensorflow' नामक कोई मॉड्यूल नहीं




उपाय:-

बहुत कुछ पीड़ित नहीं है बस अपना अजगर संस्करण डाउनग्रेड करें 3.6.1 से 3.5.2 और

पुन: स्थापित करें tensorflow .. आपको पैकेज को अपग्रेड करने की आवश्यकता नहीं है।

"पीआईपी स्थापित करें tensorflow" स्वचालित रूप से नवीनतम संस्करण डाउनलोड करेंगे (शायद

1.0.1)

कदम:-

चरण 1: - कोंडा खोज अजगर

चरण 2: - कंडडा स्थापित करें अजगर = 3.5.2

चरण 3: - पीआईपी स्थापित करें tensorflow

चरण 4: - TF के रूप में आयात करें tensorflow

हॉरे !! .. यह काम करता है ..

आशा है कि आपको वही त्रुटि नहीं मिल सकती है !!




Related