[Ubuntu] Nessun pacchetto 'lua' trovato ma l'ho installato


Answers

prova sudo apt-get install liblua5.1-0-dev

Question

Sto cercando di installare Lsyncd su Ubuntu 10.4 LTS ma ottengo qualche errore:

> checking for LUA... no checking for
> LUA... no checking for LUA...
> configure: error: Package requirements
> (lua >= 5.1.3) were not met:
> 
> No package 'lua' found
> 
> Consider adjusting the PKG_CONFIG_PATH
> environment variable if you installed
> software in a non-standard prefix.
> 
> Alternatively, you may set the
> environment variables LUA_CFLAGS and
> LUA_LIBS to avoid the need to call
> pkg-config. See the pkg-config man
> page for more details.

O so che ho installato Lua :

# lua -v
Lua 5.1.4  Copyright (C) 1994-2008 Lua.org, PUC-Rio

Ho letto su diversi forum che ho bisogno di un file lua.pc ma non riesco a trovarlo. Qualcuno sa come procedere?

Grazie

EDIT: SOLVED

Mancavano alcuni pacchetti;)

apt-get install liblua5.1-0-dev liblua50-dev liblualib50-dev



Sembra che tu abbia installato Lua .

Il file lua5.1.pc mancante sarà presente nella cartella etc. Per installare gli altri pacchetti mancanti, prova il comando seguente

sudo apt-get install libreadline-dev