[swift] "ファイル" MyApp.app "は、Xcode 6 Beta 4でアプリケーションを実行しているときに、そのファイルを表示する権限がないため開けませんでした


Answers

Xcodeで次の操作を行います

ウィンドウ - >オーガナイザ - >プロジェクト - >派生データの問題 - >削除ボタン付きのアプリケーション。

私はその後、プロジェクトをきれいにして、

作品

Question

Xcode 6 Beta 4で自分のアプリケーションを実行しようとすると、エラーが発生します:

The file "MyApp.app" couldn't be opened because you don't have permission to view it.

このエラーは、私がターゲットとするシミュレータまたはデバイスに関係なく表示されます。

私が試してみました:

  • Xcodeでオーガナイザからすべての派生データを削除する
  • ドライブのアクセス許可を修復する
  • ビルドされたMyApp.appのアクセス許可を手動で昇格させる
  • コンピュータを再起動する

他の誰かがこの問題にぶつかり、解決策を見つけましたか?




私は今日の朝にこの問題に直面していて、答えのどれも私の場合特に助けにならなかった。 そして、何時間も試した後、私は問題を理解しました。

実際にストーリーボードで間違って作業している間、私は " Main.storyboard "を " .storyboard "に改名し、 " Main.storyboard "に戻して私の問題を解決しました。

解決策(私の問題として) :xcodeがファイルを読み込めず、問題を提起したためにファイルの名前を変更した可能性があります。 例えば、上記のように「 実行ファイル名」を変更した場合
考えられる問題領域:あなたが取り組んでいた最後のいくつかのファイルかもしれません。




私は私のプロジェクトで同じ問題を抱えていました。 その後、プロジェクトで使用されているサードパーティ(SQLite用のfmdb )ファイルにInfo.plistが含まれていたことが判明しました

単に私のために働いたInfo.plistファイルを削除するだけです!




プロジェクトターゲットから設定をビルドし、ビルドオプションに移動し、「C / C ++ / Objective-C用コンパイラ」の値をデフォルトコンパイラに変更します。 私はXcode 6 beta 4を使用しています。




プロジェクトのInfo.plistに問題がありました。 Xcode 6 beta 4に同じ名前の新しいプロジェクトを作成し、実際のプロジェクトのInfo.plistを新しいものに置き換えました。 プロジェクトは、その後、構築し、正常に実行されました。

diffを見て、plistが何とか遊び場のplistと混ざり合ったように見える。 バンドル識別子は "com.apple.dt.playground.iOS-18300-13"で、実行可能ファイル名とバンドル名は "iOS"で、他の奇妙なものもありました。

これは誰でも参照のために完全なdiffです:

        <key>CFBundleDevelopmentRegion</key>
        <string>en</string>
        <key>CFBundleExecutable</key>
-       <string>iOS</string>
+       <string>${EXECUTABLE_NAME}</string>
        <key>CFBundleIdentifier</key>
-       <string>com.apple.dt.playground.iOS-18300-13</string>
+       <string>com.myCompany.${PRODUCT_NAME:rfc1034identifier}</string>
        <key>CFBundleInfoDictionaryVersion</key>
        <string>6.0</string>
        <key>CFBundleName</key>
-       <string>iOS</string>
+       <string>${PRODUCT_NAME}</string>
        <key>CFBundlePackageType</key>
-       <string>AAPL</string>
+       <string>APPL</string>
        <key>CFBundleShortVersionString</key>
        <string>1.0</string>
-       <key>CFBundleSupportedPlatforms</key>
-       <array>
-               <string>iPhoneSimulator</string>
-       </array>
+       <key>CFBundleSignature</key>
+       <string>????</string>
        <key>CFBundleVersion</key>
        <string>1</string>
-       <key>DTPlatformName</key>
-       <string>iphonesimulator</string>
-       <key>DTSDKName</key>
-       <string>iphonesimulator8.0</string>
-       <key>LSBackgroundOnly</key>
-       <true/>
        <key>LSRequiresIPhoneOS</key>
        <true/>
+       <key>UIMainStoryboardFile</key>
+       <string>Main</string>
        <key>UIRequiredDeviceCapabilities</key>
        <array>
                <string>armv7</string>
        </array>
+       <key>UISupportedInterfaceOrientations</key>
+       <array>
+               <string>UIInterfaceOrientationPortrait</string>
+               <string>UIInterfaceOrientationLandscapeLeft</string>
+               <string>UIInterfaceOrientationLandscapeRight</string>
+       </array>
 </dict>
 </plist>



それを解決したのは、 Build Active Architecture OnlyNoからYesに設定することでした。




私は更新するために食器棚から出ている私の古いプロジェクトのいくつかでこのエラーが発生しました。 古いコードでXcode 6を使用すると、何らかの理由でこれが発生するようです。

私はこれを次のようにすべてのプロジェクトで修正しました:

  1. 派生データの削除
  2. 製品内:きれいにする
  3. プロジェクトターゲットのビルド設定に行き、ビルドオプションに行き、 "C / C ++ / Objective-Cのコンパイラ "の値を「 デフォルトコンパイラ 」に変更します。



ビルドオプションでLLVM 6.0にコンパイラを変更するだけで十分であることが判明しました(xcode 6.1)




製品 - >クリーン(コマンドシフトK)が私のために修正しました




私はこの同様の問題を抱えていた。 どういうわけかキー実行可能ファイルの私の価値が混乱してしまった。 $ {EXECUTABLE_NAME}に戻してください(プロジェクト>情報の下にあります)。 私のために働いた!




私は最近、Xcode 6.0.1で古いプロジェクト(最初はXcode 4.xで作成)を実行して同じ問題を抱えています。

私は、 Building SettingArchitecturesをデフォルト値に変更することで問題を解決しました。これは " 標準アーキテクチャ(armv7、arm64) "です。

これは似たような問題を抱えている人を助けることができると思う




1)最初にビルドオプションを実行します。

2)次に、 "C / C ++ / Objective-Cのコンパイラ"の値をデフォルトのコンパイラに変更しました。

きれいで働いています:-)




問題が関連しているかどうかは分かりませんが、私のような髪を引っ張ってくれる人にとっては解決策になるかもしれません。

私の場合、私は多くの目標を持ったプロジェクトを持っています。 各ターゲットは、 Cocoa Touch Static Libraryとターゲット、 Applicationsであるその基本プロジェクトのカスタマイズです。 mainファイルがライブラリコンパイルに追加されていても各ターゲットに追加されていなくても、そのエラーメッセージが表示されます。 だから私は何をしましたか? 手動でCompile SourcesファイルをCompile Sourcesセクションとbingoの各ターゲットに追加しました。




ダウンロードしたサンプルコードについても同様の問題(xCode 6.2)がありました。 Default in Info.plist Executable NameDefault in Info.plist設定しようとしましたが、これはうまくいきませんでした。

代わりに、プロジェクトのUnsupported Compiler(com.apple.compilers.llvmgcc42)の代わりに、C / C ++ / Objective-Cの コンパイラデフォルトコンパイラ(Apple LLVM 6.0)に変更してください。




私にとって、シンプルな製品 - >クリーンは素晴らしい仕事をした




Related