[node.js] Конфликты зависимостей Grunt в Bootstrap


Answers

Я столкнулся с той же проблемой. Выполнение следующего:

bower install bootstrap
cd bower_components/bootstrap
npm install

В результате:

npm ERR! peerinvalid The package grunt does not satisfy 
   its siblings' peerDependencies requirements!

Я решил это, сначала удалив grunt из каталога начальной загрузки

npm uninstall grunt

Затем я установил grunt 0.4.2

npm install grunt@0.4.2

На этот раз npm install работал просто отлично

npm install
Question

Я загрузил исходные файлы Bootstrap с официального сайта, и я получаю конфликты зависимости при установке проекта с использованием npm узла. У меня есть grunt 0.4.3 установленный на моей машине, но для некоторых зависимостей bootstrap требуется 0.4.0 и 0.4.1 .

Команда npm install -g grunt-cli выполняется без каких-либо проблем. Вот журнал, который я получаю после выполнения команды npm install :

npm ERR! peerinvalid The package grunt does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer grunt-banner@0.2.1 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-contrib-clean@0.5.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-concat@0.3.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-connect@0.6.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-copy@0.5.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-csslint@0.2.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-cssmin@0.7.0 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-contrib-jade@0.9.1 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-contrib-jshint@0.8.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-less@0.9.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-qunit@0.4.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-uglify@0.3.3 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-watch@0.5.3 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-csscomb@2.0.1 wants grunt@~0.4.2
npm ERR! peerinvalid Peer grunt-exec@0.4.3 wants grunt@~0.4
npm ERR! peerinvalid Peer grunt-html-validation@0.1.13 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-jekyll@0.4.1 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-jscs-checker@0.3.2 wants grunt@0.4.2
npm ERR! peerinvalid Peer grunt-saucelabs@5.0.1 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-sed@0.1.1 wants grunt@~0.4

npm ERR! System Windows_NT 6.1.7601
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install"
npm ERR! cwd C:\Users\\Desktop\bootstrap-3.1.1
npm ERR! node -v v0.10.15
npm ERR! npm -v 1.3.5
npm ERR! code EPEERINVALID
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     C:\Users\\Desktop\bootstrap-3.1.1\npm-debug.log
npm ERR! not ok code 0

Я следую these шагам установки.

Как я могу установить этот проект без ошибок?




Попробуйте npm cache clean а затем снова попробуйте установить команду.




У вас может быть установлен Grunt 0.4.3 глобально, но ничто не установлено локально.

  1. Запустите $ grunt --version чтобы найти версию, в которой вы находитесь (не необходимый шаг).
  2. Создайте файл package.json в корне папки, на которой вы хотите включить свой проект.

    {
        "name" : "MyProject",
        "version" : "0.1.0",
        "author" : "My name",
        "private" : true,
    
        "devDependencies" : {
            "grunt" : "~0.4.2"
        }
    }
    
  3. Запустите $ npm install в корневой папке проекта.

Готово!

--- ОБНОВИТЬ ---

Вы можете использовать Bower для установки Bootstrap для вас. Это делает громоздкие установки легкими. Руководство Bootstrap's Getting Started советует использовать его!

$ bower install bootstrap

Вот сообщение в блоге, которое может иметь отношение к вам: использование Grunt + Bower с Laravel и Bootstrap

Или вы всегда можете позволить Grunt управлять установкой Bootstrap и поддерживать ее как зависимость ... Есть несколько плагинов, которые делают тяжелую работу.






Related