[android] Как удалить ошибку «Требуется уровень API»?



0 Answers

Примечание: принятый answer устарел.

В Android Studio 3.0 Beta 7 вам больше не нужна аннотация @TargetApi .
Кажется, что проверка ворса теперь умнее.

Так что этого достаточно:

public void yourMethod() {
    if (android.os.Build.VERSION.SDK_INT >= Build.VERSION_CODES.ICE_CREAM_SANDWICH) {
        getActionBar().setHomeButtonEnabled(false);
    }
}
Question

Я получаю эту ошибку в Eclipse: для вызова требуется уровень API 14 (текущий минимум 8): android.app.ActionBar # setHomeButtonEnabled

Это код:

if(android.os.Build.VERSION.SDK_INT>=14) {
    getActionBar().setHomeButtonEnabled(false);
}

В манифесте:

<uses-sdk android:minSdkVersion="8" android:targetSdkVersion="14" />

Как удалить эту ошибку?




Related