插件太舊,請更新到更新的版本,或將ANDROID_DAILY_OVERRIDE環境變量設置為



Answers

解決方案(更新時間:2016年5月24日):更改build.gradle(項目)

buildscript {
repositories {
    jcenter()
}
dependencies {
    classpath 'com.android.tools.build:gradle:X.X.X-lastVersionGradle'
    classpath 'com.google.gms:google-services:X.X.X-lastVersionGServices' // If use google-services

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}

https://bintray.com/android/android-tools/com.android.tools.build.gradle/view :例如: 2.1.0

X.X.X-lastVersionGServices :例如: 3.0.0 (支持Firebase Analytics)

注意:如果您使用google-services插件必須是相同的版本(如果有的話)

警告!! - > 2.2.0-alpha拋出不支持的major.minor版本52.0,如果你不使用java JDK 8u91和NetBeans 8.1

Question

今天我剛剛從Android SDK中導入了一個示例應用程序作為我項目中的模塊(分析),當我嘗試同步它時突然發生了這個gradle錯誤: Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE envrinment variable to...

這是我的應用程序gradle文件:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 22
    buildToolsVersion "22.0.0"
    defaultConfig {
        applicationId "xxx.xxxxxx.xxxxx"
        versionCode 1
        versionName '1'
        minSdkVersion 9
        targetSdkVersion 22
        versionCode 1
        versionName '1'
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }


    dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:appcompat-v7:22.0.0'
    compile 'com.google.android.gms:play-services:6.5.87'
    compile 'com.android.support:recyclerview-v7:21.0.0'
    compile 'com.android.support:cardview-v7:21.0.0'
    compile 'com.facebook.android:facebook-android-sdk:3.21.1'
    testCompile 'junit:junit:4.12'
    compile project(':volley')
}

你有什麼想法可能是原因(我使用插件版本1.1.0-rc1和gradle版本2.2和Android Studio版本1.1.0)?

編輯:

這是我的頂級build.gradle

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:1.1.0-rc1'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
    }
}



以防萬一有人在為此苦苦掙扎,在我的情況下,我使用的是Gradle 1.4 beta 1,我需要保留它。 因此,為了使Android Studio能夠運行到終端並運行此操作:

launchctl setenv ANDROID_DAILY_OVERRIDE <your-value-on-error-message>

重新啟動Android Studio,該項目將重新生成。

榮譽更新2在這裡: https://emmanuelbernard.com/blog/2012/05/09/setting-global-variables-intellij/ : https://emmanuelbernard.com/blog/2012/05/09/setting-global-variables-intellij/




您應該升級Gradle的版本。 例如:com.android.build.gradle 1.3.0

當更改Gradle的版本時會發生此問題。







將環境變量ANDROID_DAILY_OVERRIDE設置為相同的值示例 - b9471da4f76e0d1a88d41a072922b1e0c257745c

這對我有用。




我有一種方法可以最終解決這個問題1.檢查頂部build.gradle中的calsspath,例如我的類路徑是'com.android.tools.build:gradle:2.1.0-alpha3',然後轉到https://jcenter.bintray.com/com/android/tools/build/gradle/找到一個比你的更新的版本,在這裡我選擇2.1.0-beta3改變classpath到下面,然後啟動構建。 classpath'com.android.tools.build:gradle:2.1.0-beta3'




在過去的幾個月中,我使用了Android Studio的“預覽版”。 我試著回到軟件更新的“穩定”版本,但這還不夠,我得到了這個著名的錯誤。

卸載我的Android Studio 2.2.preview並安裝最新的穩定版Android Studio(2.1)為我修復了:)




用類似這樣的含糊不清的東西替換你的班級路徑。 它的解決方案,它的工作原理,但它可能不是一個好的解決方案。

classpath'com.android.tools.build:gradle:+'

最好的方法是用最新版本的Gradle替換+




Links