[java] Android需要編譯器符合性級別5.0或6.0。 取而代之的是“1.7”。 請使用Android工具>修復項目屬性


Answers

  1. 轉到項目文件夾並右鍵單擊它 - > properties ->檢查只讀框並單擊確定

  2. 右鍵單擊您的項目並選擇"Android Tools -> Fix Project Properties"

  3. 右鍵單擊項目並選擇"Properties -> Java Compiler" ,選中"Enable project specific settings"並從“Compiler compliance settings”選擇框中選擇1.5或1.6。 (為了以防萬一,請逐個嘗試所有關卡)

  4. Window -> Preferences -> Java -> Compiler ,將Compiler compliance level設置為1.6或1.5。

希望它能解決問題。

Question

有沒有人有類似的問題,我導入android項目,我得到的錯誤

[2011-10-03 17:20:09 - Screen] Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.
[2011-10-03 17:21:55 - App] Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.
[2011-10-03 17:21:59 - App] Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.

我有錯誤刪除所有@Override上面的函數。 我有Windows 7 x64,jvm7 x64。 有沒有人知道什麼是錯的?(我完成了Android工具 - >修復項目屬性,但沒有幫助)




我同意BMSAndroidDroid和Flo-Scheild-Bobby。 我正在做一個名為DailyQuote的教程,並使用了科爾多瓦圖書館。 然後,我將操作系統從Windows更改為Ubuntu,並嘗試將項目導入到Eclipse中(我正在使用Eclipse Juno 64位,在Ubuntu 12.04 64-bit ,Oracle JDK 7上)。我還安裝了Ubuntu 32位libs-沒有64和32位的問題),並得到了同樣的問題。

按照Flo-Scheild-Bobby的建議,打開configure configure build path並添加之前添加的jar。 然後刪除舊的jar鏈接和多數民眾贊成它。




在我的情況下,從openjdk7切換到openjdk6幫助。 之後我將合規級別更改為1.6,並且所有編譯都正常。




以下為我工作

Enable project-specific settings and set the compliance level to 1.6

你怎麼能這樣做?

在你的Eclipse Package Explorer點擊你的項目並選擇properties 。 屬性窗口將打開。 在窗口的左側面板上選擇Java Compiler 。 現在Enable project specific settings並將Complier compliance level設置為1.6 。 選擇Apply ,然後OK




我建議你檢查一下jar文件是否包含在你的項目中。 有可能在沒有jar文件的情況下,項目不會被編譯




Project - > Clean...修理它給我。

我的日食已停止工作,所以我清理workspace目錄,並在我導入項目時運行eclipse後,我有這個問題。 這裡建議的其他解決方案不起作用。




Related



Tags

java java   android android