node.js - mac - npm install windows




لماذا يقول npm install لدي تبعيات غير ملباة؟ (11)

- تثبيت تثبيت devDependencies بشكل متكرر (وتشغيله إلى الأبد ..) كيف يمكن أن يساعد على حل الاختلافات الإصدار؟

يمكنك محاولة إزالة مجلد node_moduls ، ثم تنظيف ذاكرة التخزين المؤقت npm ثم تشغيل 'npm i' مرة أخرى

لدي حزمة عقدة. عندما أقوم بتشغيل npm install من جذر الحزمة ، يقوم بتثبيت مجموعة من الأشياء ، ولكن بعد ذلك يقوم بطباعة عدة رسائل خطأ تبدو كالتالي:

npm WARN unAR dependency / Users / seanmackesey / google_drive / code / explore / generator / node_modules / findup-sync / node_modules / glob يتطلب [email protected]'~1.2.0 'ولكن سيتم تحميل

يجب أن أكون حائرة حول ما يفعله بالضبط npm install . إذا اكتشفت تبعية ، ألا يجب تثبيتها؟ تحت أي ظروف تعطيني رسائل خطأ كهذه ، وكيف يمكنني حل التبعيات؟


أصلحت المشكلة باستخدام خطوط الأوامر هذه

  • $ rm -rf node_modules/
  • $ sudo npm update -g npm
  • $ npm install

تم التنفيذ!


الإجابات المذكورة أعلاه لم تساعدني بشكل كامل حتى بعد node_modules دليل node_modules .

أدناه ساعدني الأمر أخيراً:

npm config set registry http://registry.npmjs.org/

لاحظ أن هذا يسحب الوحدات النمطية عقدة عبر اتصال HTTP غير آمن.

Src: https://.com/a/13119867/4082503



حدث لي عندما ذهبت واي فاي أسفل خلال npm install . إزالة node_modules وإعادة تشغيل npm install ثابت عليه.


في حالتي ، التحديث من npm حلها.

sudo npm install -g npm

لقد واجهت مشكلة مشابهة أثناء تثبيت تطبيق React Native Native. لم أكن متأكدًا من أي دليل /node_modules كان من المفترض إزالته بعد قراءة الإجابات هنا. أنا في النهاية ركض للتو

npm update -g

وتمكنت من تثبيت الحزمة بعد ذلك.


لقد واجهت هذه المشكلة عندما كنت أقوم بتثبيت حزم رد فعل وهذا يعمل بالنسبة لي: npm install --save <package causing this error>


هذا حل لي:

  1. قم بتصحيح أرقام الإصدارات في package.json ، وفقًا للأخطاء ؛
  2. إزالة node_modules ( rm -rf node_modules
  3. أعد تشغيل npm install .

كرر هذه الخطوات حتى لا يكون هناك المزيد من الأخطاء.


يمكن أن يساعد تحسين NPM إلى الإصدار الأحدث بشكل كبير في هذا الأمر. جواب dule أعلاه هو الحق في القول أن إدارة التبعية مكسورة بعض الشيء ، ولكن يبدو أن هذا هو أساسا للإصدارات القديمة من npm.

npm list بجميع node_modules المثبتة. عندما قمت بالترقية من الإصدار 1.4.2 إلى الإصدار 2.7.4 ، لم يعد يتم ذكر العديد من الوحدات التي تم وضع علامة عليها مسبقًا مع WARN unmet dependency .

لتحديث npm ، يجب عليك كتابة npm install -g npm على MacOSX أو Linux. على نظام التشغيل Windows ، وجدت أن إعادة تنزيل أداة تثبيت nodejs وإعادة تشغيلها كانت طريقة أكثر فعالية لتحديث npm.


التحديث إلى 4.0.0

التحديث إلى 4 سهلاً مثل تحديث تبعياتك الزاويّة إلى الإصدار الأحدث ، والتحقق مجددًا إذا كنت تريد صورًا متحركة. هذا سوف يعمل لمعظم حالات الاستخدام.

على نظام التشغيل Linux / Mac:

npm install @angular/{common,compiler,compiler-cli,core,forms,http,platform-browser,platform-browser-dynamic,platform-server,router,animations}@latest [email protected] --save 

على نظام التشغيل Windows:

npm install @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] [email protected] --save

ثم قم بتشغيل أي خدمة ngm أو الأمر start npm الذي تستخدمه عادة ، ويجب أن يعمل كل شيء.

إذا كنت تعتمد على الرسوم المتحركة ، NgModule الجديد من @angular/platform-browser/animations في جذر NgModule . بدون ذلك ، سيتم ترجمة وتشغيل التعليمة البرمجية ، ولكن ستؤدي الرسوم المتحركة إلى حدوث خطأ. تم إيقاف الاستيراد من @angular/core ، باستخدام الواردات من الحزمة الجديدة

import { trigger, state, style, transition, animate } from '@angular/animations';.






npm