visual-studio - ultimate - visual studio 2017 تحميل




لا يتم تحميل حزم بعد تثبيت visual studio 2015 RTM (8)

الشيء الوحيد الذي نجح بالنسبة لي هو إصلاح أدوات بيانات SQL Server (اذهب إلى إلغاء تثبيت البرامج وحدد تغيير / إصلاح)

المشكلة

كان لدي Visual Studio 2015 RC تثبيت وتثبيت Visual Studio 2015 RTM فوقه. لم أتمكن من العثور على أي شيء على الإنترنت قال إنه لا يمكنك القيام بذلك. لا أعرف ما إذا كان هذا الأمر ذا صلة بالمشكلة.

لسوء الحظ ، عندما بدأت تشغيل VS 2015 RTM لأول مرة بعد إعادة تشغيله ، ظهرت مربعات الرسائل باستخدام:

"لم يتم تحميل حزمة" Microsoft.VisualStudio.Editor.Implementation.EditorPackage "بشكل صحيح"

أيضا:

  • XamarinShellPackage
  • TestWindowPackage
  • NuGetPackage
  • ErrorListPackage

كيف يمكنني حل هذا الخطأ؟

سجلات

قال للنظر في ActivityLog.xml . لم أتمكن من العثور على Microsoft.VisualStudio.Editor.Implementation.EditorPackage.

لكن بالنسبة إلى XamarinShellPackage ، قالت:

<entry>
    <record>339</record>
    <time>2015/07/21 13:01:54.011</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>SetSite failed for package [XamarinShellPackage]</description>
    <guid>{2D510815-1C4E-4210-BD82-3D9D2C56C140}</guid>
    <hr>80070057 - E_INVALIDARG</hr>
    <errorinfo>'providers' cannot contain a null (Nothing in Visual Basic) element.
Parameter name: providers</errorinfo>
  </entry>
  <entry>
    <record>340</record>
    <time>2015/07/21 13:01:54.013</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>End package load [XamarinShellPackage]</description>
    <guid>{2D510815-1C4E-4210-BD82-3D9D2C56C140}</guid>
    <hr>80070057 - E_INVALIDARG</hr>
    <errorinfo>'providers' cannot contain a null (Nothing in Visual Basic) element.
Parameter name: providers</errorinfo>
  </entry>

من أجل TestWindowPackage :

<entry>
   <record>394</record>
   <time>2015/07/21 13:02:02.751</time>
   <type>Error</type>
   <source>TestWindowPackage</source>
   <description>TestWindowPackage.Initialize failed with exception:
&#x000D;&#x000A;&#x000D;&#x000A;System.NullReferenceException:
Object reference not set to an instance of an object.&#x000D;&#x000A;
at Microsoft.VisualStudio.TestWindow.VsHost.TestWindowPackage.Initialize()
&#x000D;&#x000A;&#x000D;&#x000A;PackageContainer loaded: False &#x000D;&#x000A;</description>
</entry>
<entry>
   <record>395</record>
   <time>2015/07/21 13:02:02.752</time>
   <type>Error</type>
   <source>VisualStudio</source>
   <description>SetSite failed for package [TestWindowPackage]</description>
   <guid>{BFC24BF4-B994-4757-BCDC-1D5D2768BF29}</guid>
   <hr>80004003 - E_POINTER</hr>
   <errorinfo>Object reference not set to an instance of an object.</errorinfo>
</entry>

بالنسبة لـ NuGetPackage :

 <entry>
    <record>405</record>
    <time>2015/07/21 13:02:04.096</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>SetSite failed for package [NuGetPackage]</description>
    <guid>{5FCC8577-4FEB-4D04-AD72-D6C629B083CC}</guid>
    <hr>80004003 - E_POINTER</hr>
    <errorinfo>Object reference not set to an instance of an object.</errorinfo>
  </entry>
  <entry>
    <record>406</record>
    <time>2015/07/21 13:02:04.096</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>End package load [NuGetPackage]</description>
    <guid>{5FCC8577-4FEB-4D04-AD72-D6C629B083CC}</guid>
    <hr>80004003 - E_POINTER</hr>
    <errorinfo>Object reference not set to an instance of an object.</errorinfo>
  </entry>

ل ErrorListPackage قال:

<entry>
    <record>409</record>
    <time>2015/07/21 13:02:04.624</time>
    <type>Information</type>
    <source>VisualStudio</source>
    <description>Begin package load [ErrorListPackage]</description>
    <guid>{4A9B7E50-AA16-11D0-A8C5-00A0C921A4D2}</guid>
  </entry>
  <entry>
    <record>410</record>
    <time>2015/07/21 13:02:04.629</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>SetSite failed for package [ErrorListPackage]</description>
    <guid>{4A9B7E50-AA16-11D0-A8C5-00A0C921A4D2}</guid>
    <hr>80004003 - E_POINTER</hr>
    <errorinfo>Object reference not set to an instance of an object.</errorinfo>
  </entry>

ما حاولت حتى الآن

  • في الأدوات -> الإضافات والتحديثات ، حاولت إزالة تثبيت الإضافات وإعادة تثبيتها. ولكن عندما أقوم بالنقر فوق عنصر القائمة "الامتدادات والتحديثات" ، أحصل على استثناء "مرجع كائن لم يتم تعيينه"؟ لذلك لا يمكنني تجربة هذا الخيار.

لذلك ... أي اقتراحات هناك؟

تحديثات على السؤال

التحديث الأول

لقد حاولت فقط تحميل مشروع و ... هناك خطأ ما. لا يمكن تحميل مجموعة من الحزم مثل: "CSharpPackage ، و IntegrationPackage ، و MigrationPackage ، و FileIndicatorPackage ، إلخ ..." ومستكشف الحلول فارغ تمامًا! ما الذي يجري؟

التحديث الثاني

هكذا تبدو البرامج والميزات الخاصة بي:

التحديث الثالث

لقد قمت بإزالة وإزالة بقدر ما تجرأت.

  • إزالة كل شيء في AppData \ Roaming \ Microsoft \ VisualStudio \ 14.0
  • إزالة كل شيء في AppData \ Local \ VisualStudio \ 14.0
  • إلغاء تثبيت Visual Studio 2015 عبر البرامج والميزات (فوق لقطة الشاشة)
  • إزالة المجلد Visual Studio Secondary Installer في المجلد Program Files تمامًا
  • إزالة كل ما له علاقة بـ Visual Studio 14.0 من ملفات البرامج

لا أريد أن أفشل تثبيت Visual Studio 2013. لا يزال يتعذر على VS2015 تحميل الحزم أعلاه! لذلك إذا كان لدى أي شخص مزيد من المعلومات حول البرامج التي يمكن إلغاء تثبيتها بالضبط من الصورة أعلاه ، سأكون سعيدًا جدًا.

التحديث الرابع

الخطوات الواجب اتخاذها (المحدثة من التحديث 3)

  • إزالة كل شيء في AppData \ Roaming \ Microsoft \ VisualStudio \ 14.0
  • إزالة كل شيء في AppData \ Local \ VisualStudio \ 14.0
  • إزالة كل شيء يتعلق Visual Studio 14.0 من ProgramData
  • إلغاء تثبيت Visual Studio 2015 عبر البرامج والميزات (فوق لقطة الشاشة)
  • فعلت كل شيء يقول هذا المقال: https://support.microsoft.com/nl-nl/kb/3016536
  • إزالة المجلد Visual Studio Secondary Installer في المجلد Program Files تمامًا
  • إزالة أي شيء له علاقة بـ Visual Studio 14.0 من ملفات البرامج بشكل أساسي. أي شيء يتبقى من إلغاء التثبيت في البرامج والميزات.
  • إلغاء تثبيت Microsoft Visual C ++ القابلة لإعادة التوزيع (x86) - 14.0.xxx أيضًا
  • إلغاء تثبيت بلدي الاشياء Xamarin أيضا
  • آمل ألا أنسى أي شيء ، لكن بيت القصيد هو التخلص تمامًا من أي شيء مرئي 2015 studio.
  • أعد تثبيت visual studio 2015 RTM وسيعمل الآن. لا بد لي من تثبيت بعض الأشياء من طرف ثالث مرة أخرى ، ولكن على الأقل يعمل!

بسبب الامتدادات في VS2015 ، اضطررت إلى إعادة تسمية: C: \ Users \\ AppData \ Local \ Microsoft \ VisualStudio \ 14.0

بمجرد إعادة تسميتها ، فتحت VS2015 وتلقيت المزيد من هذه الأخطاء ولكن تمت إعادة إنشاء المجلد 14.0.

أغلقت VS2015 وقمت بنسخ المجلدات "الإمتدادات والقوالب" من المجلد الأصلي / المعاد تسميته إلى المجلد الجديد.

إعادة فتح VS2015 وكل شيء يعمل مرة أخرى.

تحديث: 9/24/2015 12:17 م: توقفت عن العمل مرة أخرى. حاولت جميع الخيارات في هذا المنصب. لقد وجدت وظيفة أخرى ، ويبدو أن هذا قد نجح:

تشغيل: devenv / clearcache devenv / updateconfiguration


على غرار حلTom Clelford ، ولكن بالإضافة إلى حذف كل شيء في:

C: \ المستخدمين {اسم المستخدم} \ APPDATA \ المحلية \ مايكروسوفت \ VisualStudio \ 14.0

اضطررت إلى حذف كل شيء في

C: \ المستخدمين {اسم المستخدم} \ APPDATA \ المحلية \ مايكروسوفت \ VisualStudio \ vshub

لم أضطر إلى لمس أي شيء في مجلد "التجوال" ، لكن قد يختلف ذلك من مستخدم لآخر.


عند بدء تشغيل Microsoft Visual Studio Enterprise 15 Preview (الإصدار 15.0.25123) ، حدث الخطأ نفسه:

<entry>
    <record>27</record>
    <time>2016/05/02 12:26:57.451</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>SetSite failed for package [Image Service Package]Source:
 ..
    <guid>{1491E936-6FFE-474E-8371-30E5920D8FDD}</guid>
    <hr>80131522</hr>
    <errorinfo></errorinfo>
</entry>

أحاول تغيير مفتاح التسجيل ، لكنه لم ينجح.

أنا حقًا لم أعمل أبداً ، قم بإلغاء تثبيت الإصدار السابق ، لكن جربه وعملت!

Uninstall Microsoft Visual Studio Ultimate 2015 Preview, (Version 14.0.23310)

عملت معي :) )

أركض كل النصائح أعلاه كذلك. لا أعرف إذا كان هذا ضروريًا أم لا. تحية ودية.


كان أيضا في Visual Studio 2015 RC.

مشكلة في استخدام "ملف-> جديد-> مشروع .." رمي استثناء

تابعت إجابة Shittu Olugbenga ، 10 أغسطس عن طريق حذف محتوى المجلد: "C: \ Users \\ AppData \ Local \ Microsoft \ VisualStudio \ 14.0 \ ComponentModelCache".

إعادة تشغيل Visual Studio وأنها عملت. :) Tnx.


لدي استوديو مرئي 2012 و 2013 و 2015 مثبت على الجهاز. بعد تثبيت التحديث الخامس لبرنامج Visual Studio 2013 ، بدأت في الحصول على خطأ "لم يتم تحميل الحزمة بشكل صحيح" في VS 2013.

كل ما فعلته للحصول على العمل هو اتباع هذه الخطوة:

  1. أغلق جميع مثيلات Visual Studio
  2. احذف كل شيء في هذا المجلد C:\Users\%username%\AppData\Local\Microsoft\VisualStudio\12.0\ComponentModelCache
  3. أعد تشغيل Visual Studio

على الرغم من أنني لم أحاول هذا لعام 2015 ، أعتقد أن هذا يجب أن يحل المشكلة أيضًا. للقيام بذلك في Visual Studio 2015 ، يجب تغيير 12.0 إلى 14.0

تحديث

بدلاً من حذف كل شيء في المجلد (كما هو مقترح في الخطوة 2 أعلاه) ، أصبح إعادة تسمية المجلد أكثر أمانًا والسماح لبرنامج Visual Studio بإنشاء مجلد جديد. في بعض الأحيان ، قد تضطر إلى نسخ بعض الشيء من المجلد القديم.

آمل أن يكون هذا مزيد من المساعدة لكم جميعا.


مزيد من الحل البديل لـ Visual Studio 2015 Update 1

  1. افتح c:\Users\{User_Name}\AppData\Local\Microsoft\VisualStudio\14.0\devenv.exe.config
  2. تغيير إعادة توجيه الربط لـ System.Collections.Immutable ، يجب أن يكون 1.1.37.0 (وليس 1.1.36.0 ).

يجب أن تبدو إعادة التوجيه كالتالي:

    <dependentAssembly>
        <assemblyIdentity name="System.Collections.Immutable" publicKeyToken="b03f5f7f11d50a3a" culture="neutral"/>
        <bindingRedirect oldVersion="1.0.27.0-1.1.65535.65535" newVersion="1.1.37.0"/>
    </dependentAssembly>

خطأ من ActivityLog.xml :

فشل SetSite للحزمة [CSharpPackage] [تعذر تحميل الملف أو التجميع 'System.Collections.Immutable ، الإصدار = 1.1.36.0 ، الثقافة = محايدة ، PublicKeyToken = b03f5f7f11d50a3a' أو أحد تبعياتها. تعريف بيان التجميع الموجود لا يتطابق مع مرجع التجميع. (استثناء من HRESULT: 0x80131040)]: {في Microsoft.VisualStudio.LanguageServices.Implementation.LanguageService.AbstractPackage ` .Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite (IServiceProvider sp)}

يمكنك قراءة المزيد حول كيفية استكشاف هذه المشكلات في منشور المدونة الخاص بي. كيفية استعادة Visual Studio 2015 بعد التحديث 1


واجهت نفس المشكلة بعد الترقية إلى Resharper 2016.2 جديدة. لقد أصلحت المشكلة عن طريق تعليق الشاحن في الاستوديو المرئي (أدوات> خيارات> إعادة الشحن> تعليق)







visual-studio-2015