javascript - يتطلب جافا سكريبت Bootstrap إصدار jQuery 1.9.1 أو أعلى ، ولكنه أقل من الإصدار 3




twitter-bootstrap-3 (5)

أحدث إصدار حالي من Bootstrap (3.3.7) يدعم الآن jQuery 3+ ، وفقًا لتعليق المطور هنا https://github.com/twbs/bootstrap/issues/16834 .

المقدمة

أنا أعمل مع إطار bootstrap. أعمل حاليًا على "علامات بدء التشغيل" (إخفاء / إظهار) .أستخدم الإصدار 3 من bootstrap والإصدار 3.0.2 من jquery.

مشكلة

لا تعمل علامات التبويب الخاصة بي ، إلا إذا قمت بتحميل jquery من الإصدار الذي يقل عن 1.6. ولكن أياكس تسبب مشكلة في jquery أقل من 1.6. وحدة تحكم Chrome تعطيني هذا الخطأ.

bootstrap.min.js: 6 خطأ لم يسبق له مثيل: يتطلب JavaScript في Bootstrap إصدار jQuery 1.9.1 أو أعلى ، ولكنه أقل من الإصدار 3

جربت تقنيات ارتجالية مختلفة ولكن لم أستطع تنفيذها بشكل صحيح

أنا عالق هنا لمدة يومين ، إذا كان لدى أي شخص أي فكرة أو أي إشارة ، يرجى المساعدة. شكرا على وقتك.


إذا كنت تستخدم Bower لإدارة حزم javascript الخاصة بك ، لاستبعاد jquery 3.0 ، فيجب عليك تحديد إصدار jquery مثل:

"jquery": "^2.2"

في bower.json الخاص بك.

يحتوي bower.json الخاص bower.json jquery-ui على السطر التالي:

"jquery": ">=1.6"

بسبب ذلك ، يقوم Bower بتثبيت أحدث إصدار من jQuery ، والذي يسبب مشكلتك.

لاحظ أنه تم إصدار jQuery 3.0 اعتبارًا من 9 يونيو 2016.


حاليًا لا يدعم Bootstrap 3.x jQuery 3.x كما هو موضح هنا: https://github.com/twbs/bootstrap/issues/16834

سبب المشكلة هو:

jQuery 3 أكثر صرامة من jQuery 2. يشبه XHTML و HTML. يتم الحفاظ على التوافق مع الإصدارات السابقة ولا يبدو الرمز وكأنه فوضى. إذا لم أكن مخطئًا ، فكل ما عليك فعله هو استبدال وظائف show () وإخفاء () بـ .css ("عرض" ، "") أو addClass ("مخفي") وإصلاح محدد في alert.js (QUnit فشل في هذا السطر لأن $ ('#') غير صالح في jQuery 3)

تم إصلاحه في إصدار Bootstrap 3.3.7: https://github.com/twbs/bootstrap/issues/16834#issuecomment-225039913


لذلك كان لدي الإصدار الجديد من Bootstrap ، لكن لسبب ما ، كان الإصدار min لا يزال الإصدار القديم الذي لم يدعم JQuery 3. لقد قمت بإزالة Bootstrap minified JS ثم أعدت تذكير Bootstrap.js الجديد ونشرته وانتهت المشكلة.


واجهت نفس المشكلة ولم أحصل على مسج 1.8.2 في صفحات الويب الخاصة بي.أحل مشكلتي عن طريق تغيير إصدار مسج في حزم .config

يتغيرون

  <package id="AspNet.ScriptManager.jQuery" version="1.8.2" targetFramework="net45" />
 <package id="jQuery" version="1.8.2" targetFramework="net45" />

إلى

<package id="AspNet.ScriptManager.jQuery" version="2.1.4" targetFramework="net45" />
 <package id="jQuery" version="2.1.4" targetFramework="net45" />

بلدي نسخة مسج هو 2.1.4





twitter-bootstrap-3