new - import settings android studio




لا يمكن تحديد مسار الفئة لواجهة com.android.builder.model.AndroidProject (6)

Palanivelraghul كان على حق. يجب على Studio تنزيل الإصدار القديم. ثم قدمت 3 خيارات مختلفة بعد اكتمالها.

اختر الخيار العلوي ~ "Sync with 3.0.1" .

سجل الأحداث:

Gradle sync started > Project setup started > Gradle sync finished > Executing tasks:

[:app:generateDebugSources, :app:generateDebugAndroidTestSources, :app:mockableAndroidJar] > Gradle build finished.

عندما أقوم باستيراد مشروع Eclipse إلى Android Studio ، Gradle 'XNote' project refresh failed Error:Could not determine the class-path for interface com.android.builder.model.AndroidProject. لي هذه المشكلة: Gradle 'XNote' project refresh failed Error:Could not determine the class-path for interface com.android.builder.model.AndroidProject. أحد يعرف لماذا حدث ما حدث؟ شكر!


أفضل طريقة لحل هذه المشكلة هي نسخ / لصق قيم build.gradle و gradle-wrapper.properties من مشروع عمل إلى المشروع المستهدف !!

ترميز سعيد!


الآن فقط أواجه نفس المشكلة.

1. check classpath في ملف build.gradle. التغيير إلى

classpath 'com.android.tools.build:gradle:2.3.0'

  1. ثم انتقل إلى gradle-wrapper.properties ، وقم بتغيير distributionUrl

distributionUrl = HTTP: //services.gradle.org/distributions/gradle-3.3-all.zip

ثم قم بإعادة بناء المشروع. مساعدتها بالنسبة لي ... وأعتقد أن هذا سوف يساعدك بالتأكيد.


حصلت عليه بعد ترقية أدوات الإنشاء إلى الإصدار 25.0.0 في build.gradle:

buildToolsVersion '25.0.0'

وتغيير المشروع لاستخدام أحدث إصدار للمحتوى 3.3 مع مجمّع gradle افتراضي (ملف -> إعدادات -> Gradle)


في حالتي ، قمت بإزالة المجلد .idea من المشروع ثم إعادة تشغيل الاستوديو تلقائيًا إلى جميع المجلدات المطلوبة وأعمال المهارة.


لقد حللت هذه المشكلة.

لا يقوم Google بتحديث ADT بعد الآن ، لذلك عندما يقوم Eclipse بتصدير مشروع إلى مستوى جديد ، فإنه يستخدم إصدارًا إضافيًا من مكونات gradle لا يدعمه Android Studio.

أولاً ، يجب عليك التحقق من إصدار المكوّن الإضافي الذي قمت بتثبيته. افتح دليل تثبيت Android Studio ، ثم افتح الدليل \gradle\m2repository\com\android\tools\build\gradle\ ، سترى كل الإصدار الذي قمت بتثبيته.

ثم افتح Android Studio ، ثم افتح علامة التبويب "Project -> Gradle Scripts" ، و Edit file build.gradle ، build.gradle بتغيير المكوّن الإضافي gradle إلى أحدث إصدار قمت بتثبيته ، مثل 2.3.0:

[اختياري] هذه الخطوة ليست ضرورية ، ولكن إذا لم تقم بذلك ، فقد ترى هذه المشكلة:

A problem occurred evaluating root project 'XXX'.
> org/gradle/initialization/BuildCompletionListener

تحقق من أحدث إصدار من gradle قمت بتثبيته على C:\Users\YOUR USER NAME\.gradle\wrapper\dists . ثم افتح علامة التبويب "Project -> Gradle Scripts" ، gradle-wrapper.properties بتحرير ملف gradle-wrapper.properties ، gradle-wrapper.properties بتعديل إصدار gradle (الاهتمام: gradle ، وليس gradle plugin) إلى الأحدث في السطر الأخير.

أخيرًا ، انقر فوق Build - Clean Project ، تم! إذا استمر التحذير "فشل مزامنة مشروع Gradle ..." ، فما عليك سوى النقر فوق " Try Again !

في النهاية ، ساعدني شخص ما في ترجمة إجابتي إلى الإنجليزية الحقيقية التي لا توجد أخطاء نحوية !!!





import