php - how - make laravel project composer




لا يمكن تثبيت برنامج تثبيت laravel عبر الملحن (8)

أحاول تثبيت مثبّت laravel مع الملحن على كمبيوتر Ubuntu الخاص بي ، لكني حصلت على هذا الخطأ أثناء التثبيت. `لا يمكن حل الاحتياجات الخاصة بك إلى مجموعة قابلة للتثبيت من الحزم.

  Problem 1
    - laravel/installer v1.4.1 requires ext-zip * -> the requested PHP extension zip is missing from your system.
    - laravel/installer v1.4.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.
    - Installation request for laravel/installer ^1.4 -> satisfiable by laravel/installer[v1.4.0, v1.4.1].

  To enable extensions, verify that they are enabled in those .ini files:
    - /etc/php/7.0/cli/php.ini
    - /etc/php/7.0/cli/conf.d/10-opcache.ini
    - /etc/php/7.0/cli/conf.d/10-pdo.ini
    - /etc/php/7.0/cli/conf.d/20-calendar.ini
    - /etc/php/7.0/cli/conf.d/20-ctype.ini
    - /etc/php/7.0/cli/conf.d/20-exif.ini
    - /etc/php/7.0/cli/conf.d/20-fileinfo.ini
    - /etc/php/7.0/cli/conf.d/20-ftp.ini
    - /etc/php/7.0/cli/conf.d/20-gettext.ini
    - /etc/php/7.0/cli/conf.d/20-iconv.ini
    - /etc/php/7.0/cli/conf.d/20-json.ini
    - /etc/php/7.0/cli/conf.d/20-phar.ini
    - /etc/php/7.0/cli/conf.d/20-posix.ini
    - /etc/php/7.0/cli/conf.d/20-readline.ini
    - /etc/php/7.0/cli/conf.d/20-shmop.ini
    - /etc/php/7.0/cli/conf.d/20-sockets.ini
    - /etc/php/7.0/cli/conf.d/20-sysvmsg.ini
    - /etc/php/7.0/cli/conf.d/20-sysvsem.ini
    - /etc/php/7.0/cli/conf.d/20-sysvshm.ini
    - /etc/php/7.0/cli/conf.d/20-tokenizer.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.
`

يظهر الخطأ ثم استخدم هذا التعليق:

composer global require "laravel/installer"

sudo - الحصول على تثبيت php-zip

عملت هذا الحل بالنسبة لي.


Centos 7 مع PHP7.2:

sudo yum --enablerepo=remi-php72 install php-pecl-zip

بالنسبة إلى Ubuntu 16.04 ، لقد استخدمت هذا الأمر من أجل PHP7.2 وهو يعمل من أجلي.

sudo apt-get install php7.2-zip

تقول أنه يتطلب تمديد الرمز البريدي

laravel / installer v1.4.0 يتطلب تحويل الرمز البريدي ........

قم بتثبيت الإصدار الخاص بإصدار php المثبت:

# For php v7.0
sudo apt-get install php7.0-zip

# For php v7.1
sudo apt-get install php7.1-zip

# For php v7.2
sudo apt-get install php7.2-zip

# For php v7.3
sudo apt-get install php7.3-zip

ل PHP7.1 تثبيت هذا

sudo apt-get install php7.1-zip

لـ PHP 7.2 في Ubuntu 18.04 LTS

sudo apt-get install php7.2-zip

يعمل كالسحر


لنظام التشغيل Mac مع Macports ،

# port install php71-zip

الرمز البريدي التمديد مفقود ، يمكنك تجنب هذا الخطأ عن طريق تشغيل بسيط أدناه الأمر ، وسوف يستغرق الإصدار بشكل افتراضي

sudo apt-get install php-zip

إذا كنت بحاجة إلى أي إصدار محدد ، فأنت بحاجة إلى ذكر إصدار محدد من php الخاص بك ، افترض أنني بحاجة إلى تثبيت الإصدار X من php-zip ثم الأمر.

sudo apt-get install phpX-zip  

استبدل X بالإصدار المطلوب ، وفي حالتي ، يكون X = 7.3