python - Matplotlib: الأنف ، تورنادو




pip jupyter (2)

لأنني أحاول تثبيت jupyter على جهاز mac الخاص بي ، فقد قمت بتطوير برنامجي. لقد أظهر لي كل شيء على ما يرام ، ولكن بعد ذلك لاحظت هذا:

    Requirement already up-to-date: pip in /Library/Python/2.7/site-packages/pip-10.0.0b2-py2.7.egg (10.0.0b2)
     matplotlib 1.3.1 requires nose, which is not installed.
     matplotlib 1.3.1 requires tornado, which is not installed.
     matplotlib 1.3.1 has requirement numpy>=1.5, but you'll have numpy 1.8.0rc1 which is incompatible.

ماذا يعني هذا؟ هل ستعمل matplotlib بشكل طبيعي حتى لو لم يكن لدي numphy> = 1.5؟

حاولت إصلاحها مثل matplotlib المقترح 1.3.1 يحتوي على متطلبات numpy> = 1.5 ، ولكن سيكون لديك 1.8.0rc1 numpy وهو أمر غير متوافق ولكنه لا يعمل:

sudo -H pip install numphy

Password:
Requirement already satisfied: numphy in /Library/Python/2.7/site-packages (0.0.1)
matplotlib 1.3.1 requires nose, which is not installed.
matplotlib 1.3.1 requires tornado, which is not installed.
matplotlib 1.3.1 has requirement numpy>=1.5, but you'll have numpy 1.8.0rc1 which is incompatible.

بعد البحث ، وجدت طريقة لتثبيت الحزم دون التحقق من الإصدار الحالي ، على سبيل المثال ، لتثبيت matplotlib :

sudo -H pip install --ignore-installed matplotlib

لست متأكدًا مما إذا كانت هناك طريقة أفضل ، لكن في عقد الإيجار ، دعني أستمر في العمل. اتمني ان يكون مفيدا


حصلت على نفس القضية. لديك لتثبيت التبعيات المذكورة. التي هي الأنف ، والإعصار ، والنسخة numpy أكبر من 1.5 قم بما يلي

sudo easy_install nose
sudo easy_install tornado

بالنسبة للجزء الأخير من الإصدار numpy أكبر من 1.5 ، يجب عليك الحصول على أحدث إصدار من python. الرجوع إلى هنا





jupyter