python - خطأ عند محاولة تثبيت نقطة على أوبنزيوس



pip rpm (1)

أحاول نشر pip على خادم الإنتاج الخاص بي، ولكن يكون خطأ غير منطقي، حيث يحاول تثبيت دون نجاح كومبوسنت المثبتة بالفعل.

~> sudo zypper in python-pip
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: python-pip-1.0.2-3.1.2.noarch requires python = 2.7, but this requirement cannot be provided
  uninstallable providers: python-2.7.2-7.10.1.i586[Updates-for-openSUSE-12.1-12.1-1.4]
                   python-2.7.2-7.17.1.i586[Updates-for-openSUSE-12.1-12.1-1.4]
                   python-2.7.2-7.10.1.x86_64[Updates-for-openSUSE-12.1-12.1-1.4]
                   python-2.7.2-7.17.1.x86_64[Updates-for-openSUSE-12.1-12.1-1.4]
                   python-2.7.2-7.1.3.x86_64[openSUSE-12.1-12.1-1.4]
                   python-2.7.2-7.1.3.i586[repo-oss]
                   python-2.7.2-7.1.3.x86_64[repo-oss]
 Solution 1: deinstallation of patterns-openSUSE-minimal_base-conflicts 12.1-25.21.1.x86_64
 Solution 2: do not install python-pip-1.0.2-3.1.2.noarch
 Solution 3: do not install python-pip-1.0.2-3.1.2.noarch
 Solution 4: break python-pip-1.0.2-3.1.2.noarch by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/4/c] (c): c

هذا أمر لا يصدق لأنه يتم تثبيت python-2.7.2-7.17.1 لمنصة جيدة (x86_64)

~> sudo zypper if python-base
Loading repository data...
Reading installed packages...


Information for package python-base:

Repository: Updates for openSUSE 12.1 12.1-1.4
Name: python-base
Version: 2.7.2-7.17.1
Arch: x86_64
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 20.8 MiB
Summary: Python Interpreter base package
Description:
Python is an interpreted, object-oriented programming language, and is
often compared to Tcl, Perl, Scheme, or Java.  You can find an overview
of Python in the documentation and tutorials included in the python-doc
(HTML) or python-doc-pdf (PDF) packages.

This package contains all of stand-alone Python files, minus binary
modules that would pull in extra dependencies.

إزالة patterns-openSUSE-minimal_base-conflicts 12.1-25.21.1.x86_64 كتم المشكلة؛ ولكن هل هناك طريقة نظيفة لحل هذه المشكلة؟


كان لي مشكلة مماثلة وكانت المسألة التي كنت تستخدم مستودع زيبر خاطئة (أوبنزيوس بدلا من SP3 سلي).

أنا إلغاء تثبيت الأنابيب الخاطئة، وإزالة مستودع خاطئ، وأضاف المستودع الصحيح وأخيرا إعادة تثبيت نقطة مرة أخرى. ثم عملت.





opensuse