npm - বাবেল আদেশটি পাওয়া যায় নি




babeljs (8)

বাবেল 'শুরু করা' পৃষ্ঠাটি ব্যাখ্যা করে আমি ব্যাবেল-ক্লাইপ সরঞ্জামটি ইনস্টল করেছি।

আমার প্রকল্প ফোল্ডারের ভিতরে একটি টার্মিনাল থেকে:

npm install --save-dev babel-cli

এর পরে, বাবেল-ক্লিপ ফোল্ডার সহ একটি নোড_মডিউলস ডিরেক্টরি রয়েছে তবে কোনও প্যাকেজ নেই j জসন তৈরি। এনপিএম নিম্নলিখিত ত্রুটিটিও দেখায়:

npm WARN enoent ENOENT: no such file or directory, open '/Users/MyName/Sites/Tutorials/Babel2/package.json

বাবেল চালানোর চেষ্টা করার সময়, আমি এটি পেয়েছি:

babel src -d lib
-bash: babel: command not found

আমি নোডেজ / এনপিএম এর সর্বশেষতম সংস্করণ ইনস্টল করেছি। আমি এনপিএম আপডেট-জি চালিয়েছি, এবং আমি অন্তর্ভুক্ত করতে আমার .bash_profile ফাইলটি সম্পাদনা করেছি:

export PATH=$PATH:/Users/MyName/npm/bin
export PATH=/usr/local/share/npm/bin:$PATH

আমি ব্রাউজারিফাইয়ের মতো অন্যান্য এনপিএম সরঞ্জামগুলির সাথে এটি অনুভব করিনি। বাবেলকে কেন স্বীকৃতি দেওয়া হচ্ছে না?


আমারও একই প্রশ্ন ছিল. nodemodules ফোল্ডারটি মুছে ফেলা হয়েছে এবং প্রশাসক হিসাবে কমান্ড প্রম্পট ওপেন করেছে এবং তারপরে npm install

সমস্ত প্যাকেজ জরিমানা ইনস্টল।


আমি আমার স্থানীয় প্রকল্প node_modules/.bin স্বয়ংক্রিয়ভাবে যোগ করার জন্য এটি করেছি। আমি ~/.profile যোগ করেছি:

if [ -d "$PWD/node_modules/.bin" ]; then 
    PATH="$PWD/node_modules/.bin"
fi

তারপরে আপনার বাশ প্রোফাইলটি পুনরায় লোড করুন: source ~/.profile প্রোফাইল


আমি যখন এই প্রশ্নটি পেয়েছি, আমি সন্ধান করছি

$ npm install -g babel-cli

আসলে আপনি যদি সিএমডি কমান্ড ব্যবহার করতে চান তবে আপনার দুটি উপায় রয়েছে। প্রথমে এটি গ্লোবাল পরিবেশে ইনস্টল করুন। অন্য npm link হল npm link । সুতরাং, প্রথম উপায়ে চেষ্টা করুন: npm install -g babel-cli


এটি সাধারণ সমস্যা এবং এটি আপনার মূল ডিরেক্টরি থেকে .cmd ফাইল সন্ধান করা যেখানে আপনি .cmd ইনস্টল করেছেন। নীচের আদেশটি চেষ্টা করুন।

./node_modules/.bin/babel.cmd

একবার আপনি কমান্ড প্রম্পটে আপনার উত্স কোডটি দেখতে সক্ষম হন। আপনার পরবর্তী পদক্ষেপটি আরও একটি এনপিএম মডিউল babel-preset-es2015

babel-preset-es2015 ইনস্টল করতে নীচের উত্তরটি অনুসরণ করুন এবং কেন babel-preset-es2015 প্রয়োজন।

babel-file-is-copied-without-being-transformed


তাদের জন্য এনপিএমের পরিবর্তে প্যাকেজ ম্যানেজার হিসাবে সুতা ব্যবহার করছেন:

yarn global add babel-cli

বাবেল চালনার 7+ সংস্করণ ইনস্টল করতে:

npm install -g @babel/cli
npm install -g @babel/core

যেমন আমার জন্য কাজ করেছেন

./node_modules/.bin/babel --version
./node_modules/.bin/babel src/main.js




babeljs