java - অ্যান্ড্রয়েড স্টুডিও ত্রুটি: ত্রুটি: ক্রিয়েটপ্রসেস ত্রুটি=216,% 1 এর এই সংস্করণটি আপনি যে উইন্ডোজটির সাথে চালাচ্ছেন তার সাথে সামঞ্জস্য নয়




android android-studio (3)

অ্যান্ড্রয়েড স্টুডিও 2.2 পূর্বরূপ 2 ইনস্টল করা হয়েছে এবং এই ত্রুটিটি পেয়েছে:

ত্রুটি: ক্রিয়েটপ্রসেস ত্রুটি = 216,% 1 এর এই সংস্করণটি আপনি যে উইন্ডোজটি চালাচ্ছেন তার সাথে সামঞ্জস্য নয়। আপনার কম্পিউটারের সিস্টেমের তথ্য পরীক্ষা করুন এবং তারপরে সফ্টওয়্যার প্রকাশকের সাথে যোগাযোগ করুন

স্ক্রীনশট:

আমি জেডিকে পুনরায় ইনস্টল করেছি, এখনও একই সমস্যা।

আমি এম্বেড করা জেডিকে ব্যবহার করার চেষ্টা করেছি কিন্তু এখনও একই সমস্যা রয়েছে:


আমার একই সমস্যা ছিল, তবে আমি এটি পরবর্তী সমাধান করেছি:

1) jdk1.8 ইনস্টল করুন ...

2) অ্যান্ড্রয়েড স্টুডিও ফাইল-> প্রকল্পের কাঠামো-> এসডিকে অবস্থানের ক্ষেত্রে, আপনার ডিরেক্টরিটি নির্বাচন করুন যেখানে জেডি কে রয়েছে, ডিফল্টরূপে স্টুডিও এম্বেডড জেডিকে ব্যবহার করে তবে কোনও কারণে এটি ত্রুটি তৈরি করে = 216।

3) ওকে ক্লিক করুন।



কারণ

এটি ঘটায় কারণ আপাতত তারা কেবলমাত্র উইন্ডোজের জন্য অ্যান্ড্রয়েড স্টুডিওর সাথে 64 বিবিটি জেআরই চালিত করে যা 32 বিট সিস্টেমে গ্লিটস তৈরি করে।

সমাধান

  • এম্বেড করা জেডিকে ব্যবহার করবেন না: ফাইল -> প্রকল্প কাঠামো ডায়ালগ এ যান, "এম্বেডড জেডিকে ব্যবহার করুন" নির্বাচন করুন এবং আপনার সিস্টেমে আলাদাভাবে ইনস্টল করা 32-বিট জেআরই নির্বাচন করুন
  • গ্রেডল.প্রোপার্টি (প্রকল্পের বৈশিষ্ট্য) এ গ্রেডলের জন্য মেমরির পদচিহ্ন হ্রাস করুন, উদাহরণস্বরূপ এটি -Xmx768m এ সেট করুন।

আরও বিশদের জন্য: https://code.google.com/p/android/issues/detail?id=219524





android-studio-2.2