angular cli - কৌণিক-ক্লাইটি পুনরায় ইনস্টল করার পরে বিল্ড কমান্ডটি ব্যবহার করতে আপনাকে একটি কৌণিক-ক্লাইপ প্রকল্পের ভিতরে থাকতে হবে




angular-cli (13)

আমি বিশ্বব্যাপী সর্বশেষতম কৌণিক-ক্লিপ ইনস্টল করেছি এবং আমার প্রকল্পটি সফলভাবে তৈরি হচ্ছে।

অন্য সমস্যার জন্য প্রস্তাবিত সমাধানটি পড়ার সময়, ( https://github.com/angular/angular-cli/issues/917 ) আমি বিশ্বব্যাপী কৌণিক-ক্লিপটি আনইনস্টল করে দেব-নির্ভরতা হিসাবে ইনস্টল করেছি।

এই অন্যান্য সমস্যাটির সমাধান হয়নি তাই আমি দেব-নির্ভরতা আনইনস্টল করে বিশ্বব্যাপী আবার কৌণিক-ক্লিপ পুনরায় ইনস্টল করেছি। এখন যখন আমি এনজি বিল্ড করার চেষ্টা করি তখন আমি ত্রুটি পেয়ে যাচ্ছি:

বিল্ড কমান্ডটি ব্যবহার করতে আপনাকে একটি কৌণিক-ক্লাইপ প্রকল্পের মধ্যে থাকতে হবে

আমার কৌণিক-ক্লাইনের সংস্করণটি পরিবর্তন হয়নি। কেন আমার প্রকল্পটি কৌণিক-ক্লাইপ প্রকল্প হিসাবে স্বীকৃত হচ্ছে না ??


এই ত্রুটিটি তখন আসে যখন নোড সংস্করণ এবং কৌণিক / ক্লিপ সংস্করণের মধ্যে অসঙ্গতি থাকে। অতএব ক্লায়াল সংস্করণটি সর্বশেষে আপডেট করতে নীচের কমান্ডটি ব্যবহার করুন

এনপিএম ইনস্টল করুন -জি @ কৌনিক / ক্লিপ @ সর্বশেষ


- ফোর্স ব্যবহার করতে ভুলবেন না:

npm cache clean --force

আমার একই সমস্যা ছিল - এটি প্রমাণিত হয়েছে যে আমি @ কৌণিক / ক্লাইটের পরিবর্তে অবনতিযুক্ত কৌণিক-ক্লিট ব্যবহার করছি। পরেরটি আমার ডেভ টিম ব্যবহার করেছিল এবং আমাকে খেয়াল করতে কিছুটা সময় লাগল যে আমরা কৌণিক-ক্লাইমের বিভিন্ন সংস্করণ ব্যবহার করছি।


আমার ক্ষেত্রে (ম্যাক ওএস এক্স এবং পূর্বে ব্যবহৃত কৌণিক 1.5 1.5 পরিবেশ)

npm -g cache clean --force

npm cache clean --force

কাজ করছে. ( npm install -g @angular/[email protected] পরে)


আমি একই ত্রুটি বার্তা ছিল। তবে কারণ ও সমাধান কিছুটা আলাদা। আমি যখন "এনজি-ভি" চালিয়েছি তখন এটি কৌণিক-ক্লাইমের (1.0.0-beta.28.3) এবং @ কৌণিক / ক্লিমে (1.0.0-বিটা.31) এর বিভিন্ন সংস্করণ দেখিয়েছিল। আমি আবার দৌড়েছি:

npm install -g @angular/cli

এখন উভয়ই 1.0.0-beta.31 এর একটি সংস্করণ দেখায়। ত্রুটি বার্তাটি চলে গেছে এবং "এনজি সার্ভিস" এখন কাজ করে। (হ্যাঁ - এটি ছিল @ কৌণিক / ক্লিপ যা আমি পুনরায় ইনস্টল করেছি এবং কৌণিক-ক্লিপ সংস্করণ আপডেট হয়েছিল))


আমি যখন একই সমস্যায় পড়েছি তখন এটিই আমাকে সাহায্য করেছিল:

npm uninstall -g angular-cli @angular/cli
npm cache clean --force
npm install -g @angular/[email protected]

এটা আমার ক্ষেত্রে কাজ করেছে

sudo npm uninstall -g angular-cli @angular/cli
sudo npm cache clean --force
npm install [email protected] -g
sudo npm install -g @angular/cli

এটি আমার জন্য npm install -g @angular/[email protected] দিয়ে কাজ করে।


ঠিক আছে, এটি খুঁজে পেয়েছি।

প্যাকেজ.জসনে অবশ্যই কৌণিক- ক্লাইমের একটি নির্ভরতা থাকতে হবে।

যখন আমি আমার স্থানীয় কৌণিক-ক্লিপটি আনইনস্টল করি, এনপিএম নির্ভরতা এন্ট্রিও সরিয়ে দেয়।


নিম্নলিখিত কমান্ডগুলি ধাপে ধাপে কার্যকর করুন:

sudo npm uninstall -g angular-cli @angular/cli

sudo npm cache clean

npm install [email protected] -g

sudo npm install -g @angular/cli

npm rebuild node-sass --force

npm uninstall -g angular-cli
npm uninstall --save angular-cli
npm uninstall -g @angular/cli
npm uninstall --save @angular/cli
npm cache clean
npm install --save-dev @angular/[email protected]

npm uninstall -g angular-cli 

npm install -g @angular/cli

এটাই!


npm uninstall -g angular-cli @angular/cli
npm cache clean
npm install -g @angular/cli

ম্যাক / লিনাক্সে sudo ব্যবহার করুন।







angular-cli