macos - কমান্ড লাইন সরঞ্জাম বাশ(গিট) কাজ করছে না-ম্যাকস সিয়েরার চূড়ান্ত প্রকাশের প্রার্থী




terminal macos-sierra (4)

আমি সবেমাত্র ওএস এক্স 10.11 "এল ক্যাপিটান" থেকে 10.12 তে আপগ্রেড করেছি : "সিয়েরা" এবং যখন আমি টার্মিনালের অভ্যন্তরে গিট কমান্ডগুলি অ্যাক্সেস করার চেষ্টা করি তখন আমি নিম্নলিখিত ত্রুটিটি পাই:

xcrun: ত্রুটি: অবৈধ সক্রিয় বিকাশকারী পথ

(/ গ্রন্থাগার / বিকাশকারী / কমান্ডলাইনটুলস), এক্সক্রন অনুপস্থিত:

/ লাইব্রেরি / ডেভেলপার / CommandLineTools / usr / bin / xcrun

কারও সমাধান থাকলে দয়া করে আমাকে সাহায্য করুন।


আমি অ্যাপল বিকাশকারী ডাউনলোডগুলি থেকে 'এক্সকোড 8' প্যাকেজটির জন্য 'কমান্ড লাইন সরঞ্জাম (ম্যাকোস সিয়েরা) ডাউনলোড এবং ইনস্টল করে এই সমস্যাটি সমাধান করেছি।

আপনি যদি Xcode 8.1 বিটা ইনস্টল না করেন তবে Command Line Tools (macOS 10.12) for Xcode 8 এবং 8.1 বিটার জন্য নয় তা নির্বাচন করা নিশ্চিত করুন।


আমি সদ্য সাম্প্রতিক ম্যাকোস হাই সিয়েরা সংস্করণ 10.13.3 এ আপগ্রেড করেছি এবং এর এক্সকোড রয়েছে। আমার গিট কমান্ড লাইনের একই সমস্যা আছে। "$ এক্সকোড-নির্বাচন - ইনস্টল" আমার পক্ষে পুরোপুরি কাজ করে।


একা - এক্সকোড-নির্বাচন - ইনস্টল আমার পক্ষে কাজ করে নি।

সমস্ত 3 টি পদক্ষেপ করতে হয়েছিল:

  1. অ্যাপ স্টোর থেকে এক্স-কোড ডাউনলোড করুন (অ্যাপ্লিকেশন ফোল্ডারে উপস্থিত না থাকলে)
  2. $ এক্সকোড-নির্বাচন - ইনস্টল
    ক। কমান্ড লাইনে সফ্টওয়্যারআপডেট ব্যবহার করে ইনস্টলের পরে আপডেট করার প্রয়োজন হতে পারে। do sudo সফ্টওয়্যার আপডেট -i "এক্সকোড -9.1 এর জন্য কমান্ড লাইন সরঞ্জাম (ম্যাকোস উচ্চ সিয়েরা সংস্করণ 10.13)"

  3. $ সুডো এক্সকোডবিল্ড-লাইসেন্স


এক্সকোড বিকাশকারী সরঞ্জামগুলি পুনরায় ইনস্টল করুন

xcode-select --install




macos-sierra