python - পাইথন: কীভাবে নির্দিষ্ট সংস্করণ 2.4.9 সহ ওপেনকভি 2 ইনস্টল করবেন?




opencv pip (8)

আমি জানি যে আমি pip install opencv-python করতে পারি যা ওপেনসিভি 3 ইনস্টল করে, তবে ওপেনসিভি নির্দিষ্ট সংস্করণ যেমন 2.4.9 এর জন্য আলাদা কমান্ড বা নাম আছে?

যদি তা না হয় তবে আমি কোন সংস্করণটি ইনস্টল করব তা কীভাবে নির্দিষ্ট করতে পারি?

ধন্যবাদ।


আপনি এটি Anaconda ব্যবহার করেও করতে পারেন:

conda install -c https://conda.binstar.org/menpo opencv=2.4.9

আপনি এটি চেষ্টা করতে পারেন

pip install opencv==2.4.9

আপনি যদি উইন্ডোজ ব্যবহারকারী হন তবে ওপেনসিভি এই জাতীয় পাইপ ব্যবহার করে ইনস্টল করা যেতে পারে:

sudo apt-get install python-opencv

আপনি যদি লিনাক্স ব্যবহারকারী হন:

conda install -c https://conda.binstar.org/menpo opencv=3.6

একই সময়ে, ওপেনসিভি এই জাতীয় কনডা ব্যবহার করে ইনস্টল করা যেতে পারে ...

 conda install -c https://conda.binstar.org/menpo opencv=3.6 

আর একটি সহজ উপায় আছে, আপনি টার্মিনাল টাইপ করতে পারেন

sudo apt-get install python-opencv

উবুন্টুতে ওপেনসিভি-পাইথন ইনস্টল করুন

এটি ইনস্টল করার পরে, আপনি সি ++ এবং পাইথন উভয় ক্ষেত্রে ওপেনসিভি সংস্করণ 2.4 ব্যবহার করতে পারেন।

তবে আমি আপনাকে ওপেনসিভি ৩.২.০ এবং ওপেনসিভি-অবদান ব্যবহার করার পরামর্শ দিচ্ছি, এটি আরও বৈশিষ্ট্য দেয়

আশা করি এটি সাহায্য করতে পারে!


প্রথমে, আপনি ইনস্টল করতে চান এমন সঠিক ওপেনসিভি সংস্করণ এক্সটেনশান পান। আপনি যদি 3.4.9.20 ইনস্টল করতে চান তবে pip install opencv-python==3.4.5.20


সহজ এবং সহজ

  • পূর্বশর্ত
    • পাইপ ইনস্টল matplotlib
    • পাইপ ইনস্টল অদ্ভুত
  • শেষ ধাপ
    • পাইপ ওপেনসিভি-পাইথন ইনস্টল করুন

নির্দিষ্ট সংস্করণ * চূড়ান্ত পদক্ষেপ * ওপেনসিভি-পাইথন == 2.4.9


সিভি 2 বনাম "ওপেনসিভি 3"

সম্ভাব্য ভুল বোঝাবুঝির import cv2 জন্য: পাইথন ওপেনসিভি মডিউলের নাম এবং 3.0> 3.0 সহ সমস্ত সংস্করণ> 2.0 এ import cv2 মাধ্যমে import cv2 । আপনি যদি cv2 2 দিয়ে কাজ করতে চান তবে cv2 সংস্করণ> 3 ইনস্টল করা ঠিক আছে - যদি না আপনি পুরানো সংস্করণগুলির সাথে নির্দিষ্ট সামঞ্জস্যতা খুঁজছেন বা 2.4.x সংস্করণের অনুরাগী না হন। 2.4.x থেকে 3.x এ স্যুইচটি 2015 সালে ছিল এবং বৈশিষ্ট্য, গতি এবং স্বচ্ছতার দিক থেকে এটি নতুন সংস্করণগুলি ব্যবহার করতে অনেক বেশি অর্থবোধ করে। আপনি here এবং here বড় পার্থক্য সম্পর্কে পড়তে পারেন। ২.৪.x সংস্করণগুলি এখনও সমর্থিত, বর্তমান প্রকাশ ২.৪.১৩.৫।

একটি নির্দিষ্ট সংস্করণ ইনস্টল করা, যেমন ওপেনসিভি 2.4.9 .9

এটি বলেছিল: আপনি যদি একটি নির্দিষ্ট সংস্করণ ইনস্টল করতে চান যা pip install opencv-python==2.4.X না করে, sudo apt-get install opencv না conda install opencv=2.4.x সরবরাহ করুন (অন্যান্য উত্তর দ্বারা এখানে ব্যাখ্যা করা হয়েছে) সর্বদা উত্স থেকে ইনস্টল করুন। সোর্সফোর্জ সংগ্রহস্থলে আপনি প্রতিটি অপারেটিং সিস্টেমের জন্য সমস্ত বড় সংস্করণ খুঁজে পেতে পারেন। যদিও অনভিজ্ঞ ব্যবহারকারীদের জন্য এটি ভীতিজনক হতে পারে তবে কয়েকটি টিউটোরিয়ালে এটি ভালভাবে ব্যাখ্যা করা হয়েছে। উদাহরণস্বরূপ উবুন্টু 14.04 এ here 2.4.9 এর জন্য। অথবা সর্বশেষ প্রকাশের ২.৪.১৩.৫ এর জন্য অফিসিয়াল লিনাক্স ইনস্টল ডক is

সংক্ষেপে, ইনস্টল প্রক্রিয়াটি এখানে নীচে ফোটে:

  1. নির্ভরতা ইনস্টল করুন, প্রয়োজনীয় প্যাকেজগুলির জন্য ডকগুলি (যেমন here ) দেখুন

  2. ওপেনসিভিস উত্স থেকে উত্স পান

    যেমন wget http://sourceforge.net/projects/opencvlibrary/files/opencv-unix/2.4.9/opencv-2.4.9.zip

  3. উত্স আনজিপ করুন এবং বিল্ড ডিরেক্টরি তৈরি করে তৈরি করুন এবং cmake চালাবেন build

    mkdir build
    cd build
    cmake (... your build options ...)
  4. এর সাথে তৈরি বিল্ড ডিরেক্টরিটি তৈরি করুন:

    make
    sudo make install

pip install opencv-python==<python version>

ex - pip install opencv-python==3.6

যা আপনার বর্তমান পাইথনের উপর ভিত্তি করে ওপেনসিভি ইনস্টল করবে





package