python - প্রয়োজনীয় টেনস্রোফ্লো সন্তুষ্ট করে এমন কোনও সংস্করণ খুঁজে পেল না




python-3.x python-2.7 (6)

আমি পাইথনের সর্বশেষতম সংস্করণ (3.6.4 64-bit) এবং PyCharm (2017.3.3 64-bit) সর্বশেষ সংস্করণ PyCharm (2017.3.3 64-bit) । তারপরে আমি পাইচার্মে কিছু মডিউল ইনস্টল করেছি (নম্পি, পান্ডাস, ...), কিন্তু যখন আমি টেনসরফ্লো ইনস্টল করার চেষ্টা করেছি তখন এটি ইনস্টল হয়নি এবং আমি ত্রুটি বার্তাটি পেয়েছি:

টেনস্রোফ্লো প্রয়োজনীয়তার সাথে সন্তুষ্ট এমন কোনও সংস্করণ খুঁজে পেল না (সংস্করণগুলি থেকে): টেনসরফ্লোয়ের জন্য কোনও মিল খুঁজে পাওয়া যায় নি

তারপরে আমি কমান্ড প্রম্পট থেকে টেনসরফ্লো ইনস্টল করার চেষ্টা করেছি এবং আমি একই ত্রুটি বার্তা পেয়েছি। তবে আমি সফলভাবে ইনস্টল করেছি tflearn।

আমি পাইথন ২.7 ইনস্টল করেছি তবে আমি আবার একই ত্রুটি বার্তা পেয়েছি। আমি ত্রুটিটি গুগল করেছিলাম এবং এমন কিছু জিনিস চেষ্টা করেছি যা অন্যান্য লোকদের কাছে প্রস্তাবিত হয়েছিল তবে কিছুই কার্যকর হয়নি (এর মধ্যে ফ্লাস্ক ইনস্টল করা অন্তর্ভুক্ত)।

আমি কীভাবে টেনসরফ্লো ইনস্টল করতে পারি? ধন্যবাদ।


আমি এটি pip install https://storage.googleapis.com/tensorflow/mac/cpu/tensorflow-1.8.0-py3-none-any.whl দ্বারা সফলভাবে pip install https://storage.googleapis.com/tensorflow/mac/cpu/tensorflow-1.8.0-py3-none-any.whl


অগস্ট -13-2018 হিসাবে টেনসরফ্লো সমর্থন করে, পাইথন 3.6.x। পাইথন 3.6.x ইনস্টল করুন


আমি এটি উইন্ডোজের জন্য দিচ্ছি

আপনি যদি পাইথন -3 ব্যবহার করেন

  1. py -m pip install --upgrade pip ব্যবহার করে সর্বশেষ সংস্করণে পিপ আপগ্রেড করুন
  2. py -m pip install <package-name> ব্যবহার করে প্যাকেজ py -m pip install <package-name>

আপনি যদি পাইথন -২ ব্যবহার করেন

  1. py -2 -m pip install --upgrade pip ব্যবহার করে সর্বশেষ সংস্করণে পিপ আপগ্রেড করুন
  2. py -2 -m pip install <package-name> ব্যবহার করে প্যাকেজ py -2 -m pip install <package-name>

এটা আমার জন্য কাজ করে


টেনসরফ্লো ইনস্টল করার জন্য দুটি গুরুত্বপূর্ণ নিয়ম রয়েছে:

  • আপনাকে পাইথন x64 ইনস্টল করতে হবে। এটি 32 বি তে কাজ করে না এবং এটি আপনার মত একই ত্রুটি দেয়।

  • এটি পাইথন 3 = 3.7 এর সর্বশেষতম সংস্করণ সমর্থন করে না

উদাহরণস্বরূপ, আপনি পাইথন 3.6.2-64 বিট ইনস্টল করতে পারেন এবং এটি একটি কবজির মতো কাজ করে।

পাইথন ৩.7-এ আপডেট করুন: পাইথন ৩.7 রয়েছে এমন কারও জন্য (কন্ডার মতো) আপনি টেনসরফ্লো ইনস্টল করতে নিম্নলিখিত কমান্ডটি ব্যবহার করতে পারেন:

pip install tf-nightly

পাইথন আনইনস্টল করা এবং তারপরে পুনরায় ইনস্টল করা আমার সমস্যার সমাধান করেছে এবং আমি সফলভাবে টেনসরফ্লো ইনস্টল করতে সক্ষম হয়েছি।


পাইথন সংস্করণ আনইনস্টল পাইথন সমর্থিত নয়

https://www.python.org/downloads/release/python-362/

আপনার ইনস্টল পৃষ্ঠায় সঠিক সংস্করণটি পরীক্ষা করা এবং ব্যবহার করা উচিত। tensorflow.org/install/install_windows

অজগর 3.6.2 বা পাইথন 3.5.2 আমার জন্য এই সমস্যাটি সমাধান করেছে





pip