git - উত্সট্রি ত্রুটি: 1407742E: এসএসএল রুটিনগুলি: SSL23_GET_SERVER_HELLO: tlsv1 সতর্কতা প্রোটোকল সংস্করণ




github atlassian-sourcetree (5)

আমি সোর্স ট্রি ব্যবহার করছি এবং একটি সাধারণ গিথুব সংগ্রহশালা থেকে ক্লোন করার চেষ্টা করছি, তবে আমি এই ত্রুটিটি পেয়েছি:

মারাত্মক: ' https://github.com/mfitzp/15-minute-apps.git/ ' অ্যাক্সেস করতে অক্ষম: ত্রুটি: 1407742E: SSL রুটিনগুলি: SSL23_GET_SERVER_HELLO: tlsv1 সতর্কতা প্রোটোকল সংস্করণ ত্রুটিগুলি সম্পন্ন হয়েছে, উপরে দেখুন।

কীভাবে সমাধান করবেন?



আমার একই সমস্যা ছিল এবং আমার ফিক্সটি হ'ল:

সর্বশেষ সংস্করণে 1. আপগেট গিট

2.in কমান্ড লাইনে আপনার টিএলএস সংস্করণটি কমান্ড সহ পরীক্ষা করুন: গিট কনফিগারেশন http.sslVersion

৩. সংস্করণটি tlsv1.0 এর চেয়ে কম কমান্ড সহ tlsv1.2 এ আপডেট করতে হবে:

  • git config --global --unset http.sslVersion
  • git config --global --add http.sslVersion tlsv1.2

এবং ত্রুটির চেয়ে আর উপস্থিত হবে না


আমি মাউন্টেন সিংহটি ব্যবহার করছি (10.8.5) তাই আমি 2.3.5 এর চেয়ে বেশি গিট সংস্করণ পাব না। আমার পক্ষে একমাত্র কাজটি ছিল আমার গিথুব অ্যাকাউন্টে একটি এসএসএইচ কী যুক্ত করা , যা here ব্যাখ্যা করা here

এবং তারপরে এসএসএইচ দিয়ে ক্লোনিং করা । হয় সোর্স ট্রি বা কেবল git clone [email protected]:[username]/[repository].git


নতুন সংস্করণ ডাউনলোড করুন, এটি কবজির মতো কাজ করবে -

https://git-scm.com/downloads


সোর্সট্রিতে Tools > Options > Git পরীক্ষা করুন, আপনি যদি এমবেডড Tools > Options > Git ব্যবহার করেন তবে আপনি গিট সংস্করণটি 1.9.5 দেখতে 1.9.5 যা পুরানো, 1.9.5 সর্বশেষ সংস্করণটি 2.16.2

সুতরাং Use System Git করুন ক্লিক Use System Git , আপনি যদি Use System Git নতুন সংস্করণ ইনস্টল করেন, Use system Git পরে এটি আরও নতুন সংস্করণ দেখায়, তবে এটি আবার ঠিকঠাক করার চেষ্টা করুন এটি ভাল কাজ করবে work

আরও একটি উত্তর HERE







atlassian-sourcetree