c# - .NET Core 2.2 ভিসুয়াল স্টুডিও বিল্ড ফ্রেমওয়ার্কে নির্বাচিত করা যাবে না




visual-studio asp.net-core (8)

পূর্বে, আমি .NET কোর প্রজেক্টের বৈশিষ্ট্য বিভাগে .NET কোর 2.2 ফ্রেমওয়ার্ক নির্বাচন করতে সক্ষম হয়েছিলাম, তবে সর্বশেষ ভিজ্যুয়াল স্টুডিও আপডেটের পরে আমি সক্ষম হব না।

যা আমি চেষ্টা করেছি:

  • .NET Core 2.2 SDK ইনস্টলেশন মেরামত করা হচ্ছে
  • আনইনস্টল এবং .NET Core 2.2 SDK পুনরায় ইনস্টল করা
  • ভিসুয়াল স্টুডিও পুনঃসূচনা
  • আমার মেশিন পুনরায় আরম্ভ করা হচ্ছে
  • একটি তাজা .NET কোর প্রকল্প তৈরি করা

কিছুই কাজ করতে সক্ষম হয়েছে। যেহেতু আমি সর্বশেষ আপডেটগুলি ইনস্টল করার আগে এটি কাজ করে আসছে, এটি কি শুধু একটি বাগ হতে পারে? নাকি এমন কিছু আছে যা আমি অনুপস্থিত?

আরো কিছু স্বচ্ছতার জন্য, উইন্ডোজ 10 প্রফেশনাল এক্স 64 এ উইন্ডোজের সর্বশেষ সংস্করণে চলছি।

আমি এখানে থেকে .NET কোর 2.2 এর এই সংস্করণ ইনস্টল

কোন সাহায্য প্রশংসা করা হয়। ধন্যবাদ!


'বর্তমান নেট নেটের জন্য অনুসন্ধানের পরে এখানে ল্যান্ডিংয়ের জন্য অন্য কেউ এখানে নেই। নেট কোর 2.2 ...' নিশ্চিত করুন যে আপনার ডাউনলোডের জন্য সঠিক প্ল্যাটফর্ম নির্বাচন করা হয়েছে: 3286-এ x64 ব্যবহার করুন যখন ভিজ্যুয়াল স্টুডিওতে 32- বিট মোড (যা বর্তমানে সবসময় ক্ষেত্রে)।


2017 15.9.11 ব্যবহার করে শুধুমাত্র 2.2.202 দিয়ে (রান করা ডটনেট - ইনফোফ ইন্সটল করার জন্য দেখুন) আমি ড্রপ ডাউন থেকে 2.2 টি নির্বাচন করতে পারিনি এবং ত্রুটিটি পেতে হবে "বর্তমান .NET SDK লক্ষ্যমাত্রা সমর্থন করে না .NET কোর 2.2 "।

একবার আমি 2.2.104 ইন্সটল করলে আমি ফ্রেমওয়ার্ক নির্বাচন ড্রপ ডাউন থেকে 2.2 সংকলন করতে এবং নির্বাচন করতে সক্ষম হয়েছিলাম।

প্রিয় এমএস - ভিএস খুব সম্ভবত বিদায় হয়। আপনি চুপচাপ গিয়েছিলাম আমি সত্যিই অস্থিরতা প্রশংসা করি না।


আমিও একই সমস্যাটি মোকাবেলা করছি (কোর 2.2 ফ্রেমওয়ার্ক লক্ষ্য কাঠামো ড্রপ ডাউন না আসছে) যাতে এই সমস্যাটি সমাধান করতে নিম্নলিখিত পদক্ষেপগুলি অনুসরণ করুন:

  1. here থেকে সর্বশেষ কোর সংস্করণ ইনস্টল here
  2. ফোল্ডারে global.json ফাইলটি খুঁজুন (C: \ ব্যবহারকারীগণ [ব্যবহারকারীর নাম]), এই ফাইলের মূল কাঠামোর সংস্করণটি পরিবর্তন করুন।
  3. চাক্ষুষ স্টুডিও পুনরায় আরম্ভ করুন।

আশা করি এটা তোমাকে সাহায্য করবে!


উত্তর সহজ,

  1. মাইক্রোসফট নেট এবং ভিসুয়াল স্টুডিও টিমের ব্লগগুলিতে সাবস্ক্রাইব করুন যাতে আপনি সবসময় নতুন কিছু শিখতে পারেন, যেমন https://blogs.msdn.microsoft.com/dotnet/2018/11/13/net-core-tooling-update-for-visual-studio-2017-version-15-9/
  2. .NET কোর SDK ( Options ) এর পূর্বরূপগুলি ব্যবহার করতে ভিসুয়াল স্টুডিও 2017 15.9 কনফিগার করুন এবং VS পুনরায় চালু করুন।

2019 আপডেট করুন:

মাইক্রোসফ্ট সিদ্ধান্ত নেয় যে VS2017 / 2019 বিভিন্ন .NET কোর SDK সংস্করণগুলি ব্যবহার করতে হবে, তাই আপনার VS সংস্করণগুলির জন্য সঠিক সংস্করণগুলি ইনস্টল করতে ভুলবেন না এবং এখানে আনুষ্ঠানিক ঘোষণাটি পড়ুন,

https://github.com/dotnet/announcements/issues/108

আপনি .NET কোর রিলিজ নোটগুলিতে এসডিকে সংস্করণ / ভিএস সংস্করণ সারণী খুঁজে পেতে পারেন, যেমন https://github.com/dotnet/core/blob/master/release-notes/2.2/2.2.4/2.2.4.md


ভিএস। নেট কোর এসডিকে 2.2.107 এর জন্য আপডেট করুন

এই পৃষ্ঠাটি here বিশেষভাবে ভিএস 2017 এর জন্য 2.2.107 sdk এর জন্য লিঙ্ক করেছে। আমি ভিজুয়াল স্টুডিওতে প্রকল্প ড্রপডাউন থেকে 2.2 কোর বিকল্পটি দেখতে পাচ্ছি যদিও এটির প্রয়োজন ছিল।

ক্ষুদ্র রিলিজ বৃদ্ধি কিন্তু দৃশ্যত তারা অন্তর্নিহিত এমএস বিল্ড জিথুব ডটনেট কোর তৈরি করে যা ২017 এর বক্কেড হয়। তাছাড়া ভিএস 2017 15.9.12 কোনও আপডেটের প্রয়োজনীয়তা দেখাচ্ছে না।

এছাড়াও global.json এবং project.json ইত্যাদি চলে গেছে এবং পরিবর্তে csproj ফাইল এখন ব্যবহার করা হয়।


ভিজ্যুয়াল স্টুডিও 2017 এবং 2019 নির্দিষ্ট বিল্ড সংস্করণের প্রয়োজন। এই অনুপস্থিত এই ভুল দিতে হবে।

  • 2017 এক্সএক্স 100 ব্যবহার করে
  • 2019 xx200 ব্যবহার করে

সর্বশেষ sdk https://github.com/dotnet/core প্রতিটি বনাম সংস্করণ নির্দিষ্ট।

https://github.com/dotnet/core/blob/master/release-notes/2.2/2.2.4/2.2.4-download.md

  • 2017 ইনস্টল 2.2.106
  • 2019 ইনস্টল 2.2.203

এই সমস্যা সমাধান


সঠিক। নেট কোর কাঠামো নির্বাচন করুন। ভিজ্যুয়াল স্টুডিও 2017 বনাম 15.9.12। নেট কোর এসডিকে 2.2.107 এর সাথে সামঞ্জস্যপূর্ণ। ভিজুয়াল স্টুডিও 2019 এর সাথে সামঞ্জস্যপূর্ণ ডিডি 2.2.300


সর্বশেষ নেট নেট এসডিকে ইনস্টল করার পরে .নেট কোর অ্যাপ্লিকেশনগুলি কম্পাইল করার সাথে আটকে থাকা লোকেদের জন্য।

টি এল; ডিআর:

আপনার ভিজ্যুয়াল স্টুডিও সংস্করণের উপর নির্ভর করে (15, 17 বা 19) আপনাকে নির্দিষ্ট SDK সংস্করণ ইনস্টল করতে হবে (যা সর্বশেষ উপলব্ধ হবে না)।

তাই আজকের হিসাবে, আপনি নিম্নলিখিত লিঙ্ক ব্যবহার করতে পারেন:

  • ভিজ্যুয়াল স্টুডিও 2017 (সংস্করণ 15.9 বা উপরে) এর জন্য, আপনাকে SDK সংস্করণ 2.2.106 ইনস্টল করতে হবে
  • ভিজ্যুয়াল স্টুডিও 2019 (পূর্বরূপ বা উপরে) জন্য, আপনাকে SDK সংস্করণ 2.2.203 ইনস্টল করতে হবে

সম্পূর্ণ তথ্যাদি:

ভিজ্যুয়াল স্টুডিও টিম কীভাবে ভিজ্যুয়াল স্টুডিও ব্যবহার করবে তার পরিবর্তনের কারণে। নেট কোর এসডিকে ইনস্টল করা হয়েছে, একটি উপযুক্ততা টেবিল রয়েছে যা দেখায় যে কোন SDK সংস্করণটি ভিজ্যুয়াল স্টুডিও 2015/2017 এবং 2019 এর সাথে সামঞ্জস্যপূর্ণ।

এই পরিবর্তনটি হাইলাইট করার ব্লগ পোস্ট: https://devblogs.microsoft.com/dotnet/net-core-tooling-update-for-visual-studio-2017-version-15-9/

সমস্যাটির সমাধান করার জন্য আপনাকে আপনার ভিজ্যুয়াল স্টুডিও সংস্করণের সাথে সামঞ্জস্যপূর্ণ SDK সংস্করণটি ব্যবহার করতে হবে তা নিশ্চিত করতে হবে।

এই পৃষ্ঠায় টেবিলটি পরীক্ষা করে দেখুন এবং আপনার ভিজ্যুয়াল স্টুডিও সংস্করণের সাথে সামঞ্জস্যপূর্ণ SDK সংস্করণটি ইনস্টল করুন: https://github.com/dotnet/core/blob/master/release-notes/2.2/2.2.4/2.2.4.md






asp.net-core