Angular Compiler এ ERROR টাইপস্ক্রিপ্ট>=3.1.1 এবং<3.2.0 প্রয়োজন কিন্তু 3.2.1 এর পরিবর্তে পাওয়া যায়




typescript npm (4)

CircleCi এর ত্রুটির লগ থেকে অনুরূপ ত্রুটি পেয়েছে।

"Angular Compiler এ ত্রুটিটি টাইপস্ক্রিপ্ট> = 3.1.1 এবং <3.3.0 প্রয়োজন কিন্তু 3.3.3333 এর পরিবর্তে পাওয়া যায়।"

ঠিক তাই আপনি জানেন যে এটি কৌণিক অ্যাপ্লিকেশনটিকে প্রভাবিত করে না, কিন্তু CircleCi ত্রুটি বিরক্তিকর হয়ে উঠছে। আমি কৌণিক 7.1 চালাচ্ছি

আমি দৌড়ালাম: $ npm আমি প্যাকেজ-লক.জson ফাইলটি আপডেট করার জন্য [email protected] --save-dev --save-exact টাইপ করব।

তারপর আমি রান: $ npm আমি

তারপরে আমি দৌড়ে গেলাম: $ npm অডিট ফিক্স

"এই CircleCi ত্রুটি বার্তা" চলে গেছে। সুতরাং এটা কাজ করে

আমি এই ত্রুটি পাচ্ছি

Angular Compiler এ ERROR টাইপস্ক্রিপ্ট> = 3.1.1 এবং <3.2.0 প্রয়োজন কিন্তু 3.2.1 এর পরিবর্তে পাওয়া যায়।

TypeScript আপডেট মনে হচ্ছে কিন্তু কৌণিক কম্পাইলার যে পছন্দ করে না।

আমি কিভাবে এটা ঠিক করব?


আমার ক্ষেত্রে কমান্ড উইন্ডোজ জন্য কাজ। এটি 3.1.1 এবং 3.2.0 এর মধ্যে সর্বশেষ প্রয়োজনীয় সংস্করণ ইনস্টল করবে। ওএস ব্যবহার করে দ্বিগুণ বা একক উদ্ধৃতি ব্যবহার

npm install [email protected]">=3.1.1 <3.2.0" 

প্রথমে আপনার লক্ষ্য সংস্করণ ইনস্টল করুন

npm i [email protected].1.6 --save-dev --save-exact

তারপর কম্পাইল করার আগে

   npm i

npm install [email protected]">=3.1.1 <3.3.0" --save-dev --save-exact
rm -rf node_modules
npm install




angular-cli