Eclipse, Subclipse এবং Subversive এর জন্য SVN প্লাগইনগুলির পেশাদার এবং বিপরীত কী?




(20)

+1 উপগ্রহ
-1 বিভ্রান্তিকর

Subversive এমনকি ক্ষুদ্র refactoring পরে বিভ্রান্ত এবং উপরের হিসাবে বৈধতা সমস্যা আছে।

পরিবেশ: STS 2.7.2 (গ্যালিলিও উপর ভিত্তি করে)

Eclipse মধ্যে SVN দুই শিবিরে ছড়িয়ে পড়ে। এসভিএন মানুষ Subclipse নামে একটি প্লাগইন উন্নত করেছে। Eclipse মানুষের একটি প্লাগইন নামক Subversive বলা হয়। ব্যাপকভাবে তারা উভয় একই জিনিস বলে। প্রতিটি সুযোগসুবিধা এবং অসুবিধেও কি কি?


Brendons উত্তর যোগ করার জন্য:

আমরা সংস্করণ 1.5.1 থেকে সাবভার্সন ব্যবহার করি এবং প্রথমে উপগ্রহ ব্যবহার করি। কিন্তু আমরা মার্জিং বৈশিষ্ট্যটির উপর পুরোপুরি নির্ভর করে থাকি, আমরা সাবভারসিভে স্যুইচ করেছি যা আরও সুবিধাজনক এবং মার্জিং ডায়লগটিতে একটি পৃথক পুনঃনির্বাচন বিকল্প রয়েছে।

মার্জিংয়ে বাধা দিতে পারে এমন একটি বাগ এটি হল যে আপনি যদি সংশোধনগুলি নির্দিষ্টভাবে নির্বাচন করেন তবে এটি সর্বশেষ সংস্করণ তালিকাভুক্ত করে না। উদাহরণস্বরূপ "101-100" R100 এবং "100" একত্রীকরণ করে না তাই এটিকে একত্রিত করে না। (সংস্করণ 0.7.5)

এবং এটি সিভিএস প্লাগইন হিসাবে একই সূচক ব্যবহার করে।


Subversive উপর উপগ্রহ উপকার ... এটা আসলে কাজ করে!

আমি দীর্ঘকাল আগে সাব্ললিপ্স ব্যবহার করেছি যখন ইক্লিপ্সের জন্য একটি সহযোগী প্লাগইন ডেভেলপ করা যা উপগ্রহের উপর নির্ভরশীল। প্লাগিনের সাবক্রিপ্স অংশটি কোনও সমস্যা ছিল না, যদিও পুরো কী জিনিস এখনও আমাকে একটু বিভ্রান্ত করে তবে ভাল অংশটি কীভাবে এটি ব্যবহার করতে হয় তা জানার জন্য কীভাবে এটি কাজ করে তা বোঝার দরকার নেই।

আমি আজ পিডিটি ইনস্টল করার চেষ্টা করছি (যা একটি সম্পূর্ণ অন্যান্য ব্লগ) এবং তারপরে বিভ্রান্তিকর কারণ অনেকের মতো এটি "দ্য ইক্লিপস এসভিএন প্লাগইন" হিসাবে চিত্রিত। আমি একযোগে চারটি সংযোগকারী ইনস্টল করতে পারিনি, তাই আমাকে একবারে একবার ও একটিতে ইনস্টল করতে হয়েছিল এবং এক সময়ে এটি SVN সার্ভারের সাথে প্রমাণীকরণ করতে পারে নি।

আমি পিডিটি এবং সাবভারভাইভ চেষ্টা করছি, কারণ আমি সময় বাঁচাতে চাই, প্লাগিনের সাথে বিভিন্ন বিষয়গুলিতে এটি বেশি ব্যয় করি না।

আমি সাবস্ক্রাইব আনইনস্টল, ইনস্টল Subclipse, এবং ঠিক অনুরূপ যে।

সময় এবং ঝগড়া নিজেকে সংরক্ষণ করুন, শুরু থেকে Subclipse যান।


অবশ্যই উভয় আইডিই প্লাগইন তাদের সমস্যা আছে। কিন্তু TortoiseSVN বা কমান্ড-লাইনের মতো অন্যান্য সমাধানগুলির সমান্তরাল ব্যবহারকেও সীমাবদ্ধ করে না। আমি কাজ আমার প্রকল্পের জন্য তিনটি ব্যবহার।

মনে রাখা গুরুত্বপূর্ণ বিষয় হল যে আপনার সমস্ত ক্লায়েন্ট এসভিএন সফটওয়্যারটি একই SVN ফাইল ফর্ম্যাট ব্যবহার করতে হবে - যা SVN এর সংস্করণের মধ্যে আলাদা - অথবা আপনি সমস্যার জন্য জিজ্ঞাসা করছেন।

আপনার ক্লায়েন্ট সফ্টওয়্যার সার্ভারের চেয়ে ভিন্ন SVN ফাইল বিন্যাস ব্যবহার করে যখন আমরা খুঁজে পাওয়া আরেকটি সমস্যা। (ফাইল ফরম্যাটের মাধ্যমে, আমার মানে যে সমস্ত তথ্যগুলি দৃশ্যত অদৃশ্য .svn ফাইলগুলিতে উপস্থাপিত হয় যা কার্যকরভাবে আপনার প্রোভিভ ফাইলগুলি সম্পর্কে কোনও SVN সম্পর্কে জানার প্রয়োজন তা রেকর্ড করে।) এটি হতাশাকে ধ্বংস করতে পারে। 1.5 সার্ভার এবং 1.6 ক্লায়েন্টের মধ্যে একটি নথিযুক্ত বাগ আছে, তবে আমি এখনই লিঙ্কটি খুঁজে পাচ্ছি না।

আমাদের SVN 1.5.5 সার্ভারের সাথে অসঙ্গতির কারণে উচ্চতর (আইএমও) উপগ্রহ ক্লায়েন্ট 1.6 প্লাগইনটি চালানোর ক্ষেত্রে আমাদের সমস্যা ছিল। সুতরাং আমরা সাবস্ক্রাইব ফিরে। এটা ঠিক কাজ করে, ধীর এবং কিছুটা বাগ্গী যদিও (কিন্তু উন্নতি)। আমাদের সার্ভার আপডেট করা হয়, যখন আমরা Subclipse সুইচ করতে হবে, যদিও। এবং হ্যাঁ, আমরা TortoiseSVN এর সাথে আমাদের প্রকল্পগুলি পরীক্ষা করে দেখি এবং সেগুলি ইক্লিপসে আমদানি করুন (এটি দ্রুত)।

আমরা খুঁজে পেয়েছি যে, অন্য পোস্টাররা এখানে বলেছিলেন যে, আমরা যদি 1.6.x বিন্যাসে ফাইলগুলি লিখেছে এমন টর্টোইসএসভিএন এর নতুন সংস্করণগুলি চালাতে পারি তবে এটি কাজ করবে না, কিন্তু যখন আমরা TortoiseSVN 1.5.x তে ফিরে যাই, তখন এটি ঠিক কাজ করে। একই কমান্ড লাইন ক্লায়েন্ট (যা আমরা আমাদের Ant কর্মগুলির সাথে লিভারেজ) সত্য ছিল।


আপনি যদি আপনার কোম্পানিতে তাদের একজন ব্যবহার করেন এবং সম্ভবত তাদের নিজস্ব Eclipse- ভিত্তিক পণ্যগুলিতেও বান্ডিল করতে চান তবে আপনার জীবনটি সাবস্লিপ্সের সাথে অনেক সহজ, কারণ এটি ব্যবসা-বান্ধব Eclipse Public License এর অধীনে উপলব্ধ।

অন্যদিকে বিপর্যস্ত তথাকথিত সংযোগকারীগুলিকে সম্পূর্ণরূপে কাজ করার প্রয়োজন। এবং যারা পৃথক এবং বিভিন্ন লাইসেন্স আছে। সুতরাং আপনি শুধুমাত্র সাবস্ক্রাইভ কার্যকারিতাগুলির জন্য দুটি বা তিনটি ভিন্ন লাইসেন্সের সাথে শেষ করতে পারেন, অন্য সমস্ত Eclipse প্লাগইনগুলি কেবলমাত্র একটি EPL এর অধীনে রয়েছে। এ কারণেই সেই সংযোগকারীগুলিকে eclipse.org এ হোস্ট করা হয় না।

এবং এই কারণে তারা সাবভারসিভ ইনস্টলেশনের পরে গতিশীলভাবে ডাউনলোড হয় (যার অর্থ হল eclipse.org আপডেট সাইটটি সহজেই মিরর করা আপনার কোম্পানির নেটওয়ার্কগুলিতে একটি ব্যবহারযোগ্য সাবভারভাইভ অফলাইন ইনস্টলেশন দেয় না)।


আপনি যদি আপনার রিপোজিটরিটি অ্যাক্সেস করতে স্ক্রোল হিসাবে svn + ssh ব্যবহার করেন তবে আমি দৃঢ়ভাবে সুপারভাইপস নির্বাচন করতে পরামর্শ দিই: সাবভারসিভ আপনার প্রমাণপত্রাদি সঠিকভাবে মনে রাখতে যথেষ্ট বুদ্ধিমান নয় এবং ব্যবহারকারীর নাম এবং ব্যক্তিগত কী আপনাকে আপনার কাজের কপি আপডেট করার জন্য প্রত্যেকটি সময় অনুরোধ করে এবং প্রতিটি svn বহিরাগত জন্য আপনি সেট আপ হতে পারে।

এই প্রসঙ্গে "শংসাপত্রগুলি মনে রাখুন" বিকল্পগুলি ভাঙ্গা হয়েছে এবং সাবভারসিভের প্রথম প্রকাশনার পরে এটি হয়েছে।


আমরা আমাদের দলের উভয় চেষ্টা।

সাব্ললিপস (গ্যালিলিও / হিলিওস থেকে একজন) ভাসের মাধ্যমে আমাদের এসভিএন সার্ভারটি প্রমাণীকরণে কিছু সমস্যা ছিল, আমাদের অন্যত্র কোন সমস্যা ছিল না, যেমন টর্টোইএসভিএন ক্লায়েন্ট, ব্রাউজার (ইন্টারনেট এক্সপ্লোরার 7 ছাড়া)।

সুতরাং আমরা সাবস্ক্রাইভ ইনস্টল এবং সমস্যা সমাধান করা হয়েছে।


আমার জন্য ভাল বা খারাপ না, কিন্তু সাবভারভাইভ হল Eclipse Ganymede প্ল্যাটফর্মের ডিফল্ট SVN প্লাগইন, তাই এটি একটি সুযোগ যা এটি ইক্লিপ্সের সাথে আরও ভালভাবে সংহত।


আমি Ganymede থেকে আপগ্রেড করার পর থেকে আমি সাবমেরভ ব্যবহার করছি। আমি লিনাক্সে উকিলস (উবুন্টু এবং ফেডোরা কোর), উইন্ডোজ এক্সপি এবং ম্যাক ওএস এক্স 5 এর সাথে এটি ব্যবহার করি। ম্যাক অপারেটিং সিস্টেমের অধীনে সঠিক সুরক্ষা লাইব্রেরিগুলি ব্যবহার করার জন্য সাবভারশন 1.5.1 পাওয়ার কিছু সমস্যা ছাড়াও আমার কোন সমস্যা নেই। এটি একটি ইক্লিপস প্রযুক্তি প্রকল্পের রূপে গৃহীত হয়েছে বলে মনে করা হয়, দীর্ঘমেয়াদী আশাগুলির ক্ষেত্রে আমি আমার বিটগুলি স্থাপন করতে আগ্রহী।


আমি Subclipse এর সাথে যেতে বেছে নিলাম কারণ এটি সাবভার্সন প্রজেক্টের সাথে ঘনিষ্ঠভাবে জড়িত এবং কোর SVN কার্যকারিতাটি আরও ভালভাবে পরিচালনা করার সম্ভাবনা বেশি। যদি এটি কোনও ফাংশন সম্পাদন করতে ব্যর্থ হয় তবে আমার ব্যাকআপ হিসাবে TortoiseSVN রয়েছে।


আমি আবিষ্কার করেছি যে সাব্ললিপ্সের সাথে কোনও বৈশিষ্ট্যের পার্থক্য কীভাবে দেখুন তা আমি বুঝতে পারছি না। সাবভারভাইভ ইন আপনি ইতিহাস ভিউতে দুটি সংশোধন নির্বাচন করুন, ডান ক্লিক করুন এবং পপআপ থেকে বৈশিষ্ট্য তুলনা নির্বাচন করুন। এটা আমার জন্য সাবক্রিভিক সঙ্গে আটকাতে যথেষ্ট।

সুইচ করার চেষ্টা করার কারণ ছিল ওএস এক্স-তে সাভারসভাইভের অদ্ভুত আচরণ: 'svn ক্যাশে আপডেট' নামে কিছু স্বয়ংক্রিয় অপারেশন সিউনকে প্রতিটি 'svn আপডেট' চালানোর পরে অস্বাভাবিক স্তরে হগ করে ফেলে, সর্বদা একটি বিরক্তিকর দীর্ঘ সময় নিচ্ছে।


আমি আসলে তাদের উভয় ধরনের স্তন্যপান মনে। TortoiseSVN ব্যবহার করে আমার মতে একটি অনেক ভাল সমাধান। এটি অনেক বেশি শক্তিশালী এবং কেবল ভাল কাজ করতে থাকে এবং আমি সর্বদা উপগ্রহ এবং সাবস্ক্রাইভের সাথে একীকরণ সমস্যা করেছি।


আমি উভয়ই ব্যবহার করেছি, এবং যখন সাব্লিপপ্স আমার জন্য ফ্যাকাশে হয়েছে, সাবক্রিভভ (কমপক্ষে পূর্ববর্তী সংস্করণের সাথে) আমার সহকর্মীর অ্যাকাউন্ট বন্ধ করে দিয়েছে যখন সে ভুলভাবে ভুল প্রমাণপত্রাদি দেয় (নেটওয়ার্ক লগইনটি সাবভার্সন রিপোজিটরিটি অ্যাক্সেস করতে ব্যবহৃত হয়) )।

Subclipse সময় সঙ্গে অসংগঠিত পেতে থাকে। যদি Eclipse নিয়মিত রিফ্রেশ না হয় Subclipse তার ফাইল ট্র্যাকিং তথ্য হারান বলে মনে হয়। আন্তরিকভাবে, আমার কাছে ইজ এক্সপ্লোরার প্লাগইন রয়েছে , তবে আমি ইতিহাসের জন্য সাবভারসিভ (মাঝে মাঝে) ব্যবহার করি এবং তথ্য পরিবর্তন করি, তবে আমি সম্প্রতি পরিবর্তন করেছি এমন প্রকল্পগুলিতে সম্পাদন এবং আপডেটগুলির জন্য আমি সহজেই অনুসন্ধান এবং টারটোয়েসএসভিএন ব্যবহার করি।


আমি এই উত্তর একটি ফাটল নিতে হবে। আমি সাবclipse এর জন্য একটি প্রকল্প সীসা এবং প্রকল্পটির জন্য আমি সমস্ত রিলিজগুলি পরিচালনা করি। তাই আমার পক্ষপাত সুস্পষ্ট।

আমি বিভ্রান্তিকর সম্পর্কে খুব বেশি কথা বলতে যাচ্ছি না। স্পষ্টতই, ব্যবহারকারীরা এটি ব্যবহার করে এবং এটি পছন্দ করেন। উভয় পরিপক্ক পণ্য হিসাবে কার্যকরী পণ্য খুব অনুরূপ।

এক জিনিস যা আমি মন্তব্য করতে চাই তা হল এই ধারণার যে যেকোনোভাবে সাবভারভাইভ "অফিসিয়াল ইক্লিপস" প্লাগইন। যে ঠিক যেমন সত্য, যে কোন নাম নেই। Eclipse একটি ওপেন সোর্স ফাউন্ডেশন এবং যে কোন প্রকল্প তাদের নিয়ম, প্রক্রিয়া এবং আইপি প্রয়োজনীয়তা অনুসরণ করতে চায় ইত্যাদি। তাদের প্রকল্পটি ভিত্তি করে হোস্ট করে। যে কোন প্লাগইন তুলনায় আপনি আরো বা কম অফিসিয়াল না।

আমি এটাও মনে করব যে সাবমেরভিভটি তার সূচনা থেকে "ইনকুইবেশন" পর্যায়ে রয়ে গেছে, এবং এটা আমার কাছে উপস্থিত হয় না যে এটি সর্বদা স্নাতকের জন্য প্রয়োজনীয়তা পূরণ করবে। আপনি এখানে দেখতে পারেন, প্রকল্পে শুধুমাত্র একটি কমিটি হয়েছে এবং কমিটি খুব কম মাত্রায় dwindled হয়েছে।

বিচ্ছিন্ন - SVN টিম সরবরাহকারী

তাহলে কেন আপনি উপগ্রহ ব্যবহার করতে হবে? আমরা সক্রিয়ভাবে Subversion সঙ্গে জড়িত হয়। আমি একটি সাবভার্সন পিএমসি সদস্য এবং জাভা ভাষার বাইন্ডিংগুলিকে বজায় রাখতে সহায়তা করি যাতে আমরা (এবং অন্যান্য প্রকল্পগুলি সাবভারসিভ) API ব্যবহার করতে পারি।

API এ সংজ্ঞায়িত এবং উন্নত করতে আমরা সাবভার্সনের সাথে সরাসরি কাজ করি এবং সাব্ললিপ্সের মতো ক্লায়েন্টদের প্রয়োজনীয় বৈশিষ্ট্যগুলি নিশ্চিত করা যায়। আমরা ক্লায়েন্ট জুড়ে একটি অপেক্ষাকৃত সামঞ্জস্যপূর্ণ ব্যবহারকারী অভিজ্ঞতা নিশ্চিত করতে ভিসুয়াল স্টুডিও ইন্টিগ্রেশন ( AnkhSVN ) এবং TortoiseSVN টিমের সাথে ঘনিষ্ঠভাবে কাজ করে এবং সহযোগিতা করি।

উপগ্রহ এখনও সক্রিয়ভাবে রক্ষণাবেক্ষণ করা হয় এবং আমরা Eclipse সংস্করণ 3.2 থেকে 4.2 সংস্করণের জন্য সমর্থন বজায় রাখি। আমরা সবসময় প্রতিক্রিয়া শুনতে এবং সম্প্রদায় থেকে ধারনা অন্তর্ভুক্ত করার চেষ্টা করা হয়। সাম্প্রতিক 1.8.x রিলিজগুলিতে অভ্যন্তরীণ পরিবর্তনগুলি অন্তর্ভুক্ত রয়েছে যা বড় প্রকল্পগুলির সাথে কাজ করার সময় প্রচুর পরিমাণে Eclipse এর কর্মক্ষমতা উন্নত করে (যেটি আপনি যখন এটি দেখতে পান)।

সাবক্রিপসে মার্জ ট্র্যাকিং সহায়তার মতো ক্ষেত্রগুলিতে নেতৃত্ব সৃষ্টি করেছেন, যেখানে আমরা 1.5 টির মধ্যে এই বৈশিষ্ট্যটি যোগ করার পরে সদৃশ টিমের সাথে ঘনিষ্ঠভাবে কাজ করেছিলাম এবং তারপরে পরবর্তী সংস্করণগুলিতে এটির বিকাশ ঘটে। আমরা প্রায়ই নতুন API এর প্রাথমিক ভোক্তাদের ছিলাম এবং বৈশিষ্ট্যটি শক্ত করার জন্য প্রয়োজনীয় প্রতিক্রিয়ার সাথে প্রকল্পটি সরবরাহ করেছি। আমরা কয়েক বছর আগে একটি গ্রাফিকাল পুনর্বিবেচনা গ্রাফ বৈশিষ্ট্যটিও চালু করেছি, এটি Eclipse ব্যবহারকারীদের কাছে এই দীর্ঘ জিজ্ঞাসা করার বৈশিষ্ট্যটি আনতে প্রথম হয়ে উঠছে।

সাবক্রিভারে নির্দিষ্ট UI বৈশিষ্ট্য থাকলে উপগ্রহে তৈরি করা লোকেরা দেখতে চায়, আমি আপনাকে আমাদের সম্প্রদায়ের সাথে দেখা করতে এবং আমাদের আলোচনার ফোরামগুলিতে যোগ দিতে উত্সাহিত করব। হয়তো অন্যান্য ব্যবহারকারীরা আপনার মতামত ভাগ করে নেবে এবং আমরা একসাথে UI কে উন্নত করতে পারি।

ফোরাম [Subclipse-users]

ইক্লিপস 4.2 এই পোস্টের সর্বশেষ সংস্করণ, তবে এটি অনুমান করা নিরাপদ যে সাব্ললিপস ভবিষ্যতে অ্যাককিপ্স রিলিজগুলি যেভাবে তৈরি করা হয়েছে সেগুলিকে সমর্থন করবে।


উপগ্রহ, কারণ অন্তত এটি কাজ করে।

Subversive এতদূর আমার জন্য ব্যর্থ একটি বালতি হয়েছে। আমি সাবclipse সঙ্গে চেক আউট আমার পুরানো প্রকল্প সব সুন্দর সঙ্গে খেলা হবে না।


উভয় খুব অনুরূপ কিন্তু Subversive হয় "গ্রহনযোগ্য svn প্রদানকারী"। আমি মূলত কয়েক সুবিধাজনক বৈশিষ্ট্যগুলির কারণে সাবমেরভ ব্যবহার করি:

ইতিহাস গ্রুপ

যখন আমি প্রতিটি শাখার সারির একটি গুচ্ছ দেখতে শুধুমাত্র শাখার ইতিহাস ব্রাউজ করছি তখন এটি আজ, সপ্তাহ, ইত্যাদি দ্বারা গোষ্ঠী তৈরি করতে পারে।

ট্রাঙ্ক, শাখা, এবং ট্যাগের ম্যাপিং

বিপর্যয়কারী ডিফল্ট svn লেআউট অনুমান করে: ট্রাঙ্ক, শাখা, ট্যাগগুলি (যা আপনি পরিবর্তন করতে পারেন), তাই যখনই আপনি ট্যাগ করতে বা শাখা করতে চান তখন এটি একটি ক্লিক এবং আপনি ট্যাগ বা শাখাটির নাম সরবরাহ করেন।

যেমন আমি বলেছি এই ছোটখাট পার্থক্য যা আমি সহজেই খুঁজে পাচ্ছি। উভয় mylyn সঙ্গে মহান কাজ, কিন্তু সামগ্রিকভাবে এই দুটি এক্সটেনশন সঙ্গে পার্থক্য একটি সম্পূর্ণ অনেক নেই।

Subversive সঙ্গে মার্জ একটি ব্যথা যদিও (Subclipse চেষ্টা না), আমি সফলভাবে একত্রিত করতে সক্ষম হয়েছে না। মার্জ পূর্বরূপটি দুর্দান্ত তবে এটি মার্জ সম্পূর্ণ করবে না বা এটি দীর্ঘতর পথ গ্রহণ করবে। অধিকাংশ সময় আমি কোন সমস্যা ছাড়াই কমান্ড লাইন মাধ্যমে মার্জ সম্পূর্ণ।


এফডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউউডব্লিউআইডব্লিউউডব্লিউআইডব্লিউউডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউআইডব্লিউএইচএস যাইহোক এসভিএন "।

বিভ্রান্তিকর শুধুমাত্র পুরোনো সংস্করণ হ্যান্ডেল করতে সক্ষম বলে মনে হচ্ছে। আমি দুঃখিত, যদিও, বিবরণ মনে করতে পারেন না।


তাদের উভয়ই বেশ জঘন্য মার্টিন রয়েছে, কিন্তু আমি কমান্ড লাইন থেকে চেক করা একটি প্রকল্পের সাথে কাজ করার জন্য সাবমেরভিস্ট পেতে পারিনি, এবং এটি আমার জন্য শো-স্টপার ছিল।


মে 2008 পর্যন্ত আমি সাব্ললিপ্স ব্যবহার করছিলাম, কিন্তু কিছু প্রকল্প নিয়ে সমস্যাগুলির কারণে, আমি সাবভারসিভের উপর স্যুইচ করেছি এবং কোনও সমস্যা ছাড়াই এটি ব্যবহার করছি। আপনি যদি শিরোনামহীন Buckminster মতো কিছু অভিনয় করছেন তবে তারপরেও সাবভারসিভটি যেতে হবে।


শুধু একটি আপডেট। আমি সম্প্রতি ইক্লিপস পুনরায় ইনস্টল করা ছিল এবং Subclipse বনাম সাবস্ক্রাইভ পছন্দ সঙ্গে সম্মুখীন হয়েছিল। আমিও, আমার সমস্যাগুলি ভাগ করে নেওয়ার চেষ্টা করার জন্য সমস্যাগুলি ভাগ করে নেব যাতে আমি উপগ্রহের জন্য যাই।

এটি আমার লিনাক্স 64 বিট মেশিনে পুরোপুরি ইনস্টল হয়েছে এবং ঠিক আছে। আমি শর্টকাটে আপডেট, Commit, .. ইত্যাদি সবচেয়ে সাধারণ ফাংশন mapped এবং এটি একটি বিস্ফোরণ। মার্জিং খুব ভাল, যদিও বড় মজাদার জন্য আমি এখনও TortoiseSVN চালু। আমি 3.5 এবং 3.6 উভয় দিয়ে এটি চেষ্টা করেছি, এবং তারা উভয় জরিমানা কাজ। আমি 3.5 ব্যবহার করে শেষ পর্যন্ত কারণ কিছু কারণের জন্য বাঁধাই 3.6 সঙ্গে কাজ করা হয় না।







subversive