ios - xcode for windows




FBSOpenApplicationErrorDomain code=4 Fehler (8)

Öffnen Sie Ihre App-Schema-Einstellung und bearbeiten Sie sie wie in der beigefügten Screenshot gezeigt, Eigentlich müssen Sie deaktivieren "Starten wegen Hintergrund holen". Arbeitete für mich. Schritte, 1. Wählen Sie Ihr Ziel und wählen Sie "Schema bearbeiten" 2. Wählen Sie die Registerkarte "Optionen" auf der rechten Seite des Detailfensters 3. Deaktivieren Sie das Kontrollkästchen "Durch Hintergrundabruf starten".

Wenn ich versuche, iOS-Anwendung in Xcode 6 in iPhone 6-Simulator auszuführen, erhalte ich die Fehlermeldung , dass die App im Simulator nicht ausgeführt werden kann .

Und der Fehlercode ist:

Beim Ausführen ist ein Fehler aufgetreten (Domain = FBSOpenApplicationErrorDomain, Code = 4)

Kann jemand vorschlagen, wie man es löst?


Beenden Sie einfach die xcode6.0-Beta oder sonst und führen Sie das Projekt erneut aus, es hat für mich funktioniert.


Das Zurücksetzen des Xcodes löscht etwas schlechten Müll, den der Simulator zwischengespeichert hat, daher ist das Zurücksetzen eine gute Option, um dieses Problem zu lösen.

iOS Simulator -> Inhalt und Einstellungen zurücksetzen.



Ich habe den Simulator einfach verlassen, das Projekt aufgeräumt und wieder gelaufen, es hat funktioniert.


Keine Notwendigkeit, den Simulator zu verlassen oder den gesamten Inhalt jedes Mal zurückzusetzen.

Schließen Sie einfach die App, auf der Sie gerade arbeiten, wenn Sie im Hintergrund arbeiten.

Für mich geht das .


Trennen Sie die Hardwaretastatur. Im ios-Simulator-Hauptmenü Hardware -> Tastatur -> Hardware-Tastatur trennen.


Wie in den Xcode-Versionshinweisen erwähnt, resultiert dieser Fehler (zusammen mit einigen anderen) aus einem Timing-Fehler. Die Problemumgehung besteht darin, es einfach erneut zu versuchen.

Siehe https://developer.apple.com/library/prerelease/mac/releasenotes/DeveloperTools/RN-Xcode/Chapters/xc6_release_notes.html#//apple_ref/doc/uid/TP40001051-CH4-SW1

Das Testen auf dem iOS-Simulator kann zu einem Fehler führen, der angibt, dass die Anwendung nicht installiert oder gestartet werden konnte. Führen Sie den Test erneut aus oder starten Sie eine andere Integration.

Siehe auch:

https://devforums.apple.com/thread/248879?tstart=0





iphone-6