tutorial - android studio proxy settings




Wie wähle ich Android SDK in Android Studio aus? (20)

Nach einem erfolgreichen Import eines Eclipse-Android-Projekts in "Android Studio 1.4" erhalte ich den Fehler

"Bitte Android SDK auswählen"

Wenn ich auf die Schaltfläche klicke, um die Anwendung im Simulator auszuführen, kann ich dies jedoch nicht tun.

Dieser Dialog öffnet sich, wenn ich auf "Ausführen" klicke:

Dies ist der "Projektstruktur" -Dialog:

Was sollte ich jetzt tun?


Ändere einfach die Build-Tools-Version auf 25.0.3 und synchronisiere sie jetzt. Ich hoffe, es hilft.


Öffnen Sie die Datei build.gradle. Fügen Sie einfach ein Leerzeichen hinzu oder drücken Sie die Eingabetaste. Synchronisiere dann das Projekt. Es klappt...


Android Support Repository, Android SDK Platform 28 und 3 weitere SDK-Komponenten wurden nicht installiert. Geben Sie hier eine Bildbeschreibung ein

Da ich die JDK-Datei installiert habe und sie in Eclipse gut funktioniert und ich mit der Arbeit in Android Studio beginnen möchte, aber wenn ich das gesamte Paket von SDK Manager installiere, zeige ich, dass keine Installation durchgeführt wurde, bitte helfen Sie mir.


Das hat bei mir funktioniert.

Datei -> Einstellungen -> Android SDK -> Android SDK-Speicherort bearbeiten -> Android SDK


Die Menüstruktur und die Optionen haben sich seit Android 3.2.0 geringfügig geändert. Ich habe diesen Fehler behoben, indem ich das Modul-SDK im folgenden Menü geändert habe:

Datei> Projektstruktur> Module> Anwendungsdatei> Registerkarte Abhängigkeiten> Modul-SDK

Stellen Sie sicher, dass Sie auf Übernehmen klicken , um Ihre Änderungen zu speichern.


Die einfachste Lösung für dieses Problem:

Stellen Sie zunächst sicher, dass Ihr SDK-Pfad korrekt ist. Dann schließen Sie bitte das aktuelle Projekt und klicken Sie im Android-Startmenü auf Projekt importieren und wählen Sie Ihr Projekt aus dem Explorer. Dies wird immer mein Problem lösen


Drücken Sie " ⌘ + Shift + A " auf dem Mac (oder " Ctrl + Shift + A " auf Windows) und schreiben Sie im Popup-EditText " Sync Project with Gradle Files ". Danach doppelklicken Sie auf die erscheinende Option. Anschließend wird Ihr Gradle-Datei-SDK mit der Projektdatei synchronisiert.


Drücken Sie die erste Aktualisierungsschaltfläche auf der vertikalen Registerkarte gradle in Android Studio auf der rechten Seite


Gehen Sie einfach zur build.gradle Datei (auf App-Ebene) , geben Sie irgendwo eine leere Stelle ein und klicken Sie auf " Synchronisieren" . Sobald die Synchronisierung abgeschlossen ist, ist der Fehler behoben


Gehen Sie zu: Datei> Projektstruktur> Module -> App> Eigenschaften

Bitte wählen Sie: Compile 'SDK' version = API26 Build Tools Version = 27.0.0 Quellkompatibilität = 1.8 Zielkompatibilität = 1.8


Ich gehe zu build.gradle und build.gradle auf " Synchronisieren" . Dann hat es geklappt.

Update :

File -> Sync Project with Gradle Files (Android Studio 3.1.1)

Tools -> Android -> Sync Project with Gradle Files (Android Studio 3.0.1)

Oder Sie können auf das Symbol in der Symbolleiste klicken.

Diese Antwort hilft möglicherweise nicht bei späteren Versionen, da das Android Studio Team daran arbeitet, das Tool besser zu machen. In der nächsten Version von Android Studio wird die Synchronisierung möglicherweise anders durchgeführt.

HÄUFIG hilfreich ist möglicherweise der Versuch, das Projekt zu synchronisieren, die Caches zu ungültig zu machen und Android Studio neu zu starten .

Lösung für Android Studio 3.1.2 [Siehe Antwort unten]

Siehe Neueste Android Studio-Version


Ich hatte dieses Problem auf allen Versionen von AS 3.0+. Das Synchronisieren mit gradle hat das Problem für mich nicht gelöst. Die Lösung von András Klöczl war das einzige, mit dem ich etwas programmieren konnte. Das Problem war, dass jedes Mal, wenn ich eine Gradle-Synchronisierung durchführen musste, das Problem zurückkam. Also musste ich diesen Prozess jedes Mal durchlaufen, wenn ich eine Änderung in meinem build.gradle . Für mich funktionierte es schließlich, meine Kotlin-Version von 1.2.40 auf 1.2.30


In meinem Fall gibt es in der Projektstruktur keine ausgewählte Java SDK-Version.

Ich musste das - auswählen

1.Quellenkompatibilität (1.7)

2. Zielkompatibilität (1.7)

wie im Bild gezeigt.


In meinem Fall habe ich ein Git-Repository für ein Android-Projekt heruntergeladen. Das Projekt erforderte mindestens SDK-Version 21 und Ziel-SDK-Version 27. Als ich versuchte, das Projekt auszuführen, gab es mir "Bitte wählen Sie Android SDK-Fehler". Ich habe überprüft, ob ich die erforderlichen SDK-Dateien bereits heruntergeladen habe.

Für mich war die Lösung "Projekt mit Gradle Files synchronisieren"


Manchmal wirkt Android Studio einfach nur dumm und braucht eine Art Reset.

Gehe zur settings.gradle- Datei, die das include ':app'
ändere es so, include ':ap' und sync enthält.
Ändern Sie es nach der Synchronisierung wieder in include ':app' .

Es sollte jetzt funktionieren.


Mein Problem war, dass dieser Fehler auftrat, wenn ich das Projekt änderte (zum Beispiel ein neues Fenster von Android Studio mit einem anderen Projekt öffnete).

Daher habe ich jede Antwort in dieser Frage gelesen und die Lösung "Caches löschen und Projekt erneut öffnen" war in meinem Fall nicht so nützlich.

Stattdessen stellte ich fest, dass das Problem auftrat, wenn die Version des Kotlin-Plugins in Android Studio niedriger war als in der gradle-Datei.

Mein Setup war:

  • Android Studio 3.1.3
  • Kotlin-Plugin (in Android Studio) 1.2. 30
  • Kotlin-Version in Gradle-Datei 1.2. 51

Was hat das Problem behoben?

Ich habe das Kotlin-Plugin aktualisiert:

Datei -> Einstellungen -> Plugins -> JetBrains-Plugin installieren ...

Suchen Sie dann nach Kotlin und klicken Sie auf Aktualisieren. Nach dem Update starte einfach das Android Studio neu und synchronisiere Gradle.


Wenn Sie "Profile or Debug APK ..." verwenden, tritt möglicherweise dieser Fehler auf.

Meine Lösung besteht darin, das SDK zuerst im SDK-Manager auf Aktualisierungen zu überprüfen: Klicken Sie rechts neben dem SDK-Speicherort auf "Bearbeiten" und installieren Sie alle Aktualisierungen:

Dann habe ich unten in Android Studio auf "Logcat" geklickt und festgestellt, dass ich auch Android SDK konfigurieren muss. Wählen Sie also die neueste Android API-Plattform:

Danach kann ich die APK im Emulator ausführen.


Wenn dein Android SDK-Pfad angegeben ist und du immer noch mit diesem Problem konfrontiert bist, kann dies daran liegen, dass dein Android Studio nicht richtig synchronisiert wurde, selbst wenn du auf den Link " Jetzt synchronisieren" geklickt hast.

Zum erneuten Synchronisieren gehen Sie auf die App-Gradle- Datei und nehmen Sie die gewünschten Änderungen vor oder geben Sie einfach ein Leerzeichen ein und synchronisieren Sie sie erneut. Es wird perfekt funktionieren.


EditText "Ctrl+shift+A" und schreiben Sie im EditText "Sync Project with Gradle Files" EditText "Sync Project with Gradle Files" EditText "Sync Project with Gradle Files" . Danach doppelklicken Sie auf die erscheinende Option. Anschließend wird Ihr Gradle Datei- SDK mit der Projektdatei synchronisiert.


Folge diesen Schritten:

  • Gehen Sie zu den Android Studio-Einstellungen
  • Suchen Sie mit der Suchleiste nach "Android SDK"
  • Stellen Sie sicher, dass der Pfad zu Ihrem Android SDK-Ordner korrekt ist.
  • Stellen Sie danach auch sicher, dass der Pfad nach einer Eingabeaufforderung in Ihrer Projektdatei (local.properties) automatisch aktualisiert wird. Wenn nicht, machen Sie es manuell.

Hoffe das hilft.





eclipse-project-file