'FEHLER: Fehler beim Auflösen von: com.android.support:appcompat-v7:29.0.1'



gradle intellij-idea (1)

Ich möchte Intellij Platform für die Android-Entwicklung ausprobieren, aber auch nach dem ersten Start zeigt es gradle Fehler. Bitte helfen Sie.

Ich habe versucht, die Linie zu optimieren

implementation 'com.android.support:appcompat-v7:29.+'

zu einigen anderen Versionen, aber ohne Erfolg.

Hier ist meine Modulstufe gradle

    apply plugin: 'com.android.application'

android {
    compileSdkVersion 29
    buildToolsVersion "29.0.1"
    defaultConfig {
        applicationId "com.example.myapplication"
        minSdkVersion 23
        targetSdkVersion 29
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    implementation 'com.android.support:appcompat-v7:29.+'
    implementation 'com.android.support.constraint:constraint-layout:1.1.3'
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
}

Hier ist mein Projektlevel Gradle

// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
    repositories {
        google()
        jcenter()

    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.1.0'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        google()
        jcenter()

    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

Die Fehler, die ich bekomme, während Intellij die Gradles baut, sind

ERROR: Unable to resolve dependency for ':[email protected]/compileClasspath': Could not find any version that matches com.android.support:appcompat-v7:29.+.
Show Details
Affected Modules: app


ERROR: Unable to resolve dependency for ':[email protected]/compileClasspath': Could not find any version that matches com.android.support:appcompat-v7:29.+.
Show Details
Affected Modules: app


ERROR: Unable to resolve dependency for ':[email protected]/compileClasspath': Could not find any version that matches com.android.support:appcompat-v7:29.+.
Show Details
Affected Modules: app


ERROR: Unable to resolve dependency for ':[email protected]/compileClasspath': Could not find any version that matches com.android.support:appcompat-v7:29.+.
Show Details
Affected Modules: app


ERROR: Unable to resolve dependency for ':[email protected]/compileClasspath': Could not find any version that matches com.android.support:appcompat-v7:29.+.
Show Details
Affected Modules: app


ERROR: Failed to resolve: com.android.support:appcompat-v7:29.0.1
Affected Modules: app

Migrieren Sie zu androidX, indem Sie gehen zu:

Refactor->Migrate to androidX





appcompatactivity