ios - Flattern: So beheben Sie ITMS-90809: Veraltete API-Nutzung-Apple akzeptiert keine Einsendungen von Apps, die UIWebView-APIs verwenden




flutter (2)

Ich denke, es wurde vom firebase_auth-Plugin verwendet. Versuchen Sie, es auf die neueste Version zu aktualisieren, und führen Sie anschließend das Pod-Update aus .

Beim Einreichen meines neuesten Builds gab Apple plötzlich eine Nachricht zurück, dass ein Problem aufgetreten ist, insbesondere:

ITMS-90809: Veraltete API-Verwendung - Apple akzeptiert keine Apps mehr, die UIWebView-APIs verwenden. Weitere Informationen finden Sie unter https://developer.apple.com/documentation/uikit/uiwebview .

Da ich das Webview-Plugin nicht verwende, weiß ich nicht, wo die UIWebView API verwendet wird. Irgendwelche Ratschläge zur Lösung dieses Problems?

Dieser Fehler tritt mit dem neuesten stabilen Flutter Build 1.7.8 + Hotfix.4 und den folgenden enthaltenen Paketen auf:

http: ^0.12.0
shared_preferences: ^0.4.3
intl: any
permission_handler: ^2.1.2
contacts_service: ^0.2.8
image: ^2.0.5
cached_network_image: ^1.0.0
url_launcher: ^5.0.1
path_provider: ^0.5.0+1
after_layout: ^1.0.7
connectivity: ^0.4.3+1
device_info: ^0.4.0+2
firebase_auth: ^0.11.1+7
firebase_messaging: ^5.1.2
firebase_analytics: ^5.0.0
notification_permissions: ^0.4.0

Alle Pakete wurden auf die neueste Version aktualisiert.

Die Ausgabe von flutter doctor ist:

[] Flutter (Channel stable, v1.7.8+hotfix.4, on Mac OS X 10.14.6 18G87, locale en-US)Flutter version 1.7.8+hotfix.4 at /Users/per/flutter
    • Framework revision 20e59316b8 (6 weeks ago), 2019-07-18 20:04:33 -0700Engine revision fee001c93f
    • Dart version 2.4.0

[] Android toolchain - develop for Android devices (Android SDK version 28.0.3)Android SDK at /Users/per/Library/Android/sdk
    • Android NDK location not configured (optional; useful for native profiling support)Platform android-28, build-tools 28.0.3Java binary at: /Applications/Android Studio.app/Contents/jre/jdk/Contents/Home/bin/java
    • Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1136-b06)All Android licenses accepted.

[] Xcode - develop for iOS and macOS (Xcode 10.3)Xcode at /Applications/Xcode.app/Contents/DeveloperXcode 10.3, Build version 10G8CocoaPods version 1.7.4

[] iOS tools - develop for iOS devices
    • ios-deploy 1.9.4

[] Android Studio (version 3.2)Android Studio at /Applications/Android Studio.app/ContentsFlutter plugin version 31.3.1Dart plugin version 181.5656Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1136-b06)

[] VS Code (version 1.31.1)VS Code at /Applications/Visual Studio Code.app/ContentsFlutter extension version 2.25.1

[] Connected device (1 available)Nexus 6P5VT7N15C31001152 • android-arm64 • Android 8.1.0 (API 27)No issues found!

Ich habe dies mit unserer Cordova-App behoben und eine Abhängigkeit aktualisiert.

Verwenden Sie zufällig die Abhängigkeit oder eine andere Abhängigkeit die Abhängigkeit "cordova-plugin-inappbrowser"?

Wenn ja, sollte dies in 3.1.0 behoben werden. Siehe die Versionshinweise https://github.com/apache/cordova-plugin-inappbrowser/blob/master/RELEASENOTES.md und die PR-Korrektur https://github.com/apache/cordova-plugin-inappbrowser/pull/271

Update: Es ist noch nicht behoben. Siehe Problem bei Cordova-ios: https://github.com/apache/cordova-ios/issues/661 Hinweis: Es gibt keine Frist. Ich habe einen Apple-Entwickler kontaktiert, der über den Wechsel zu WKWebView getwittert hat, um festzustellen, ob Er kann weitere Informationen bereitstellen und wird aktualisiert, wenn ich eine Antwort erhalte.