ios - Xcode wird nach dem Update auf MacOS Catalina nicht geöffnet




(2)

Ich habe auf MacOS Catalina aktualisiert und jetzt öffnet sich mein Xcode nicht. Ich erhalte diese Aufforderung:

Was nach dem Root-Zugriff zu diesem Fehler führt:

Es gibt ein riesiges Protokoll, aber die wichtigsten Fehler sind:

2019-11-04 12: 39: 48 + 05 tk_lpt_0141_wifi Xcode [1214]: Paket: PKLeopardPackage Fehler beim Überprüfen: Fehler Domain = PKInstallErrorDomain Code = 102 "Das Paket" MobileDeviceDevelopment.pkg "ist nicht vertrauenswürdig." UserInfo = {NSLocalizedDescription = Das Paket "MobileDeviceDevelopment.pkg" ist nicht vertrauenswürdig., NSURL = MobileDeviceDevelopment.pkg - Datei: ///Applications/Xcode.app/Contents/Resources/Packages/, PKInstallPackageIdentifier = com.apple.pkg.MobileIdentifier , NSUnderlyingError = 0x7fe07012cad0 {Fehlerdomäne = NSOSStatusErrorDomain-Code = -2147409654 "CSSMERR_TP_CERT_EXPIRED" UserInfo = {SecTrustResult = 5, PKTrustLevel = PKTrustLevelExpiredCertailFail} 201LocalLocal

13: 01: 20 + 05 tk_lpt_0141_wifi Xcode [1306]: Paket: PKLeopardPackage Fehler beim Überprüfen: Fehler Domain = PKInstallErrorDomain Code = 102 "Das Paket" MobileDeviceDevelopment.pkg "ist nicht vertrauenswürdig." UserInfo = {NSLocalizedDescription = Das Paket "MobileDeviceDevelopment.pkg" ist nicht vertrauenswürdig., NSURL = MobileDeviceDevelopment.pkg - Datei: ///Applications/Xcode.app/Contents/Resources/Packages/, PKInstallPackageIdentifier = com.apple.pkg.MobileIdentifier , NSUnderlyingError = 0x7fd230cb1ae0 {Fehlerdomäne = NSOSStatusErrorDomain-Code = -2147409654 "CSSMERR_TP_CERT_EXPIRED" UserInfo = {SecTrustResult = 5, PKTrustLevel = PKTrustLevelExpiredCertCertCertCertLailF-11

13: 29: 51 + 05 tk_lpt_0141_wifi Xcode [1377]: Paket: PKLeopardPackage Fehler beim Überprüfen: Fehler Domain = PKInstallErrorDomain Code = 102 "Das Paket" MobileDeviceDevelopment.pkg "ist nicht vertrauenswürdig." UserInfo = {NSLocalizedDescription = Das Paket "MobileDeviceDevelopment.pkg" ist nicht vertrauenswürdig., NSURL = MobileDeviceDevelopment.pkg - Datei: ///Applications/Xcode.app/Contents/Resources/Packages/, PKInstallPackageIdentifier = com.apple.pkg.MobileIdentifier , NSUnderlyingError = 0x7f8ab8ba9380 {Fehlerdomäne = NSOSStatusErrorDomain Code = -2147409654 "CSSMERR_TP_CERT_EXPIRED" UserInfo = {SecTrustResult = 5, PKTrustLevel = PKTrustLevelExpiredCertificate, NSLocal

Ich habe schon versucht:

xcode-select --install

und

xcode-select --reset

Ist noch jemand auf dieses Problem gestoßen? Wie man es repariert?


Was für mich funktioniert hat, war die Aktualisierung von Xcode im App Store. Danach konnte ich die zusätzlichen Komponenten erfolgreich installieren.


Ändern Sie einfach Ihr MacOS-Datum auf

1st October 2019

Ich habe meine Systemzeit auf den 1st October 2019 wenn das Zertifikat noch gültig sein sollte. Danach habe ich versucht, Xcode zu öffnen und bin der Installation der Komponente gefolgt, die gut gelaufen ist. Jetzt kann ich wieder mit Xcode arbeiten.

Bearbeiten und stellen Sie das Datum Ihres Macs als 1st October 2019 .







xcode