Android-Entwicklung: api 14 vs api 15



xbmc plugins (2)

Ich möchte eine App für Android Ice Cream Sandwich und Versionen oben entwickeln. Also, was ich entdecke, ist, dass Android 4.0 api 14 und Android 4.0.3 api 15 unterstützt. Schauen Sie sich das Dashboard http://developer.android.com/about/dashboards/index.html . Es scheint, dass niemand android ics 4.0 hat, sondern nur 4.0.3 oder 4.0.4. Das ist wichtig, denn wenn es so aussieht, wie es scheint, werde ich die App mit api 15 und nicht mit 14 entwickeln. Ich bin mir jedoch sicher, dass niemand Android in seiner Version 4.0.0 hat. Können Sie die Daten im Dashboard bestätigen? Ich meine, sollten Sie bestätigen, dass Android Ice Cream Sandwich auf Geräten nur in den Versionen 4.0.3 und 4.0.4 vorhanden ist? Vielen Dank


Google hat den Herstellern angezeigt, dass Android 4.0.3 als Basisversion für ics verwendet werden soll. Es hat auch allen Herstellern empfohlen, automatische Updates für 4.0.3 bereitzustellen.

Ich habe keine Ahnung von Nutzungsstatistiken von Geräten mit Versionen vor 4.0.3, aber ich denke, es wird eine Minderheit der Geräte sein.


Weniger als 0,05% der Geräte sind auf 4.0, 4.0.1 oder 4.0.2, weshalb es nicht auf http://developer.android.com/about/dashboards/index.html angezeigt wird. Ähnlich verwenden weniger als 0,05% der Geräte 2,0 oder 2,0,1 und dasselbe wie 3,0.

Sie können sicher für die APIs 8, 10, 13, 15, 16, 17, 18 und 19 ( ab dem 28. Dezember 2013 ) entwickeln und auf die verbleibenden neun API-Ebenen verzichten (obwohl es selten einen Grund dafür gibt). Wenn möglich, möchten Sie vielleicht auch weiterhin API 7 unterstützen, da es gerade erst von den Dashboards verschwunden ist. (0,05% von einer Milliarde Geräte sind immer noch einige!)





level