python - win_amd64 - filename.whl is not supported wheel on this platform




torch-0.4.1-cp37-cp37m-win_amd64.whl is not a supported wheel on this platform. (16)

I would like to install scipy-0.15.1-cp33-none-win_amd64.whl that I have saved to local drive. I am using:

pip 6.0.8 from C:\Python27\Lib\site-packages
python 2.7.9 (default, Dec 10 2014, 12:28:03) [MSC v.1500 64 bit (AMD64)]

when I run:

pip install scipy-0.15.1-cp33-none-win_amd64.whl

I get the following error:

scipy-0.15.1-cp33-none-win_amd64.whl is not supported wheel on this platform

I would like to know what the problem is?


Change the filename to scipy-0.15.1-cp33-none-any.whl and then run this command:

pip install scipy-0.15.1-cp33-none-any.whl

It should work :-)


During Tensorflow configuration I specified python3.6 . But default python on my system is python2.7 . Thus pip in my case means pip for 2.7. For me

pip3 install /tmp/tensorflow_pkg/NAME.whl

did the trick.


For me, it worked when I selected the correct bit of my Python version, NOT the one of my computer version.

Mine is 32bit, and my computer is 64bit. That was the problem and the 32bit version of fixed it.

To be exact, here is the one that I downloaded and worked for me:

mysqlclient-1.3.13-cp37-cp37m-win32.whl

Once again, just make sure to chose your python version of bits and not your system one.


I am using Python2.7 and Windows 64-bit system. I was getting the same error for lxml-3.8.0-cp27-cp27m-win_amd64.whl while doing pip install lxml-3.8.0-cp27-cp27m-win_amd64.whl Run pip install lxml and it auto-detected and successfully installed the win32 version (though my system is Windows-64bit)

C:\Python27>pip install lxml
Collecting lxml
  Downloading lxml-3.8.0-cp27-cp27m-win32.whl (2.9MB)
    100% |################################| 2.9MB 20kB/s
Installing collected packages: lxml
Successfully installed lxml-3.8.0

So, I will go with @1man's answer.


I had similar problem, installing a 64-bit version for python27 on windows 7 64bit. Everything was up-to-date, yet I got the message

scipy-0.18.1-cp27-cp27m-win_amd64.whl is not supported wheel on this platform

Than I donwloaded a 32-bit whl and it worked.

pip install scipy-0.18.1-cp27-cp27m-win32.whl

I suspect that the problem was probably that I dont have an AMD processor, rather and intel one, and the scipy 64bit version says amd64 in the end.


I had the same problem

I downloaded latest pip from https://pypi.org/project/pip/#files

and then.... pip install << downloaded file location >>

then pygame and kivy installation worked... Thanks...!!


I tried a bunch of the stuff above to no avail.

Previously, I upgraded to pip 18.1.

Kept getting the following error when trying (for pyFltk):

from fltk import *

ImportError: DLL load failed %1 is not a valid Win32 Application

I was getting all sorts of errors about the *.whl file not being supported by my machine or something about being unable to remove the correct files from distutils.

Went back to my notes and they indicated that the whl file:

pyFltk-1.3.3.1-cp36-cp36m-win_amd64.whl but I kept getting the error above sooo...

it required pip 9.0.3 to install.

I downgraded my version of pip to 9.0.3

pip install pip=9.0.3

and the .whl file installed properly.

This is also related to: here


I tried to install scikit-image but got the following error when I tried to install the .whl file even though my installed version of python was 2.7 32-bit. scikit_image-0.12.3-cp27-cp27m-win32.whl is not a supported wheel on this platform.

However I also got this message before the error message:

You are using pip version 7.1.0, however version 8.1.2 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.

I then ran the command python -m pip install --upgrade pip and then pip install scikit_image-0.12.3-cp27-cp27m-win32.whl worked fine. I hope this can help someone!


I'm deploying Flask using Python34 on IIS. The following steps worked for me

  1. Upgrade pip
  2. Install the wheel file for numpy
  3. pip install pandas

If you are totally new to python read step by step or go directly to 5th step directly. Follow the below method to install scipy 0.18.1 on Windows 64-bit , Python 64-bit . Be careful with the versions of 1. Python 2. Windows 3. .whl version of numpy and scipy files 4. First install numpy and then scipy.

pip install FileName.whl
  1. ForNumpy: here ForScipy: http://www.lfd.uci.edu/~gohlke/pythonlibs/#scipy

Be aware of the file name ( what I mean is check the cp no). Ex :scipy-0.18.1-cp35-cp35m-win_amd64.whl To check which cp is supported by your pip , go to point No 2 below.

If you are using .whl file . Following errors are likely to occur .

  1. You are using pip version 7.1.0, however version 8.1.2 is available.

You should consider upgrading via the 'python -m pip install --upgrade pip' command

  1. scipy-0.15.1-cp33-none-win_amd64.whl.whl is not supported wheel on this platform

For the above error : start Python(in my case 3.5), type : import pip print(pip.pep425tags.get_supported())

output :

[('cp35', 'cp35m', 'win_amd64'), ('cp35', 'none', 'win_amd64'), ('py3', 'none', 'win_amd64'), ('cp35', 'none', 'any'), ('cp3', 'none', 'any'), ('py35', 'none', 'any'), ('py3', 'none', 'any'), ('py34', 'none', 'any'), ('py33', 'none', 'any'), ('py32', 'none', 'any'), ('py31', 'none', 'any'), ('py30', 'none', 'any')]

In the output you will observe cp35 is there , so download cp35 for numpy as well as scipy. Further edits are most welcome !!!!



It's better to check the version of python where you want to install your package. If the wheel was built for python3 and your python version is python2.x you may get this error. While installing using pip follow this convention

python2 -m pip install XXXXXX.whl #if .whl is for python2
python3 -m pip install XXXXXX.whl #if .whl is for python3

Simply if you have more than one python on your system for example 2.7/3.4/3.5 , it's necessary you check your installation path. :)


Things to check:

  1. You are downloading proper version like cp27 (means for python 2.7) cp36(means for python 3.6).
  2. Check of which architecture (32 bit or 64 bit) your python is? (you can do it so by opening python idle and typing)

    import platform  
    platform.architecture()

Now download the file of that bit irrespective of your system architecture.

  1. Check whether you're using the correct filename (i.e it should not be appended with (1) which might happen if you download the file twice)

  2. Check if your pip is updated or not. If not you can use

    python -m pip install -upgrade pip


try conda for installation, seems to resolve versions on the fly:
conda install scikit-learn


cp33 means CPython 3.3 you need scipy‑0.15.1‑cp27‑none‑win_amd64.whl instead.





pip