ruby-on-rails - working - update bundler




Error while Bundle install (2)

As it messaged in comments before, -- --with-system-v8 postfix letting bundle succesfully:

gem install libv8 -v '3.16.14.7' -- --with-system-v8

MAC OS X: I am using bundle install to install gem for my app but getting error below I am using ruby '1.9.3' ,gem 'rails', '3.2.12' in my gem file . .

    Installing gmail_xoauth 0.4.1
    Installing omniauth 1.3.1
    Installing httparty 0.13.7
    Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

/Users/userx/.rvm/rubies/ruby-1.9.3-p551/bin/ruby -r
./siteconf20170420-57041-h8rx0n.rb extconf.rb
creating Makefile
Compiling v8 for x64
Using python 2.7.12
Using compiler: /usr/bin/c++ (clang version 8.1.0)
../src/bignum.cc:761:7: error: variable 'i' is incremented both in the loop
header and in the loop body [-Werror,-Wfor-loop-analysis]
    ++i;
      ^
../src/bignum.cc:756:72: note: incremented here
  for (int i = other.used_digits_ + exponent_diff; i < used_digits_; ++i) {
                                                                       ^
1 error generated.
make[1]: ***
[/Users/userx/.rvm/gems/ruby-1.9.3-p551/gems/libv8-3.16.14.7/vendor/v8/out/x64.release/obj.target/preparser_lib/src/bignum.o]
Error 1
make: *** [x64.release] Error 2
/Users/userx/.rvm/gems/ruby-1.9.3-p551/gems/libv8-3.16.14.7/ext/libv8/location.rb:36:in
`block in verify_installation!': libv8 did not install properly, expected binary
v8 archive
'/Users/userx/.rvm/gems/ruby-1.9.3-p551/gems/libv8-3.16.14.7/vendor/v8/out/x64.release/obj.target/tools/gyp/libv8_base.a'to
exist, but it was not found (Libv8::Location::Vendor::ArchiveNotFound)
from
/Users/userx/.rvm/gems/ruby-1.9.3-p551/gems/libv8-3.16.14.7/ext/libv8/location.rb:35:in
`each'
from
/Users/userx/.rvm/gems/ruby-1.9.3-p551/gems/libv8-3.16.14.7/ext/libv8/location.rb:35:in
`verify_installation!'
from
/Users/userx/.rvm/gems/ruby-1.9.3-p551/gems/libv8-3.16.14.7/ext/libv8/location.rb:26:in
`install!'
    from extconf.rb:7:in `<main>'
GYP_GENERATORS=make \
    build/gyp/gyp --generator-output="out" build/all.gyp \
                  -Ibuild/standalone.gypi --depth=. \
                  -Dv8_target_arch=x64 \
-S.x64  -Dv8_enable_backtrace=1
-Dv8_can_use_vfp2_instructions=true -Darm_fpu=vfpv2
-Dv8_can_use_vfp3_instructions=true -Darm_fpu=vfpv3 -Dwerror=''
CXX(target)
/Users/userx/.rvm/gems/ruby-1.9.3-p551/gems/libv8-3.16.14.7/vendor/v8/out/x64.release/obj.target/preparser_lib/src/allocation.o
CXX(target)
/Users/userx/.rvm/gems/ruby-1.9.3-p551/gems/libv8-3.16.14.7/vendor/v8/out/x64.release/obj.target/preparser_lib/src/atomicops_internals_x86_gcc.o
CXX(target)
/Users/userx/.rvm/gems/ruby-1.9.3-p551/gems/libv8-3.16.14.7/vendor/v8/out/x64.release/obj.target/preparser_lib/src/bignum.o

extconf failed, exit code 1

Gem files will remain installed in
/Users/userx/.rvm/gems/ruby-1.9.3-p551/gems/libv8-3.16.14.7 for inspection.
Results logged to
/Users/userx/.rvm/gems/ruby-1.9.3-p551/extensions/x86_64-darwin-16/1.9.1/libv8-3.16.14.7/gem_make.out

An error occurred while installing libv8 (3.16.14.7), and Bundler
cannot continue.
Make sure that `gem install libv8 -v '3.16.14.7'` succeeds before bundling.
➜  coffeesender git:(sendoso-app) ✗ 

I tried to install last suggest command in error gem install libv8 -v '3.16.14.7' but another error Error installing libv8 ERROR: Failed to build gem native extension


First add the gem gem 'libv8', '~> 3.16', '>= 3.16.14.7' into the gem file or run gem install libv8 -v 3.16.14.7.

Once you have installed or added the gen, run bundle install.

the gem file will be added successfully.





bundler