java - studio - IntelliJ inspection gives “Cannot resolve symbol” but still compiles code




intellij cannot resolve symbol string (20)

Platform: IntelliJ Community Edition 10.0.3
SDK: jdk1.6.0_21
OS: Windows 7

So I have a strange situation with IntelliJ that has me completely stumped. I setup a Maven project and add log4j as a dependency in the pom.xml file. The IDEA inspections run fine and my unit tests all compile and run.

I then added hunnysoft's jmime library to my local maven repository using the mvn install:install-file as follows.

mvn install:install-file -Dfile=jmime.jar -DgroupId=jmime \
-DartifactId=jmime -Dversion=3.1.1e -Dpackaging=jar

Maven installed the jar file just fine into my local repository.

I then went into IntelliJ's Settings => Maven => Repository Services and Updated my local repository (so that IntelliJ would reindex the repository contents).

Finally, I added the following dependency to my pom.xml file (just above the log4j dependency).

<dependency>
    <groupId>jmime</groupId>
    <artifactId>jmime</artifactId>
    <version>3.1.1e</version>
</dependency>

I now create a new class as follows:

package com.stackoverflow.question;

import org.apache.log4j.Logger;
import com.hunnysoft.jmime.ByteString;
import com.hunnysoft.jmime.Field;
import com.hunnysoft.jmime.FieldBody;

public class StackOverflowQuestion {
    public Field create(String name, String text) {
        Logger.getLogger(getClass()).debug("create entered");
        FieldBody body = new FieldBody();
        body.setText(new ByteString(text));
        Field field = new Field();
        field.setFieldName(name);
        field.setFieldBody(body);
        return field;
    }
}

Now for the weirdness. IntelliJ's intention mechanism picks up and recognizes the Logger import in the maven pom file just fine. However, for all of the hunnysoft imports it reports: "Cannot resolve symbol 'ByteString/Field/FieldBody'", BUT Build => Compile 'StackOverflowQuestion.java' compiles everything correctly and the unit test I created for this class runs fine (though the intentions mark the call to create() as a problem area too).

So somewhere, somehow IntelliJ is ignoring the jmime.jar file for the intention subsystem. I'm confused because the log4j dependency works fine and everything compiles and runs fine. F12 ("Go To Declaration") works on the Logger import, but breaks on all the jmime imports.

Oh, one other thing, if I go to the 'Packages' view in the "Projects" window the "com.hunnysoft.jmime" package appears and I can see ALL of the classes I imported in the code snippet above under "Libraries". Removing the above dependency from the pom.xml file causes this package to disappear and the compilation breaks.

It appears that the inspection's classpath is broken, but there does not seem to be a setting for this anywhere in the Settings => Intentions | Compiler areas (not that I expected any such settings, I believe the IDEA should already know the correct classpath based on the pom file and JDK).

As a final experiment I created a brand new standard J2SE application project (without using maven) and added the jmime.jar file directly to the project as one of its libraries. I run into exactly the same problems as described above in this new project.

Here is the MANIFEST.MF from the jmime jar file.

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.5.4
Created-By: 10.0-b23 (Sun Microsystems Inc.)

Name: com/hunnysoft/jmime/
Sealed: true
Specification-Title: Hunny JMIME
Specification-Version: 3.1.1
Specification-Vendor: Hunny Software, Inc.
Implementation-Title: com.hunnysoft.jmime
Implementation-Version: 3.1.1E
Implementation-Vendor: Hunny Software, Inc.

I don't see anything unusual in this jar file.

My best guess is that perhaps the problem might be a missing dependency issue. But AFAIK jmime is supposed to be self contained (JarAnalyzer doesn't come up with anything, but I'm not sure it would if a dependency jar is missing).

So, anyone have any IDEAs?


  1. Open "Settings"
  2. Search for "Maven"
  3. Click on "Ignored Files" under "Maven"
  4. Uncheck the pom.xml files contains the missing dependencies
  5. Click "OK"
  6. Click File -> Invalidate Caches/Restart...
  7. Click "Invalidate and Restart"

For Gradle users:

You may need to synchronize your project with your build.gradle file.

You can right-click on your gradle file under the Project pane to do this, but that didn't seem to do anything for me (I suspect a bug in my version). You'll know if this happens because it wont' kick off any IntelliJ tasks that you will be waiting on. Instead, open up the Gradle Tool pane, then click the synchronize (refresh) button. This worked for me where invalidating the cache and restarting did not.

My own circumstance: I was using a Scala project with Gradle and had to do this.


Another thing to check: Be sure that dependencies are not duplicated. In my case I found that a module exhibiting this behavior was misconfigured as follows: it had a dependency on another module, and it had a dependency on a jar produced by that other module. This meant for every symbol referenced in duplicate, and was ambiguous.


First of all you should try File | Invalidate Caches and if it doesn't help, delete IDEA system directory. Then re-import the Maven project and see if it helps.

In some weird cases compiled classes may report wrong info and confuse IDEA. Verify that the classes from this jar report correct names using javap.


For another alternative.

I got this problem also when I used JDK7_07. I tried all answers here (except deleting IDEA System Directory). But, I still got the problem. So what I did it is:

Install newest JDK (it was JDK7_45), and set the Intellij's JDK to the new one, and it works.


Has a fixed been published? Appears issue originally affected v11/12 due to a "Compiler overhaul" back in 2013. With discussion on related issues in Jira up to end of 2014. http://youtrack.jetbrains.com/issue/IDEA-98425

Also on Jira IDEA-98425 was marked fixed but unverified (on v12.0.3). None of the following work-around helped resolve this "Unable to Resolve Symbol" issue with Version 13.1.1 on Windows

a. Delete .IdealIC13 folder (Then, File \ Invalidate Caches / Restart)

b. From Maven Projects window,

b.1 mvn -U idea:idea –〉Executing this maven goal suppose to reload the dependencies. This works prev, but since last FRI, executing this maven goal failed as it tried to recompile the project (Of course it fails as "Unable to resolve Symbols", that's what I am trying to fix by running this command in the first place) mvn -version — shows maven version referenced 3.2.5 and that it's working

b.2 Simply right click project, and Reimport

b.3 File \ Invalidate Caches / Restart

c. Tried both Enable & Disable this setting: File -> Settings -> Maven -> Importing -> "Use maven3 to import project"

d. Settings \ Maven \ Multiproject build fail policy = Fail at end (instead of Default)

Nothing works. What's happenning to IntelliJ support on Maven.

https://youtrack.jetbrains.com/issue/IDEA-99302

From JetBeans release history, https://www.jetbrains.com/company/history.jsp

IntelliJ v14 NOV 2014

IntelliJ v13 DEC 2013

I'd assume v12 fixed (although unverified) would be incorporated in subsequent releases. Any one having similar problems with which IntelliJ version? Please share your experience. IntelliJ maven support seems broken.


If your maven project is a multi-module project, check if some of the modules are ignored by intellij.

  1. Click on View -> Tool Windows -> Maven Projects, and check if some modules are ignored(Ignored modules are in grey, e.g. gs-multi-module in the following image).

  1. Right click on the ignored module and choose Unignore Projects.

Then wait for intellij to finish indexing, after which it will work.


In my case, I am trying to open a spring boot project from IntellijIdea got the same issue like unable to import all spring related files.

Then I did:

File -> Close Project -> Import Project -> Import from external model -> Choose Gradle -> Next -> Select the project from file location -> Finish

Now everything working fine as expected.

I have seen many answers here but I finally found this solution. It may use for someone like me.


In my case, this problem showed up after I checked out a big restructure of the files in my maven project. At the time of check out I had some of my own unchecked in changes still active. The changes weren't to any of the files being restructured as far as I could tell.

Invalidating the cache and restarting didn't work for me. What did work was:

  • reverting the changes I had made before the big restructure checkout
  • reimporting all the maven modules

Inconsistent/duplicate module names in project structure was causing this issue for me.

  1. Go to File -> Project Strucutre -> Modules
  2. In Click on modules which have red underline
  3. Got to "Dependencies" tab
  4. Make sure the dependencies which are red actually exist in dependency list. If not, rename them to match existing dependency names

This can happen when IntelliJ doesn't shut down properly and thus cannot properly save renamed module names.


My Project Structure:

src -> main -> scala -> mypackages

What worked:

Right click on the scala folder, and click "Mark Directory as Sources Root".


None of the above solutions solved it for me. I had the same issue where the code compiled fine but IntelliJ showed that it could not find the import. Even though IntelliJ suggested the import in the first place from code completion.

My solution was to move everything to the default package, delete the com.foo.bar package, then create it again and move everything back.


None of the solutions above worked for me. What did was removing the main.iml file manually and it suddenly worked.


One extra step, when I did File -> Invalidate Caches and restarted the IDE, open a project. It popped up a toastbox on the top-right asking me whether to enable auto-import and that solved the problem.


Re-importing the project worked for me. Right Click on Project -> Maven ->Reimport

when I did File -> Invalidate Caches and restarted the IDE,open a project. It showed a dialogue on the top-right "Maven changes detected" and gave an option to import and enable auto-import. Even after importing the project here, I had the same issue. The above step solved the problem.


Remove the :iml file found in java and test folders inside the project and invalidate and restart .

It will ask can I remove the projects . Put Yes. The error will goes off.


Suggested solutions did not work. I had to unignore several projects, by right clicking on the pom => maven => unignore project.

Then after a

mvn clean install -T 6 -DskipTests

in the console, IntelliJ was happy again. No idea how the projects became ignored...


The following trick resolved this issue for me:

  • Right click on the code editor
  • Hover on Maven and expand
  • Click on Reimport

My idea version is 12.0.4


Yes, sounds like you have to create libraries containing the JARs you need and add them as a dependency in your module.


if maven project then just go to settings ->build tools - >maven ->importing. check the checkbox "import maven project automatically". will solve the problem.





intellij-inspections