subversion - svn tigris eclipse




Eclipse sigue pidiendo la contraseña svn (8)

  1. fue a Ventana / Preferencias / Equipo / SVN
  2. configurado en "SVNKit" desde "JavaHL".

Cambié esto a SVNKit, y desde entonces no he tenido problemas.

Cuando intento sincronizar / actualizar mis proyectos con el repositorio SVN, me pide una contraseña. Me vuelve loco, estoy marcando la casilla de verificación "guardar contraseña" y no funciona en absoluto ... es más, no puedo usar una contraseña simple.

Puede que esté relacionado de alguna manera con el proxy de mi empresa, pero los sitios de actualización del complemento Eclipse funcionan bien.

Tengo un directorio de Subversion en mi directorio de datos de aplicación, ¿quizás debería eliminar esto? También puedo proporcionar información adicional, simplemente no sé lo que puede ser relevante.

Estoy usando Subclipse con el proveedor JavaHL y mi versión de Eclipse es 4.4.2 pero tengo el mismo problema en Eclipse 3.7.2


Así que probé todos los métodos que propusiste y no funcionó. La solución para mí fue:

  1. Haga clic derecho en TortoiseSVN
  2. Ajustes
  3. Red
  4. Archivo del servidor de Subversion, botón 'Editar'
  5. Yo añadí:

    [grupos] nombre_grupo = dirección_grupo

    [nombre_grupo] http-proxy-exceptions = proxy_exceptions

    http-proxy-host = proxy_host

    http-proxy-port = número_puerto

    almacenar contraseñas =

donde rellené group_name, group_address, proxy_exceptions, proxy_host, port_number y marque 'sí'.

Espero que funcione para ti.


Esto es lo que funcionó para mí. Fui a Ventana / Preferencias / Equipo y vi que había dos submenús "SVN". No estoy seguro de cómo llegué a este estado, pero es posible que haya instalado tanto Subversion como Subclipse en algún momento.

De todos modos, en el primer submenú SVN, hay una pestaña para el conector SVN. Y en el otro menú SVN, hay una subsección etiquetada como "interfaz SVN". Ambos proporcionan una lista desplegable para seleccionar un conector / interfaz. En mi caso, en el primer menú SVN, el conector SVN se configuró en "SVNKit". En el segundo menú SVN, se configuró en "JavaHL". Cambié esto a SVNKit, y desde entonces no he tenido problemas.


Esto es lo que me acaba de redactar (Mars, subclipse, SVNKit): leí el archivo $ WORKSPACE / .metadata / .log y encontré esto:

!ENTRY org.eclipse.core.runtime 2 0 2015-09-04 09:24:33.282^M
!MESSAGE Authorization infrastructure (org.eclipse.core.runtime.compatibility.auth) not installed.
!STACK 0
java.lang.ClassNotFoundException: org.eclipse.core.internal.runtime.auth.AuthorizationDatabase cannot be found by org.eclipse.core.runtime_3.11.0.v20150405-1723

Duckduck tomó el nombre del paquete org.eclipse.core.runtime.compatibility.auth y lo encontró en el repositorio de Maven , donde descargué el archivo jar, que copié en mi directorio $ ECLIPSE_HOME / dropins. Después de reiniciar Eclipse, no hubo ningún error en el registro, solo me preguntaron una vez mi contraseña maestra. No más diálogos de contraseña molestos desde entonces.


Me enfrenté a un problema similar y la solución siguiente me funcionó: Abra Windows - preferencias - Equipo - SVN y compruebe la interfaz SVN, debería ser cliente como SVNKit en lugar de JavaHL y reinicie eclipse / RAD y funcionará bien.


Ninguna de las respuestas actuales funcionó para mí en el eclipse de neón. Por lo tanto, edité el archivo hash en /.subversion/auth/svn.simple/[filename] Agregué información de contraseñas:

K 15
svn:realmstring
V 51
<https://svn.example.com:443> Subversion Repository
K 8
username
V [length_of_username]
[username[
K 8 
password
V [length_of_password]
[password]
END

Probablemente, la solución más sencilla de probar, y funcionó para nosotros, fue restablecer la contraseña del usuario en su cuenta de SVN. Recientemente hemos actualizado a una versión más reciente de CollabNet SVN y no hemos migrado las cuentas de usuario (si es algo que podríamos haber hecho, podría haber sido bueno).

Hubo dos desarrolladores que tuvieron este problema: un usuario olvidó su contraseña y la cuenta aún no se había creado para el otro usuario. Hubiera sido bueno ver un mensaje de error más descriptivo sobre las credenciales en el comportamiento del servidor.


Puedo proporcionar una solución más que funcione para mí después de probar otras soluciones.

Fue tan fácil como cambiar el combo "Aplicar a" en la ventana emergente de inicio de sesión de "http: // ..." a "Ubicación del repositorio".

He eliminado C: \ Users ... \ AppData \ Roaming \ Subversion \ auth también como comenté.

Versión de Eclipse: Mars.2 Release (4.5.2)

Espero que esto ayude.







svn