proyecto - project structure android studio




¿Cómo “selecciono Android SDK” en Android Studio? (20)

A veces, Android Studio simplemente actúa de manera estúpida y necesita algún tipo de reinicio.

Vaya al archivo settings.gradle que debe contener include ':app'
cámbielo para include ':ap' y sincronizar.
después de la sincronización, cámbielo para include ':app' nuevamente.

Debería estar funcionando bien ahora.

Después de una importación exitosa de un proyecto Eclipse-Android en "Android Studio 1.4", aparece el error

"Seleccione Android SDK"

cuando hago clic en el botón para ejecutar la aplicación en el simulador, pero no encuentro ninguna forma de hacerlo.

Este cuadro de diálogo se abre cuando hago clic en "Ejecutar":

Este es el cuadro de diálogo "estructura del proyecto":

¿Qué debería hacer ahora?


Abra el archivo build.gradle. simplemente agregue un espacio o presione enter. luego sincronizar proyecto. funciona...


Android Support Repository, Android SDK Platform 28 y 3 componentes SDK más no se instalaron ingrese la descripción de la imagen aquí

Como instalé el archivo jdk y está funcionando bien en eclipse y quiero comenzar a trabajar en el estudio de Android, pero cada vez que instalo todo el paquete de sdk manager, no se muestra ninguna instalación, por favor, ayúdenme.


Después de abrir mi proyecto en Android Studio, abrí la versión de la aplicación del archivo build.gradle, ubicado en la carpeta Gradle Scripts del Proyecto. Cuando pasé el puntero del mouse sobre el número de buildToolsVersion, apareció una información sobre herramientas que indicaba que la versión de Android Build Tools necesitaba actualizarse (ver captura de pantalla). Cambié el valor de buildToolsVersion por el identificado por el error (27.0.2) y el problema se resolvió. El error original (seleccione el SDK de Android) desapareció y el proyecto se compiló con éxito nuevamente. Aunque esta solución se mencionó anteriormente, los pasos exactos parecían faltar, así que espero que esto aclare cualquier duda. Supongo que la causa principal de este problema es que se lanzó una nueva versión de las herramientas de compilación, pero Android Studio no activó ninguna notificación, lo que habría indicado que debería solucionarlo manualmente (ya que Android Studio no parece tener capacidad de actualizar internamente este archivo build.gradle), lo que deja al usuario la responsabilidad de encontrar el problema y solucionarlo.


En Android Studio 3 y superior, tanto para Windows, Mac y Linux :

File -> Sync Project with Gradle Files

Resuelto!

O puede hacer esto con la tecla de acceso directo :

Presione ⌘ + Shift + A ( Mac ) o Ctrl + Shift + A ( Windows, Linux ). Luego, "Sync Project with Gradle Files" un Texto de edición y escriba "Sync Project with Gradle Files" . Luego presione doble clic en la opción.

Su problema resuelto! Sincronizará su archivo gradle con su archivo de proyecto, gracias.

**Captura de pantalla : **


En mi caso, descargué un repositorio git para un proyecto de Android. El proyecto requirió la versión 21 sdk mínima y la versión 27 sdk de destino. Cuando intenté ejecutar el proyecto, me dio "Seleccione el error del SDK de Android". Verifiqué que ya había descargado los archivos SDK necesarios.

Para mí, la solución fue "sincronizar el proyecto con Gradle Files"


Esta es la forma más fácil de solucionar este problema:

  • Agregue una línea de comentario al archivo gradle
  • Luego te pedirá que sincronices .
  • Haga clic en ' Sincronizar ahora '

¡Eso es! Terminaste.


Estaba teniendo este problema en todas las versiones de AS 3.0+. La sincronización con gradle no resolvió el problema para mí. La solución de András Klöczl fue lo único que me permitió hacer un poco de codificación. El problema era que cada vez que tenía que hacer una sincronización de Gradle, el problema volvía. Así que tuve que pasar por ese proceso cada vez que quería hacer un cambio en mi build.gradle . Lo que terminó funcionando para mí fue degradar mi versión de 1.2.40 de 1.2.40 a 1.2.30


Haga clic en este ícono sincronizar gradle

o edite cualquiera de sus módulos gradle y luego sincronice


La estructura del menú y las opciones han cambiado ligeramente a partir de Android 3.2.0. Solucioné este error cambiando el Módulo SDK en el siguiente menú:

Archivo> Estructura del proyecto> Módulos> Archivo de aplicación> Pestaña Dependencias> Módulo SDK

Asegúrese de presionar Aplicar para guardar sus cambios.


Me ayudó:

1. close project
2. remove .idea/ folder
3. select "import project (Gradle, Eclipse ADT, etc.)"

Ambiente:

Android Studio 3.1.3
OS Macos High Sierra 10.13.5

Otras respuestas no funcionan para mí.


Mi problema fue que si cambié el proyecto (por ejemplo, abrí una nueva ventana de Android Studio con un proyecto diferente), se produjo este error.

Entonces leí cada respuesta en esta pregunta y la solución "borrar cachés y abrir el proyecto nuevamente" no fue tan útil en mi caso.

En cambio, descubrí que si la versión del complemento de Kotlin en Android Studio era más baja que en el archivo gradle, el problema aparecía.

Mi configuración fue:

  • Android Studio 3.1.3
  • Complemento Kotlin (en Android Studio) 1.2. 30
  • Versión de Kotlin en el archivo gradle 1.2. 51

¿Qué solucionó el problema?

Actualicé el complemento de Kotlin:

Archivo -> Configuración -> Complementos -> Instalar el complemento JetBrains ...

Luego busque Kotlin y haga clic en Actualizar. Después de la actualización, simplemente reinicie Android Studio y sincronice Gradle.


Presione " ⌘ + Shift + A " en Mac (o " Ctrl + Shift + A " en Windows) y en el texto emergente EditText, escriba " Sync Project with Gradle Files ". Después de eso, haga doble clic en la opción que apareció. Luego sincronizará su SDK de archivos Gradle con el archivo del proyecto.


Presione el primer botón de actualización en la pestaña vertical de gradle en Android Studio a la derecha


Si se proporciona la ruta del SDK de Android y aún enfrenta este problema, es posible que su estudio de Android no esté bien sincronizado, incluso si ha hecho clic en el enlace " Sincronizar ahora ".

Entonces, para volver a sincronizar, vaya al archivo gradle de la aplicación y realice cualquier cambio o simplemente dé un espacio y ahora sincronice nuevamente. Funcionará perfectamente.


Simplemente cambie la versión de las herramientas de compilación a 25.0.3 ... y sincronícelas ahora.


Vaya a: Archivo> Estructura del proyecto> Módulos -> aplicación> Propiedades

elija: Compile la versión 'SDK' = API26 Versión de herramientas de compilación = 27.0.0 Compatibilidad de origen = 1.8 Compatibilidad de destino = 1.8


Vaya al archivo gradle.build y haga clic en sincronizar ahora O haga clic en el icono Sincronizar proyecto con el archivo Gradle

O Vaya a Herramientas -> Android -> Sincronizar proyecto con archivo Gradle


Vaya a Archivo >> ProjectStructure (⌘;). Esto abriría esta ventana y luego seleccionaría el módulo de la aplicación . Luego elija la versión Compile SDK. Elija el último y haga clic en aplicar.


ARREGLO PARA 3.1.2 O VERSIONES NUEVAS

Algunos de mis colegas y yo hemos enfrentado el mismo problema en AS 3.1.2 , pero una sincronización simple no nos ayudó. Para nosotros la solución fue un poco diferente:

  1. Archivo -> Invalidar cachés -> Invalidar
  2. Archivo -> Cerrar proyecto.
  3. Elimine el proyecto de la ventana del selector de proyectos AS.
  4. Salir de Android Studio
  5. Inicie AS y abra el proyecto nuevamente

CONSEJOS ADICIONALES SI SE ENFRENTA A ESTE PROBLEMA CONSTANTEMENTE

Algunos de ustedes enfrentan constantemente este problema y esta "solución" lo soluciona solo temporalmente. En el momento en que comenzamos a recibir este error, utilizamos gradle wrapper 4.6 y Android gradle plugin 3.1.0, pero desde entonces volvimos a gradle 4.4 y lo usamos con el último complemento de Android gradle, y no hemos visto este problema desde entonces.





eclipse-project-file