ruby on rails - Rails 5-Error no detectado: el menú desplegable Bootstrap requiere Popper.js



ruby-on-rails twitter-bootstrap (1)

Por lo tanto, en las últimas horas tuve dificultades para que mi barra de navegación de arranque funcionara en mi aplicación Rails 5.1.3. Sin éxito. Encontré un error de consola diciendo

Error no detectado: el menú desplegable Bootstrap requiere Popper.js

Era consciente de que bootstrap estaba perdiendo el interés por popper.js. Lo agregué al Gemfile

gem 'popper_js', '~> 1.11', '>= 1.11.1'

y no hizo nada. Agregado a la application.js como este

//= require popper

y todavía nada. Después de un tiempo, me topé con la respuesta de Joshua Colvin sobre popper.js en Angular. Después de mover la línea popper en el código, como este

//= require popper
//= require turbolinks
//= require bootstrap

Y lo tengo para trabajar. Quería compartir esto con la comunidad porque es un tema bastante reciente y fue muy difícil encontrar esta solución. Espero que esto ayude a muchos programadores;)


Simplemente agregue require popper antes de turbolinks y bootstrap como dijo en la pregunta

//= require popper
//= require turbolinks
//= require bootstrap




popper.js