ios - program - subir app a app store 2018




Cómo corregir un error de Xcode: no se pudieron localizar los archivos de soporte del dispositivo en el iPhone X(11.1) con Xcode Beta(9.2 9C32c) (3)

Respuesta: Xcode: no se pudieron localizar los archivos de soporte del dispositivo

Bueno, encontré que ninguna de las respuestas cerradas aquí no es completa y sostenible. Así que, aquí vamos.

¡Lo más importante es que no pierda su tiempo y ancho de banda de Internet descargando Xcode solo para resolver este problema que puede hacer dentro de unos pocos MB y un poco de conocimiento de SO!

Paso 1:
El siguiente repositorio de GitHub parece estar actualizado con todos los Support Files necesarios que son útiles para resolver. Y parece que este repositorio se actualiza lo más rápido posible. Compruébalo por ti mismo y estás a medio camino.

https://github.com/filsv/iPhoneOSDeviceSupport

Paso 2:
Seleccione y descargue los archivos de soporte que faltan para su Xcode, de los cuales puede obtener la pista del mensaje de alerta anterior. En mi caso, me informaron que descargue 11.4 (15FCA ... algo) . Así que fui y descargué los últimos archivos de soporte de iOS:

Que estaban en el camino de iPhoneOSDeviceSupport / 11.4 (15F5061c) /

DeveloperDiskImage.dmg
DeveloperDiskImage.dmg.signature

Paso 3:
Y luego colóquelos dentro de la carpeta DeviceSupport que se encuentra en una ruta relacionada con su instalación de Xcode. En mi caso, instalé Xcode 9.2 para que mi ruta a DeviceSupport sea la siguiente:

/Applications/Xcode-9.2.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport

Etapa 4
Coloque los dos archivos que descargó en una carpeta llamada 11.4 (15F5061c) .
Pista: en su caso, asegúrese de darle un nombre después de la versión específica de iOS que descargó los archivos.

Paso 5:
Salga de la aplicación Xcode si ya la había usado anteriormente. Vuelva a abrirlo e intente ejecutar su aplicación en su iPhone (o en iDevice de su intento anterior). Xcode primero te advertirá diciendo algo como lo siguiente:

Preparando el soporte del depurador para iPhone 6s de Randika

Poco después de que se complete (probablemente después de varios intentos para intentar volver a conectar su iPhone a Xcode), podrá ejecutar su aplicación con éxito en su dispositivo preferido.

¿Cómo podrías encontrar este camino? Vaya a la carpeta Aplicaciones, localice el archivo Xcode-xxapp, haga clic con el botón derecho en la aplicación Xcode y seleccione "Mostrar contenido del paquete" de la siguiente manera:

Y luego navegue a la carpeta DeviceSupport dentro de la aplicación Finder de la siguiente manera:

Espero que esto sea de ayuda para cualquiera de ustedes!

¡Aclamaciones!

Hola, sé que hay varias publicaciones en StackOverflow sobre este error (pero ninguna para el nuevo iPhone X): No se pudieron localizar los archivos de soporte del dispositivo.

Este iPhone X (Modelo A1865, A1901, A1902, A1903) ejecuta iOS 11.1 (15B93), que puede no ser compatible con esta versión de Xcode.

Estoy ejecutando la última versión de Xcode (Beta 9.2 9C32c) que no es compatible con el iPhone X (iOS 11.1). El problema es que es un nuevo iPhone, y no hay archivos de configuración más antiguos para hacer el cambio en la mayoría de las publicaciones resueltas.

¿Hay alguna otra solución para este problema, ya que descargar la última versión de Xcode ya es lo que estoy ejecutando, y encontrar los Archivos de configuración para hacer el cambio parece improbable ahora? ¿Alguien tiene esos archivos de configuración o sabe cómo editarlos para engañar a Xcode?


Este error se puede solucionar de 2 maneras.

1.Debes mantenerte actualizado con las últimas versiones de XCode.

2.Puedes arreglarlo sin actualizar al último XCode, en este solo necesitas actualizar el archivo de soporte del dispositivo,

Para actualizar el archivo de soporte del dispositivo solo siga los pasos,

Puede encontrar el archivo de soporte del dispositivo y actualizarlo con los detalles de la ruta a continuación,

Ruta- / Aplicaciones / Xcode9.app / Contenido / Desarrollador / Plataformas / iPhoneOS.platform / DeviceS‌ upport / 11.1

Puede descargar el archivo de soporte del dispositivo desde estos enlaces


Tuve el mismo problema con mi iPhone 8, Xcode Beta 9.2 no era compatible con mi versión de iOS 11.1.

Sin embargo, Xcode 9.1 es compatible con mi versión de iOS 11.1





iphone-x