ios - precio - itunes




La actualización de un dispositivo a iOS 11.2 rompe la compatibilidad con Xcode 9.1 (4)

Cualquiera que tenga este tipo de error cuando la versión del sistema operativo de su dispositivo se actualice y la versión de Xcode no.

Xcode - Versión 9.1 (9B55) Versión del dispositivo - 11.3

Solución:

Encuentra a tus amigos que tienen el último Xcode 9.x

De las siguientes formas puede obtener archivos de soporte del dispositivo

  1. Ir al buscador y buscar

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

  1. Haga clic con el botón derecho en Xcode -> Mostrar contenido del paquete, luego navegue hasta Contenido / Desarrollador / Plataformas / iPhoneOS.platform / DeviceSupport / 11.X Copie el 11.X

Tenga en cuenta que X - serán versiones

También puede descargar desde este enlace - https://github.com/filsv/iPhoneOSDeviceSupport/issues/7

Después de obtener los archivos de soporte del dispositivo, agregue todas las nuevas versiones a su carpeta Xcode DeviceSupport

Reinicie Xcode y ya está listo para depurar :)

Intenté ejecutar mi aplicación en un dispositivo con iOS 11.2 y recibí el siguiente error:

No se pudieron localizar los archivos compatibles con el dispositivo.

Este iPhone 5s (Modelo A1457, A1518, A1528, A1530) está ejecutando iOS 11.2 (15C114), que puede no ser compatible con esta versión de Xcode.

He usado el iPhone 5s (versión 11.1.2) y quiero compilar mi proyecto desde xcode 9.1 (ios 11.1).



Parece que Apple lanzó iOS 11.2 al público sin lanzar Xcode 9.2 todavía (la Mac App Store informa 9.1 como más reciente en el momento de escribir este artículo), que incluye el SDK de iOS 11.2 necesario para apuntar a dispositivos que ejecutan iOS 11.2. Debería poder ejecutar esto en su dispositivo con Xcode 9.2 beta, que puede descargar de la página de descargas para desarrolladores si tiene una cuenta de desarrollador.

EDITAR: Xcode 9.2 ya está disponible públicamente, y puede descargarlo de la Mac App Store


Tengo Xcode9.2 en mi MacBook y 8 en mi MacMini. Así que solo copié el 11.2 DeviceSupport DeveloperDiskImage .dmg y .signature del MacBook al MacMini. Funcionaba bien.





iphone