ruby-on-rails - proyecto - set postgresql rails



La aplicación Rails que usa el adaptador Postgres no puede activar pg (1)

En una aplicación de Rails, con un requisito de pg en su Gemfile:

gem 'pg'

Obtendrás el siguiente error:

Gem::LoadError can't activate pg (~> 0.18), already activated pg-1.0.0. Make sure all dependencies are added to Gemfile.

La pg gema recientemente lanzó la versión 1.0.0 que aún no es compatible con Rails.

Si está en Rails 5, cambie el requisito de pg su Gemfile al siguiente 1 :

gem 'pg', '~> 0.18'

o en los carriles <5, esto:

gem 'pg', '~> 0.11'

Y luego correr

bundle update pg

1 Bundler efectivamente hará exactamente lo mismo con cualquiera de las dos líneas, pero de esta manera igualará exactamente la verificación del tiempo de ejecución del código fuente de Rails, así como la versión emitida por el rails new generador Gemfile de rails new .





ruby-on-rails