asp.net 'system.web.extensions/scripting/scriptresourcehandler' - Implementación de IIS7-duplicar la sección 'system.web.extensions / scripting / scriptResourceHandler'




there duplicate (14)

El problema es porque la piscina por defecto está en .net 4.0 Solución: ingrese a un servidor Administrador IIS. ¡[Ingrese la descripción de la imagen aquí] [1] y cambie la versión del marco! [Ingrese la descripción de la imagen aquí] [2]

Con esto pudes.

----- a través de Google Translate -----

El problema es porque la agrupación está por defecto. Solución Net 4.0: ingrese el Administrador de IIS del servidor para establecer los valores en el lado derecho de los grupos de aplicaciones. [Ingrese la descripción de la imagen aquí] [1] y cambie la versión del marco! [Ingrese la descripción de la imagen aquí] [2]

Esto debería resolver el problema al instalar la administración central de SharePoint 2010

Al intentar implementar un sitio web .net 3.5 en el grupo de aplicaciones predeterminado en IIS7 con la sección de marco establecida en 4.0, obtengo el siguiente error.

Hay una sección duplicada 'system.web.extensions / scripting / scriptResourceHandler' definida.

Comentar fuera de las líneas ofensivas tampoco ayudó. ¿Algún indicador sobre lo que necesito hacer o mirar?


Mi resolución fue algo estúpida.

  • Instalé una copia de .net 3.5

  • Creó otro grupo de aplicaciones y seleccionó .net 3.5 (dice 2.0.5077 en el menú desplegable)

  • Agregué mi sitio web a ese grupo de aplicaciones

  • Reciclado las piscinas viejas y nuevas y el sitio comenzó a funcionar.

Se me ocurrió que no tenía instalado 3.5, a pesar de que las funciones de Windows indicaban que sí, y crear otro grupo de aplicaciones para usar. Espero que esto ayude a otros.



Este mensaje de error parece surgir en varias situaciones.

En mi caso, encima del archivo Web.Config de mi aplicación, tenía un archivo Web.Config adicional en la carpeta raíz (C: \ Inetpub \ www.root). Probablemente dejado allí después de algunas pruebas, lo había olvidado por completo, y no podía averiguar cuál era el problema.

Quitarlo me solucionó el problema.


En mi caso, sucedió después de que convertí la solución completa (con una extensión llamada Target Framework Migrator) a 4.6.2, pero terminé deshaciendo los cambios y volviendo a 3.5 (la solución está versionada por TFS). Para resolver esto, convertí solo el proyecto problemático (que estaba usando IIS Express para ejecutar) a 4.6.2 y luego volví a 3.5.


Si su plan es implementarlo en un IIS que tenga un grupo de aplicaciones ejecutándose en .net 4.0, deberá limpiar el archivo web.config que incluye todas las definiciones de la sección que apuntan a .net 3.5. La razón por la que esto falla es porque estas definiciones de sección ya están incluidas en la raíz web.config en .NET 4.0 (vea% windir% \ microsoft.net \ framework \ v4.0.30319 \ config \ machine.config) que incluye todo el sistema. Extensiones web declaradas ya.

Otra solución rápida es hacer que el grupo de aplicaciones se establezca en 2.0 tal como parece tener su máquina de desarrollo.


En mi caso tuve 2 aplicaciones diferentes compartiendo el mismo grupo de aplicaciones. El primero usaba el marco .net4.5 y el nuevo usaba 2.0. Cuando cambié la segunda aplicación a su propio grupo de aplicaciones, comenzó a funcionar bien sin cambios en el web.config.


Lo he resuelto, siguiendo los siguientes pasos:

  1. Creé un nuevo grupo de aplicaciones en IIS.
  2. Abra la configuración avanzada para el sitio o la aplicación web que tiene este problema.
  3. Y configura el nuevo grupo de aplicaciones.

Aquí tenéis las imágenes de estos pasos:


La solución para mí fue cambiar la versión de .NET framework en los Grupos de aplicaciones de v4.0 a v2.0 para el Grupo de aplicaciones predeterminado:


Mi aplicación era una aplicación ASP.Net3.5 (utilizando la versión 2 del marco). Cuando se crearon las aplicaciones ASP.Net3.5, Visual Studio añadió automáticamente scriptResourceHandler al web.config. Las versiones posteriores de .Net ponen esto en el machine.config. Si ejecuta su aplicación ASP.Net 3.5 utilizando el grupo de aplicaciones de la versión 4 (dependiendo del orden de instalación, este es el grupo de aplicaciones predeterminado), obtendrá este error.

Cuando me mudé a usar el grupo de aplicaciones de la versión 2.0. El error se fue. Luego tuve que lidiar con el error al servir WCF .svc:

Error HTTP 404.17 - No encontrado El contenido solicitado parece ser una secuencia de comandos y no será atendido por el controlador de archivos estáticos

Después de algunas investigaciones, parece que necesitaba registrar el controlador WCF. siguiendo los siguientes pasos:

  1. abrir Visual Studio Command Prompt (como administrador)
  2. navegue hasta "C: \ Windows \ Microsoft.NET \ Framework \ v3.0 \ Windows Communication Foundation"
  3. Ejecutar servicemodelreg -i

Esta es quizás la respuesta equivocada para usted. Pero este fue el primer éxito en Google cuando intenté resolver mi problema. Con eso dicho...

También me ocurrió el mismo mensaje de error, pero cuando intenté ejecutar IIS Express a través de Visual Studio.

Mi problema fue que por error envié mi aplicaciónhost.config a TFS. Más tarde, cuando intenté ejecutar el proyecto en mi computadora portátil después de obtener los últimos confirmaciones. Fue entonces cuando ocurrió el error.

Encontré que la ruta del directorio virtual era incorrecta.

<virtualDirectory path="/" physicalPath="C:\Users\giddan\Documents\Visual Studio 2015\Projects\ProjectName\DeV.ProjectName\DeV.ProjectName.Web" />

Espero que esto ayude a alguien!

Este es mi primer post, así que sé amable :)


Nigromancia.
Si no tiene ningún archivo system.web.extensions config -ections o controlador / entradas de módulo en su web.config, este problema se debe a que usted / alguien más copió un VisualStudio-Project (2013/2015/2017) mientras escondía -archivos sin ocultar .

Debido a eso, no solo copiará .git, sino también .VS , que contiene un archivo de .VS IIS-Express, que apunta a archivos web.config en rutas que no existen (o peor aún, rutas que sí existen). , pero no tienen el mismo contenido) ...

Solución:
Elimine el archivo applicationhost.config en la carpeta .VS.
O simplemente borre la carpeta .VS por completo.
Visual Studio lo volverá a crear.


Si, como yo, necesita apuntar a v4 pero solo puede compilar con .net 3.5, siga las instrucciones here . Simplemente reemplace en su web.config el contenido completo de las <configSections> con:

<configSections>
<sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
  <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
    <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
    <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions,  Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
      <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere"/>
      <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
      <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
      <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
    </sectionGroup>
  </sectionGroup>
</sectionGroup>






asp.net deployment iis-7