laravel - E: El paquete 'mysql-client' no tiene candidato de instalación en la compilación de imágenes php-fpm usando docker compose




docker-compose dockerfile (2)

Tuve el mismo problema en php:7.1-apache . Reemplazar mysql-client con mariadb-client funciona para mí. Gracias.

Soy bastante nuevo en Docker y estoy tratando de aprender más sobre él usando un proyecto laravel, estoy siguiendo este tutorial:

https://www.digitalocean.com/community/tutorials/how-to-set-up-laravel-nginx-and-mysql-with-docker-compose?comment=77842

Ajusté un poco el Dockerfile de lo que tiene el tutorial, pero incluso el archivo del tutorial produce el mismo resultado.

FROM php:7.3-fpm

# Copy composer.lock and composer.json
COPY composer.lock composer.json /var/www/
# Install dependencies
RUN curl -sL https://deb.nodesource.com/setup_10.x | bash - && \
    apt-get update && apt-get install -y mysql-client \


RUN npm install -g npm

# Clear cache
RUN apt-get clean && rm -rf /var/lib/apt/lists/*


# Install extensions
RUN docker-php-ext-install pdo pdo_mysql

# Install composer
RUN curl -sS https://getcomposer.org/installer | php -- --install-dir=/usr/local/bin --filename=composer

# Add user for laravel application
RUN groupadd -g 1000 www
RUN useradd -u 1000 -ms /bin/bash -g www www

# Copy existing application directory contents
COPY . /var/www

# Copy existing application directory permissions
COPY --chown=www:www . /var/www

# Change current user to www
USER www
# Set working directory
WORKDIR /var/www
# Expose port 9000 and start php-fpm server
EXPOSE 9000

CMD ["php-fpm"]

Pero sigo recibiendo el siguiente error cuando ejecuto docker-compose up -d :

E: Package 'mysql-client' has no installation candidate
ERROR: Service 'app' failed to build: The command '/bin/sh -c curl -sL https://deb.nodesource.com/setup_10.x | bash - &&     apt-get update && apt-get install -y mysql-client     nodejs     build-essential     vim     git     curl' returned a non-zero code: 100

¿Me estoy perdiendo de algo?

Esperaba que esto funcionara ya que estoy ejecutando apt-get update antes de instalar mysql-client .

Gracias.


php: 7.3-fpm ahora usa Debian 10 (Buster) como su imagen base y Buster se envía con MariaDB, así que simplemente reemplace mysql-client con mariadb-client debería solucionarlo.





dockerfile