python - wheel - Cómo instalar lxml en Ubuntu




read xml lxml python (6)

Estoy teniendo dificultades para instalar lxml con easy_install en Ubuntu 11.

Cuando $ easy_install lxml obtengo:

Searching for lxml
Reading http://pypi.python.org/simple/lxml/
Reading http://codespeak.net/lxml
Best match: lxml 2.3
Downloading http://lxml.de/files/lxml-2.3.tgz
Processing lxml-2.3.tgz
Running lxml-2.3/setup.py -q bdist_egg --dist-dir /tmp/easy_install-7UdQOZ/lxml-2.3/egg-dist-tmp-GacQGy
Building lxml version 2.3.
Building without Cython.
ERROR: /bin/sh: xslt-config: not found

** make sure the development packages of libxml2 and libxslt are installed **

Using build configuration of libxslt 
In file included from src/lxml/lxml.etree.c:227:0:
src/lxml/etree_defs.h:9:31: fatal error: libxml/xmlversion.h: No such file or directory
compilation terminated.

Parece que libxslt o libxml2 no está instalado. He intentado seguir las instrucciones en http://www.techsww.com/tutorials/libraries/libxslt/installation/installing_libxslt_on_ubuntu_linux.php y http://www.techsww.com/tutorials/libraries/libxml/installation/installing_libxml_on_ubuntu_linux.php sin éxito.

Si intento wget ftp://xmlsoft.org/libxml2/libxml2-sources-2.6.27.tar.gz obtengo

<successful connection info>
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD (1) /libxml2 ... done.
==> SIZE libxml2-sources-2.6.27.tar.gz ... done.
==> PASV ... done.    ==> RETR libxml2-sources-2.6.27.tar.gz ... 
No such file `libxml2-sources-2.6.27.tar.gz'.

Si intento el otro primero, ./configure --prefix=/usr/local/libxslt --with-libxml-prefix=/usr/local/libxml2 a ./configure --prefix=/usr/local/libxslt --with-libxml-prefix=/usr/local/libxml2 y eso fallará eventualmente con:

checking for libxml libraries >= 2.6.27... configure: error: Could not find libxml2 anywhere, check ftp://xmlsoft.org/.

He probado las versiones 2.6.27 y 2.6.29 de libxml2 sin ninguna diferencia.

Sin dejar piedra sin remover, he hecho con éxito sudo apt-get install libxml2-dev , pero esto no cambia nada.


Como @Pepijn comentó en la respuesta de @Druska, en ubuntu 13.04 x64, no hay necesidad de usar lib32z1-dev, zlib1g-dev es suficiente:

sudo apt-get install libxml2-dev libxslt-dev python-dev zlib1g-dev

Después de instalar los paquetes mencionados por AKX todavía tenía el mismo problema. Resuelto con

apt-get install python-dev

Para Ubuntu 12.04.3 LTS (Precise Pangolin) tuve que hacer:

apt-get install libxml2-dev libxslt1-dev

(Note el "1" en libxslt1-dev)

Entonces acabo de instalar lxml con pip / easy_install.


Para Ubuntu 14.04

sudo apt-get install python-lxml

trabajó para mi.


También tuve que instalar lib32z1-dev antes de que lxml compilara (Ubuntu 13.04 x64).

sudo apt-get install lib32z1-dev

O todos los paquetes requeridos juntos:

sudo apt-get install libxml2-dev libxslt-dev python-dev lib32z1-dev

Ya que estás en Ubuntu, no te molestes con esos paquetes fuente. Solo instala esos paquetes de desarrollo usando apt-get.

apt-get install libxml2-dev libxslt1-dev python-dev

Si estás satisfecho con una versión posiblemente más antigua de lxml, podrías probar

apt-get install python-lxml

y que se acabe con eso. :)





easy-install