apache - the - install apr




configure: error: APR no encontrado. Por favor lea la documentacion (4)

Estoy tratando de instalar apache en mi máquina linux. Pero cuando probé ./configure --prefix = /usr/local/apache muestra una configure: error: APR not found. Please read the documentation configure: error: APR not found. Please read the documentation . Intenté instalar apr con yum install apr apr-deve y dice

Package apr-1.4.6-1.fc15.x86_64 already installed and latest version No package apr-deve available.

Nothing to do ¿Qué debo hacer ahora? Por favor, disculpe, soy un novato de LINUX.


En el directorio donde ha instalado la distribución httpd de apache hay un directorio que se llama /srclib

Usted cd en ese directorio cd /srclib . Asegúrate de estar en esa carpeta. Ahora abra su navegador y vaya a http://apr.apache.org/download.cgi y descargue los archivos apr - *. Tar.gz en este directorio.

wget <link>

Descomprima y extráigalos en el directorio srclib después de extraerlos, asegúrese de cambiar el nombre de los directorios apr- * a "apr" y "apr-util", respectivamente. Por ejemplo:

mv apr-1.6.5 apr
mv apr-util-1.6.1 apr-util

Ahora, debería leer los archivos .apr de esa carpeta. Después de eso también le pedirá que apr-util , asegúrese de seguir el mismo procedimiento.

¡Espero que esto ayude!


En realidad tuve que instalar aprutils también ... Así que intenta usar:

sudo apt-get install libapr1-dev libaprutil1-dev

Para mi plataforma de Linux, superé esto descargando el paquete apr-dev usando el administrador de paquetes local:

opkg install libapr-1-dev

Eso fue en Angstrom linux, por lo que su versión de comando probablemente será diferente, reemplazando opkg con apt-get o lo que sea el administrador de paquetes de su distro.


Si instala en apache 2.2 o menos que agregue flag --with-included-apr

Si está utilizando 2.4, puede ir a https://apr.apache.org/download.cgi y descargar las últimas versiones de abril y abril. Desempaquételos y muévalos al archivo fuente de apache en / srclib. Asegúrate de que tengan los nombres apr y apr-util no apr.xxx Luego puedes usar la bandera --with-included-apr