xcode 5: Puis-je créer une application pour ios 5?




créer un identifiant apple sans carte bancaire (4)

Est-il possible de créer une application qui pourrait être exécutée sur iOS 5 appareils iOS 5 avec le nouveau Xcode 5 ? Sur la page de mise à jour du logiciel, dans l'App Store, il y a une mise à jour de Xcode 5 disponible, mais je me demande s'il serait sage de faire la mise à jour de Xcode 5.

Ma principale préoccupation est de savoir si je pouvais toujours créer des applications ciblant iOS 5, et si je pouvais encore travailler sur d'anciens projets ciblant iOS 5 .

J'ai cherché à travers SO, mais il semble qu'il n'y a pas encore beaucoup de ressources connexes. S'il vous plaît jeter un peu de lumière à ce sujet. Merci!


Oui c'est possible, dans la configuration du projet, vous devez sélectionner la bonne cible de déploiement (dans votre cas 5.0). Le seul problème est que vous créez une application avec le nouveau SDK 7.0, de sorte que votre application utilisera la nouvelle expérience utilisateur.


en Préférence xcode5, vous pouvez télécharger le simulator pour iOS 5.0, iOS 5.1, iOS 6.0, iOS 6.1 comme ci-dessous l'image de préférence de téléchargement Xcode:

Après avoir défini la cible de déploiement: -

ici vous obtenez l'option pour tester quel simulatore: -


Oui, vous pouvez toujours faire App compatible avec iOS5

Réglez juste le dans les paramètres de vos projets (onglet Général)

Mais vous devez être conscient que par défaut, XCode utilisera le dernier SDK (7.0), cela signifie que votre application aura la nouvelle conception native iOS7 sur les appareils iOS7


Une chose à noter:

Le simulateur iOS 5 est uniquement disponible en téléchargement si vous utilisez Xcode 5 sous Mountain Lion. Si vous utilisez Mavericks, vous ne pouvez pas le télécharger ou l'utiliser.





xcode5