python installer - Ubuntu exécutant `pip install` donne une erreur 'Les paquets requis suivants ne peuvent pas être construits: * freetype'




5 Answers

Non pip ne va pas installer les dépendances au niveau du système. Cela signifie que pip ne va pas installer RPM (s) ( systèmes basés sur Redhat ) ou DEB ( systèmes basés sur Debian ).

Pour installer les dépendances du système, vous devrez utiliser l'une des méthodes suivantes en fonction de votre système.

Ubuntu / Debian:

apt-get install libfreetype6-dev

Pour rechercher des packages sur des systèmes basés sur Ubuntu / Debian:

apt-cache search <string>

par exemple:

apt-cache search freetype | grep dev

Redhat / CentOS / Fedora:

yum -y install freetype-devel

Pour rechercher des packages sur les systèmes basés sur Redhat / CentOS / Fedora:

yum search <string>

par exemple:

yum search freetype | grep devel

Mac OS X: ( via Homebrew )

brew install freetype

Pour rechercher des packages sur des systèmes basés sur Mac OS X:

brew search <string>

par exemple:

brew search freetype
windows librairie

Lors de l' pip install -r requirements.txt , j'obtiens l'erreur suivante lors de l'installation de matplotlib :

REQUIRED DEPENDENCIES AND EXTENSIONS
                 numpy: yes [not found. pip may install it below.]
              dateutil: yes [dateutil was not found. It is required for date
                        axis support. pip/easy_install may attempt to
                        install it after matplotlib.]
               tornado: yes [tornado was not found. It is required for the
                        WebAgg backend. pip/easy_install may attempt to
                        install it after matplotlib.]
             pyparsing: yes [pyparsing was not found. It is required for
                        mathtext support. pip/easy_install may attempt to
                        install it after matplotlib.]
                 pycxx: yes [Couldn't import.  Using local copy.]
                libagg: yes [pkg-config information for 'libagg' could not
                        be found. Using local copy.]
              freetype: no  [pkg-config information for 'freetype2' could
                        not be found.]

...

The following required packages can not be built:

                    * freetype

Ne devrait pas pip install -r requirements.txt installe aussi freetype? Comment freetype doit-il être installé dans Ubuntu 12.04 pour qu'il fonctionne avec matplotlib ?




Une solution de contournement consiste à faire sudo apt-get install pkg-config que j'ai trouvé dans ce problème de github .




Cette commande va télécharger toutes les dépendances.

Pour python 2.x

sudo apt-get install python-matplotlib

Pour python 3.x

sudo apt-get install python3-matplotlib

Après l'installation, vous pouvez essayer

(sudo) pip install matplotlib



J'utilise Mint aucune de ces réponses a travaillé pour moi, je devais:

sudo apt-get install build-essential g++



Cette commande sudo apt-get install libfreetype6-dev échoué pour moi sur Ubuntu 16.04,
The following packages have unmet dependencies: libfreetype6-dev : Depends: libfreetype6 (= 2.6.1-0.1ubuntu2) but 2.6.1-0.1ubuntu2.3 is to be installed

J'ai donc téléchargé freetype installé depuis la source , crédit à ce guide

$ tar -xvjf freetype-x.y.tar.bz2  # extract the downloaded version file
$ cd freetype-x.y/ 
$ ./configure
$ make
$ sudo make install 

commuté à virtualenv et pip install matplotlib et tout fonctionne.




Related