with - eclipse android 2018




Impossible de mettre à jour le plug-in ADT dans Eclipse vers la version 23.0.0 ou ultérieure (5)

Je suis débutant en programmation Android. Mon problème est que je ne peux pas mettre à jour ADT. Le problème a commencé lorsque, après un long moment, j'ai mis à jour dans Android SDK Manager les outils de SDK Android. J'essayais ensuite d'importer un projet dans l'espace de travail. Mais je ne pouvais pas importer cela, car chaque fois que je cliquais sur le bouton Terminer, rien ne se passait. Ensuite, j'ai fermé Eclipse et l'ai ouvert à nouveau, et m'a montré l'erreur suivante:

J'ai cliqué sur Vérifier les mises à jour, mais rien n'a été trouvé. J'ai trouvé une URL Internet. J'ai donc cliqué sur Aide -> Installer un nouveau logiciel ...--> Ajouter -> et collé cette URL. Lorsque j'ai cliqué sur Suivant, il m'a montré la liste des éléments que je voulais installer et également une erreur:

Cannot complete the install because of a conflicting dependency.
 Software being installed: Tracer for OpenGL ES 23.0.0.1245622 (com.android.ide.eclipse.gldebugger.feature.feature.group 23.0.0.1245622)
 Software currently installed: Tracer for OpenGL ES 21.0.0.v201210310015-519525 (com.android.ide.eclipse.gldebugger.feature.group 21.0.0.v201210310015-519525)
Only one of the following can be installed at once: 
Tracer for OpenGL ES 23.0.0.1245622 (com.android.ide.eclipse.gldebugger 23.0.0.1245622)
Tracer for OpenGL ES 21.0.0.v201210310015-519525 (com.android.ide.eclipse.gldebugger 21.0.0.v201210310015-519525)
Cannot satisfy dependency:
From: Tracer for OpenGL ES 23.0.0.1245622 (com.android.ide.eclipse.gldebugger.feature.feature.group 23.0.0.1245622)
To: com.android.ide.eclipse.gldebugger [23.0.0.1245622]
Cannot satisfy dependency:
From: Tracer for OpenGL ES 21.0.0.v201210310015-519525 (com.android.ide.eclipse.gldebugger.feature.group 21.0.0.v201210310015-519525)
To: com.android.ide.eclipse.gldebugger [21.0.0.v201210310015-519525]

J'ai aussi lu quelque part, que je devrais essayer de remplacer le dossier plugins par le dossier plugins mis à jour, alors j'ai essayé de renommer le dossier "plugins" du dossier Eclipse en "pluginsx" et de coller le nouveau dossier téléchargé du site . Après cela, je ne pouvais plus ouvrir l’Eclipse.

Ce site traite également du même problème que moi et il existe une réponse qui est acceptée comme solution à la question. J'ai donc aussi essayé de download et de copier ces 3 choses dans des dossiers mentionnés dans le commentaire ci-dessous, mais j'ai toujours le même problème, rien n'a changé.

Alors maintenant, je n'ai aucune idée de comment résoudre ce problème. Quelqu'un peut-il m'aider s'il-vous-plaît?

Merci d'avance.


Aide -> Installer un nouveau logiciel -> Qu'est-ce qui est déjà installé?

Sélectionnez ensuite "Android DDMS, Outils de développement Andoid, Android Hierarcy Viewer, Outils de développement natifs Android, Android Traceview, Tracer pour OpenGL ES" et cliquez sur Désinstaller.

Après toute cette étape, essayez Ajouter un lien ( URL ) et le nom est ADT Plugin. Ce lien obtiendra le dernier plugin ADT. De cette façon, vous réinstallez l'ADT.


Aucune de ces "mises à jour" à elles seules ne fonctionnait pour moi.

La solution que j'ai utilisée est de désinstaller ADT (à partir de la désinstallation d'Android ADT).

Help > About Eclipse > Installation Details

Sélectionnez tous les modules Android (préfixés par com.android.ide ...)

et supprimez-les (Désinstaller ...) et rajoutez les bibliothèques à partir du

help > Install new software

Comme indiqué ci-dessus ....


Je ne pouvais pas désinstaller les anciens plug-ins ADT à partir de la page 'Aide-> Détails de l'installation` car le bouton' Désinstaller ... 'était désactivé lorsque j'ai sélectionné l'un des modules.

De plus, le paquet ADT n'étant plus disponible au téléchargement, la réinstallation n'était pas une option.

Ce qui a fonctionné pour moi a été d'installer l'environnement de base Eclipse à l'aide du programme d'installation Eclipse à partir d' here . Dans le programme d'installation, j'ai sélectionné "Mode avancé ..." dans le menu hamburger, puis uniquement la "plate-forme Eclipse" à installer, c'est-à-dire uniquement les outils principaux. Je pense que cela n’est possible qu’avec l’installateur.

Après avoir installé eclipse, j'ai installé tous les plugins ADT en utilisant "Aide-> Installer un nouveau logiciel" et en utilisant le lien URL .

YMMV, mais cela a fonctionné pour moi.


L'installation d'ADT est un problème majeur, spécialement lors de la mise à jour. De plus, installer ADT en fournissant le lien direct est parfois difficile. Eclipse se bloque souvent en affichant "Calcul des besoins et des dépendances".

Je trouvais parfois plus simple de commencer par désinstaller tous les 7 composants:

-Android DDMS
Outils de développement andoid
-Android Hierarcy Viewer
-Android Native Development Tools
-Android Traceview
-Tracer pour OpenGL ES
-Google App Engine Tools pour Android (si installé)

Ensuite, téléchargez le site .

Installer l'archive à partir de Aide-> Installer un nouveau logiciel-> Ajouter-> Archiver
Sélectionnez le fichier ZIP téléchargé, nommez-le et suivez le processus d'installation standard.


cette solution fonctionne. !!!!!!!

Ouvrez eclipse> Aide> à propos de eclipse> Installation

désinstaller le composant qui est inclus dans le fichier .zip que vous avez téléchargé. télécharger comme ci-dessous.

(crédit à m.zakimark

Je trouvais parfois plus simple de commencer par désinstaller tous les 7 composants:

-Android DDMS -Andoid Outils de développement -Android Hierarcy Viewer -Android Outils de développement natifs -Android Traceview -Tracer pour OpenGL ES -Outils Google App Engine pour Android (si installé)

Ensuite, téléchargez le site .

Installer l'archive à partir de Aide-> Installer un nouveau logiciel-> Ajouter-> Archiver Sélectionnez le ZIP téléchargé, nommez-le et suivez le processus d'installation standard.





eclipse-adt