iphone - telecharger - Comment définir la version de xcode comme valeur par défaut dans mon mac?




xcode old version (4)

À l’heure actuelle, j’ai xcode 6.0 (version bêta) comme version par défaut de mon xcode.

Aujourd'hui, j'ai installé xcode 6 depuis l'App Store mais je souhaite définir xcode 6 comme version par défaut.

Comment puis-je le définir?

Merci d'avance.


Ça devrait être facile.

Solution 1:

  • Cliquez avec le bouton droit de la souris (ou Ctrl + Clic) sur le fichier de projet Xcode ( .xcodeproj ).
  • Survolez «Ouvrir avec» et vous trouverez toutes les applications Xcode du répertoire Applications répertoriées.

  • Maintenant, maintenez la touche Option enfoncée pour que le menu «Ouvrir avec» devienne «Toujours ouvrir avec».
  • Continuez à maintenir Option et sélectionnez la version de Xcode que vous souhaitez définir comme version par défaut pour ce fichier.

Solution 2 :

Un autre moyen d'appliquer cette modification à tous les fichiers similaires consiste à cliquer sur "Obtenir des informations", puis à apporter les modifications nécessaires dans la section "Ouvrir avec".


Cela fonctionne pour moi. J'utilise la CLI de vanille titane.

Basculez vers la version de Xcode souhaitée, puis ios

sudo xcode-select -switch /path/to/Xcode.app/Contents/Developer/

ti configuration ios


Pas directement lié, mais je suppose que la plupart d’entre vous trouveraient cela utile. Voici un lien montrant la FAQ en ligne de commande.

Les 2 commandes les plus utiles sont.

  1. Imprimer la version de Xcode actuellement utilisée par mes outils

xcode-select --print-path

  1. Sélectionnez le Xcode par défaut pour vos outils de ligne de commande.

sudo xcode-select -switch Xcode.app

Exemple: sudo xcode-select -switch /Applications/Xcode5.1.1/Xcode.app


Si vous travaillez beaucoup dans les versions actuelle et bêta de Xcode, exécutez sudo xcode-select --switch /Applications/Xcode.app pour sélectionner le xcode par défaut et renommer le bêta Xcode en XcodeBeta.app ou Xcode10.app .

Chaque fois que vous souhaitez mettre à niveau, il suffit de renommer le Xcode et de redémarrer le terminal.





xcode